summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-06-17 18:29:43 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-06-17 18:29:43 +0000
commitb5b97da8dc819a3c1ab01c6afa7023b47fc4f92a (patch)
tree9a76a729f616d5d3034f47b1f68b437a7b92a41b /dev-embedded/ponyprog/files
parentMigrating away from deprecated postgres virtuals (diff)
downloadgentoo-2-b5b97da8dc819a3c1ab01c6afa7023b47fc4f92a.tar.gz
gentoo-2-b5b97da8dc819a3c1ab01c6afa7023b47fc4f92a.tar.bz2
gentoo-2-b5b97da8dc819a3c1ab01c6afa7023b47fc4f92a.zip
Respect CC, CXX and LDFLAGS wrt #317767 by Kacper Kowalik. Drop unnecessary || die from pkg_setup wrt #317769.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-embedded/ponyprog/files')
-rw-r--r--dev-embedded/ponyprog/files/ponyprog-2.07a-build.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-embedded/ponyprog/files/ponyprog-2.07a-build.patch b/dev-embedded/ponyprog/files/ponyprog-2.07a-build.patch
new file mode 100644
index 000000000000..00494f487fe1
--- /dev/null
+++ b/dev-embedded/ponyprog/files/ponyprog-2.07a-build.patch
@@ -0,0 +1,32 @@
+Respect LDFLAGS, CC, CXX
+
+http://bugs.gentoo.org/show_bug.cgi?id=317767
+
+--- Makefile
++++ Makefile
+@@ -331,7 +331,7 @@
+ prps: $(PRPS)
+
+ $(PROG): $(OBJS)
+- $(CXX) -o $@ $(OBJS) $(LDFLAGS)
++ $(CXX) $(CFLAGS) $(LDFLAGS) -o $@ $(OBJS) $(LIBDIR) $(LIBS)
+
+ %.o: %.cpp
+ $(CXX) $(CFLAGS) -c $< -o $@
+--- v/Config.mk
++++ v/Config.mk
+@@ -35,8 +35,6 @@
+ #---------------------------------------------------------------------
+ # Tools used in the makefile execution
+ #---------------------------------------------------------------------
+-CC = gcc
+-CXX = g++
+
+ #---------------------------------------------------------------------
+ # VPATH for dependencies on header files
+@@ -297,5 +295,3 @@
+ #---------------------------------------------------------------------
+ # LINK/LOAD options
+ #---------------------------------------------------------------------
+-LDFLAGS = $(LIBDIR) $(LIBS)
+-