summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2007-05-13 20:42:28 +0000
committerAlfredo Tupone <tupone@gentoo.org>2007-05-13 20:42:28 +0000
commit022f80967a144d89bb5feb73f02817d4333fdd02 (patch)
treed6b7211e5f2de7dc6d7bc0fb509e65af8a5baa24 /dev-games
parentPunt old version (diff)
downloadgentoo-2-022f80967a144d89bb5feb73f02817d4333fdd02.tar.gz
gentoo-2-022f80967a144d89bb5feb73f02817d4333fdd02.tar.bz2
gentoo-2-022f80967a144d89bb5feb73f02817d4333fdd02.zip
Fixing bug #148332
(Portage version: 2.1.2.2)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/KXL/ChangeLog11
-rw-r--r--dev-games/KXL/KXL-1.1.7-r1.ebuild28
-rw-r--r--dev-games/KXL/files/KXL-1.1.7-amd64.patch95
-rw-r--r--dev-games/KXL/files/digest-KXL-1.1.7-r13
4 files changed, 135 insertions, 2 deletions
diff --git a/dev-games/KXL/ChangeLog b/dev-games/KXL/ChangeLog
index 4d3ff5831907..92b125e5a68a 100644
--- a/dev-games/KXL/ChangeLog
+++ b/dev-games/KXL/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-games/KXL
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/KXL/ChangeLog,v 1.7 2006/10/21 00:18:23 nyhm Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/KXL/ChangeLog,v 1.8 2007/05/13 20:42:28 tupone Exp $
+
+*KXL-1.1.7-r1 (13 May 2007)
+
+ 13 May 2007; Tupone Alfredo <tupone@gentoo.org>
+ +files/KXL-1.1.7-amd64.patch, +KXL-1.1.7-r1.ebuild:
+ Fixing bug #148332 by Pacho Ramos
+ Patch are from debian. It regards 64bit, sound and autorepeat
21 Oct 2006; Tristan Heaven <nyhm@gentoo.org> KXL-1.1.7.ebuild:
HOMEPAGE update
diff --git a/dev-games/KXL/KXL-1.1.7-r1.ebuild b/dev-games/KXL/KXL-1.1.7-r1.ebuild
new file mode 100644
index 000000000000..e7e4c42d7dcc
--- /dev/null
+++ b/dev-games/KXL/KXL-1.1.7-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/KXL/KXL-1.1.7-r1.ebuild,v 1.1 2007/05/13 20:42:28 tupone Exp $
+
+inherit eutils
+
+DESCRIPTION="Development Library for making games for X"
+HOMEPAGE="http://kxl.orz.hm/"
+SRC_URI="http://kxl.hn.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libX11"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-m4.patch \
+ "${FILESDIR}"/${P}-amd64.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog README
+}
diff --git a/dev-games/KXL/files/KXL-1.1.7-amd64.patch b/dev-games/KXL/files/KXL-1.1.7-amd64.patch
new file mode 100644
index 000000000000..ec4b141d2a3e
--- /dev/null
+++ b/dev-games/KXL/files/KXL-1.1.7-amd64.patch
@@ -0,0 +1,95 @@
+--- src/KXLsound.c.old 2007-05-13 21:59:27.000000000 +0200
++++ src/KXLsound.c 2007-05-13 22:09:19.000000000 +0200
+@@ -4,6 +4,9 @@
+ #include <sys/ioctl.h>
+ #include <sys/time.h>
+ #include <linux/soundcard.h>
++#include <stdlib.h>
++#include <errno.h>
++#include <string.h>
+ #include "KXL.h"
+
+ #define MIN(a, b) (((a) < (b)) ? (a) : (b))
+@@ -22,7 +24,7 @@
+ struct {
+ Uint16 ListCnt;
+ Sint32 ID;
+- Sint32 Pipe[2];
++ int Pipe[2];
+ Sint32 Device;
+ Uint16 PlayCnt;
+ KXL_SoundControl PlaySound[MAX_SOUNDS_PLAYING];
+@@ -242,11 +244,19 @@
+ KXL_SoundOk = False;
+
+ KXL_LoadSoundData(path, fname);
+- // device check
+- if ((KXL_SoundData.Device = open("/dev/dsp", O_WRONLY)) == -1) {
+- fprintf(stderr, "KXL error message\nnot found sound card\n");
++ // Open the sound device in non-blocking mode, because ALSA's OSS
++ // emulation and some broken OSS drivers would make a blocking call
++ // wait forever until the device is available. Since this breaks the
++ // OSS spec, we immediately put it back to blocking mode if the
++ // operation was successful.
++ KXL_SoundData.Device = open("/dev/dsp", O_WRONLY|O_NDELAY);
++ if (KXL_SoundData.Device < 0) {
++ fprintf(stderr, "KXL error message\ncould not open sound card (%s)\n",
++ strerror(errno));
+ return;
+ }
++ fcntl( KXL_SoundData.Device, F_SETFL,
++ fcntl( KXL_SoundData.Device, F_GETFL ) &~ FNDELAY );
+ // create pipe
+ if (pipe(KXL_SoundData.Pipe) < 0) {
+ fprintf(stderr, "KXL error message\npipe error\n");
+--- src/KXL.h.old 2007-05-13 22:25:11.000000000 +0200
++++ src/KXL.h 2007-05-13 22:25:47.000000000 +0200
+@@ -205,6 +205,7 @@
+ KXL_Frame *Frame; // Pointer of frame structure
+ GC FontGC; // GC of font
+ XFontStruct *WinFont; // Pointer of font structrue
++ Bool DetectAutoRepeat; // Does the server have detectable auto repeat
+ } KXL_Window;
+ // RGBE palette
+ typedef struct {
+--- src/KXLimage.c.old 2007-05-13 22:29:02.000000000 +0200
++++ src/KXLimage.c 2007-05-13 22:29:33.000000000 +0200
+@@ -1,4 +1,5 @@
+ #include <stdio.h>
++#include <stdlib.h>
+ #include "KXL.h"
+
+ extern KXL_Window *KXL_Root;
+--- src/KXLvisual.c.old 2007-05-13 22:22:34.000000000 +0200
++++ src/KXLvisual.c 2007-05-13 22:28:39.000000000 +0200
+@@ -1,4 +1,6 @@
+ #include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
+ #include "KXL.h"
+
+ //================================================================
+@@ -364,7 +366,11 @@
+ KXL_ReSizeFrame(w, h);
+ KXL_Clear_Frame(0, 0, w, h);
+ // Auto repeat off
+- XAutoRepeatOff(KXL_Root->Display);
++ XkbSetDetectableAutoRepeat(KXL_Root->Display, True,
++ &KXL_Root->DetectAutoRepeat);
++ if(!KXL_Root->DetectAutoRepeat) {
++ XAutoRepeatOff(KXL_Root->Display);
++ }
+ }
+
+ //==============================================================
+@@ -377,7 +383,9 @@
+ XFreeGC(KXL_Root->Display, KXL_Root->Frame->Gc);
+ KXL_Free(KXL_Root->Frame);
+ // Auto repeat on
+- XAutoRepeatOn(KXL_Root->Display);
++ if(!KXL_Root->DetectAutoRepeat) {
++ XAutoRepeatOn(KXL_Root->Display);
++ }
+ // Delete font
+ XFreeGC(KXL_Root->Display, KXL_Root->FontGC);
+ // Delete window
diff --git a/dev-games/KXL/files/digest-KXL-1.1.7-r1 b/dev-games/KXL/files/digest-KXL-1.1.7-r1
new file mode 100644
index 000000000000..ebd6ec7a17c8
--- /dev/null
+++ b/dev-games/KXL/files/digest-KXL-1.1.7-r1
@@ -0,0 +1,3 @@
+MD5 321bfad9dee29840656225b54bb6feb0 KXL-1.1.7.tar.gz 192070
+RMD160 58820a316311e8ae79e3705171356a768bd30680 KXL-1.1.7.tar.gz 192070
+SHA256 118b704befa24992031b51c9da1bc3786da153cfb21a0452bae97b1d479bdd98 KXL-1.1.7.tar.gz 192070