summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-03-26 18:02:47 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-03-26 18:02:47 +0000
commit9db9f77cc2ac9b4f247fdf621ffeaf07855fc10f (patch)
tree6804e2b23af859df33b6bdd60a7aeafd4f2f1a72 /dev-games
parentold (diff)
downloadgentoo-2-9db9f77cc2ac9b4f247fdf621ffeaf07855fc10f.tar.gz
gentoo-2-9db9f77cc2ac9b4f247fdf621ffeaf07855fc10f.tar.bz2
gentoo-2-9db9f77cc2ac9b4f247fdf621ffeaf07855fc10f.zip
old
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/mygui/ChangeLog6
-rw-r--r--dev-games/mygui/files/mygui-3.2.1-FHS.patch44
-rw-r--r--dev-games/mygui/mygui-3.2.1.ebuild141
3 files changed, 5 insertions, 186 deletions
diff --git a/dev-games/mygui/ChangeLog b/dev-games/mygui/ChangeLog
index 76e24d1cf6e8..e974c7865d39 100644
--- a/dev-games/mygui/ChangeLog
+++ b/dev-games/mygui/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-games/mygui
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/mygui/ChangeLog,v 1.9 2015/03/14 05:27:23 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/mygui/ChangeLog,v 1.10 2015/03/26 18:02:47 mr_bones_ Exp $
+
+ 26 Mar 2015; Michael Sterrett <mr_bones_@gentoo.org>
+ -files/mygui-3.2.1-FHS.patch, -mygui-3.2.1.ebuild:
+ old
*mygui-3.2.2 (14 Mar 2015)
diff --git a/dev-games/mygui/files/mygui-3.2.1-FHS.patch b/dev-games/mygui/files/mygui-3.2.1-FHS.patch
deleted file mode 100644
index b0a6b09eb31a..000000000000
--- a/dev-games/mygui/files/mygui-3.2.1-FHS.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-From: Julian Ospald <hasufell@gentoo.org>
-Date: Sat Oct 27 22:39:31 UTC 2012
-Subject: FHS
-
-paths hardcoded until upstream fixed the logic
-
---- Common/Base/Ogre/BaseManager.cpp
-+++ Common/Base/Ogre/BaseManager.cpp
-@@ -49,13 +49,13 @@
- mWindow(nullptr),
- mExit(false),
- mPluginCfgName("plugins.cfg"),
-- mResourceXMLName("resources.xml"),
-+ mResourceXMLName("/etc/MYGUI/resources.xml"),
- mResourceFileName("MyGUI_Core.xml")
- {
- #if MYGUI_PLATFORM == MYGUI_PLATFORM_APPLE
- mResourcePath = macBundlePath() + "/Contents/Resources/";
- #else
-- mResourcePath = "";
-+ mResourcePath = "/etc/MYGUI/";
- #endif
- }
-
---- CMake/InstallResources.cmake
-+++ CMake/InstallResources.cmake
-@@ -24,7 +24,7 @@
- else ()
- install(FILES
- ${MYGUI_BINARY_DIR}/bin/${FILENAME}
-- DESTINATION "bin"
-+ DESTINATION "/etc/MYGUI"
- )
- endif ()
- endfunction(install_file)
-@@ -51,7 +51,7 @@
- if (WIN32)
- set(MYGUI_MEDIA_DIR "../../Media")
- elseif (UNIX)
-- set(MYGUI_MEDIA_DIR "../share/MYGUI/Media")
-+ set(MYGUI_MEDIA_DIR "${CMAKE_INSTALL_PREFIX}/share/MYGUI/Media")
- else ()
- set(MYGUI_MEDIA_DIR "../../Media")
- endif ()
diff --git a/dev-games/mygui/mygui-3.2.1.ebuild b/dev-games/mygui/mygui-3.2.1.ebuild
deleted file mode 100644
index 19baa2f1035d..000000000000
--- a/dev-games/mygui/mygui-3.2.1.ebuild
+++ /dev/null
@@ -1,141 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/mygui/mygui-3.2.1.ebuild,v 1.1 2014/08/24 18:01:18 hasufell Exp $
-
-EAPI=5
-CMAKE_REMOVE_MODULES="yes"
-CMAKE_REMOVE_MODULES_LIST="FindFreetype"
-inherit eutils cmake-utils flag-o-matic multilib
-
-MY_PN=MyGUI
-MY_P=${MY_PN}${PV}
-
-DESCRIPTION="A library for creating GUIs for games"
-HOMEPAGE="http://mygui.info/"
-SRC_URI="https://github.com/MyGUI/mygui/archive/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug doc +ogre -opengl plugins samples static-libs test tools linguas_ru"
-REQUIRED_USE="ogre? ( !opengl )
- opengl? ( !ogre )"
-
-RDEPEND="
- media-libs/freetype:2
- ogre? (
- dev-games/ogre:=[freeimage,opengl]
- samples? ( dev-games/ois )
- )
- opengl? ( virtual/opengl )
- tools? ( dev-games/ois )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen )"
-
-S=${WORKDIR}/mygui-${MY_P}
-STATIC_BUILD=${WORKDIR}/${P}_build_static
-
-pkg_setup() {
- if use samples && use !ogre ; then
- ewarn "Samples disabled, because they only work with ogre!"
- ewarn "Enable ogre USE flag if you want to use samples."
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-3.2.0-underlinking.patch \
- "${FILESDIR}"/${PN}-3.2.0-build.patch \
- "${FILESDIR}"/${PN}-3.2.1-FHS.patch
-}
-
-src_configure() {
- use debug && append-cppflags -DDEBUG
-
- local mycmakeargs=()
-
- # static configuration
- if use static-libs ; then
- mycmakeargs=( -DMYGUI_STATIC=ON
- -DMYGUI_BUILD_DOCS=OFF
- -DMYGUI_INSTALL_DOCS=OFF
- -DMYGUI_USE_FREETYPE=ON
- $(cmake-utils_use plugins MYGUI_BUILD_PLUGINS)
- -DMYGUI_BUILD_DEMOS=OFF
- -DMYGUI_INSTALL_SAMPLES=OFF
- -DMYGUI_BUILD_TOOLS=OFF
- -DMYGUI_INSTALL_TOOLS=OFF
- -DMYGUI_BUILD_WRAPPER=OFF
- -DMYGUI_RENDERSYSTEM=$(usex opengl "4" "$(usex ogre "3" "1")") )
-
- CMAKE_BUILD_DIR=${STATIC_BUILD} cmake-utils_src_configure
- unset mycmakeargs
- fi
-
- # main configuration
- mycmakeargs=( -DMYGUI_STATIC=OFF
- $(cmake-utils_use doc MYGUI_BUILD_DOCS)
- $(cmake-utils_use doc MYGUI_INSTALL_DOCS)
- -DMYGUI_USE_FREETYPE=ON
- $(cmake-utils_use plugins MYGUI_BUILD_PLUGINS)
- $(usex ogre "$(cmake-utils_use samples MYGUI_BUILD_DEMOS)" "-DMYGUI_BUILD_DEMOS=OFF")
- $(usex ogre "$(cmake-utils_use samples MYGUI_INSTALL_SAMPLES)" "-DMYGUI_INSTALL_SAMPLES=OFF")
- $(cmake-utils_use tools MYGUI_BUILD_TOOLS)
- $(cmake-utils_use tools MYGUI_INSTALL_TOOLS)
- -DMYGUI_BUILD_WRAPPER=OFF
- -DMYGUI_RENDERSYSTEM=$(usex opengl "4" "$(usex ogre "3" "1")") )
-
- if use tools || (use samples && use ogre) ; then
- mycmakeargs+=( -DMYGUI_INSTALL_MEDIA=ON )
- else
- mycmakeargs+=( -DMYGUI_INSTALL_MEDIA=OFF )
- fi
-
- cmake-utils_src_configure
-}
-
-src_compile() {
- # build system does not support building static and shared at once,
- # run a double build
- if use static-libs ; then
- CMAKE_BUILD_DIR=${STATIC_BUILD} cmake-utils_src_compile
- fi
-
- cmake-utils_src_compile
-
- use doc && emake -C "${CMAKE_BUILD_DIR}"/Docs api-docs
-}
-
-src_install() {
- cmake-utils_src_install
-
- if use static-libs ; then
- find "${STATIC_BUILD}" -name "*.a" \! -name "libCommon.a" -exec dolib.a '{}' \;
- insinto /usr/$(get_libdir)/pkgconfig
- doins "${STATIC_BUILD}"/pkgconfig/MYGUIStatic.pc
- fi
-
- if use doc ; then
- dohtml -r "${CMAKE_BUILD_DIR}"/Docs/html/*
-
- if use linguas_ru ; then
- docompress -x /usr/share/doc/${PF}/Papers
- dodoc -r Docs/Papers
- fi
- fi
-
- keepdir /etc/MYGUI
- fperms o+w /etc/MYGUI
-
- # test media not needed at runtime
- rm -rf "${D}"/usr/share/MYGUI/Media/UnitTests
- # wrapper not available for linux, remove related media
- rm -rf "${D}"/usr/share/MYGUI/Media/Wrapper
-}
-
-pkg_postinst() {
- einfo
- elog "ogre.cfg and Ogre.log are created as"
- elog "/etc/MYGUI/mygui-ogre.cfg and /etc/MYGUI/mygui-Ogre.log"
- einfo
-}