summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-06-02 06:01:00 +0000
committerMark Wright <gienah@gentoo.org>2012-06-02 06:01:00 +0000
commit455bf3a0e359686bf2b8b7a3725436f85726b2a0 (patch)
tree0d1fe5da6589581ea04521494e3ed902c7094226 /dev-haskell/hdbc-postgresql
parentBump hdbc-odbc to 2.3.1.0 (diff)
downloadgentoo-2-455bf3a0e359686bf2b8b7a3725436f85726b2a0.tar.gz
gentoo-2-455bf3a0e359686bf2b8b7a3725436f85726b2a0.tar.bz2
gentoo-2-455bf3a0e359686bf2b8b7a3725436f85726b2a0.zip
Bump hdbc-postgresql to 2.3.2.1
(Portage version: 2.1.10.63/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/hdbc-postgresql')
-rw-r--r--dev-haskell/hdbc-postgresql/ChangeLog9
-rw-r--r--dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.1.ebuild57
2 files changed, 64 insertions, 2 deletions
diff --git a/dev-haskell/hdbc-postgresql/ChangeLog b/dev-haskell/hdbc-postgresql/ChangeLog
index e0380544ae0f..442ade66ae2d 100644
--- a/dev-haskell/hdbc-postgresql/ChangeLog
+++ b/dev-haskell/hdbc-postgresql/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/hdbc-postgresql
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-postgresql/ChangeLog,v 1.15 2011/06/12 19:53:43 slyfox Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-postgresql/ChangeLog,v 1.16 2012/06/02 06:01:00 gienah Exp $
+
+*hdbc-postgresql-2.3.2.1 (02 Jun 2012)
+
+ 02 Jun 2012; Mark Wright <gienah@gentoo.org> +hdbc-postgresql-2.3.2.1.ebuild:
+ Bump hdbc-postgresql to 2.3.2.1
*hdbc-postgresql-2.2.3.3 (12 Jun 2011)
diff --git a/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.1.ebuild b/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.1.ebuild
new file mode 100644
index 000000000000..41f9f00d9130
--- /dev/null
+++ b/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.1.ebuild,v 1.1 2012/06/02 06:01:00 gienah Exp $
+
+EAPI=4
+
+# ebuild generated by hackport 0.2.18.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal versionator
+
+MY_PN="HDBC-postgresql"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="PostgreSQL driver for HDBC"
+HOMEPAGE="http://github.com/hdbc/hdbc-postgresql"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="test" # requires configured postgresql
+
+hdbc_PV=$(get_version_component_range 1-2)
+
+RDEPEND=">dev-db/postgresql-base-8
+ dev-haskell/convertible[profile?]
+ =dev-haskell/hdbc-${hdbc_PV}*[profile?]
+ dev-haskell/mtl[profile?]
+ dev-haskell/parsec[profile?]
+ dev-haskell/time[profile?]
+ dev-haskell/utf8-string[profile?]
+ >=dev-lang/ghc-6.8.2"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ cabal_src_configure $(cabal_flag test buildtests)
+}
+
+src_test() {
+ # default tests
+ haskell-cabal_src_test || die "cabal test failed"
+
+ # built custom tests
+ "${S}/dist/build/runtests/runtests" || die "unit tests failed"
+}
+
+src_install() {
+ cabal_src_install
+
+ # if tests were enabled, make sure the unit test driver is deleted
+ rm -f "${ED}/usr/bin/runtests"
+}