summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2006-10-11 18:18:00 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2006-10-11 18:18:00 +0000
commit5f8acbd40d4391e0d56a6a6bfea6556170c78414 (patch)
tree4fa6bf49b4157dc4de0a69149725ee3906e69314 /dev-haskell/hmake/files
parentStable on sparc wrt security #144869 (diff)
downloadgentoo-2-5f8acbd40d4391e0d56a6a6bfea6556170c78414.tar.gz
gentoo-2-5f8acbd40d4391e0d56a6a6bfea6556170c78414.tar.bz2
gentoo-2-5f8acbd40d4391e0d56a6a6bfea6556170c78414.zip
Added patch to fix building with ghc-6.6
(Portage version: 2.1.1-r1)
Diffstat (limited to 'dev-haskell/hmake/files')
-rw-r--r--dev-haskell/hmake/files/hmake-3.11-ghc66.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/hmake/files/hmake-3.11-ghc66.patch b/dev-haskell/hmake/files/hmake-3.11-ghc66.patch
new file mode 100644
index 000000000000..6dbb2c85efd9
--- /dev/null
+++ b/dev-haskell/hmake/files/hmake-3.11-ghc66.patch
@@ -0,0 +1,36 @@
+diff -urwpN hmake-3.11.orig/src/hmake/Makefile hmake-3.11/src/hmake/Makefile
+--- hmake-3.11.orig/src/hmake/Makefile 2006-05-03 14:38:29.000000000 +0100
++++ hmake-3.11/src/hmake/Makefile 2006-09-12 10:34:28.000000000 +0100
+@@ -46,7 +46,7 @@ ifeq "nhc" "$(BUILDCOMP)"
+ HEAP = -H4M
+ endif
+ ifeq "ghc" "$(BUILDCOMP)"
+-HFLAGS += $(shell ${LOCAL}fixghc ${GHCSYM} -package lang)
++HFLAGS += $(shell ${LOCAL}fixghc ${GHCSYM})
+ endif
+ ifeq "hbc" "$(BUILDCOMP)"
+ all: hbc
+diff -urwpN hmake-3.11.orig/src/interpreter/Makefile hmake-3.11/src/interpreter/Makefile
+--- hmake-3.11.orig/src/interpreter/Makefile 2005-10-07 14:34:32.000000000 +0100
++++ hmake-3.11/src/interpreter/Makefile 2006-09-12 10:37:23.000000000 +0100
+@@ -11,7 +11,7 @@ CHFILES = $(patsubst %.hs, ../hmake/%.$C
+
+ ifeq "${BUILDCOMP}" "ghc"
+ HFLAGS = $(shell $(LOCAL)fixghc $(GHCSYM) \
+- -package lang -package util -package base $(READLINE) )
++ -package base $(READLINE) )
+ export HFLAGS
+ endif
+ ifeq "${BUILDCOMP}" "hbc"
+diff -urwpN hmake-3.11.orig/src/interpreter/SimpleLineEditor.hs hmake-3.11/src/interpreter/SimpleLineEditor.hs
+--- hmake-3.11.orig/src/interpreter/SimpleLineEditor.hs 2004-06-25 20:58:31.000000000 +0100
++++ hmake-3.11/src/interpreter/SimpleLineEditor.hs 2006-09-12 10:39:43.000000000 +0100
+@@ -26,7 +26,7 @@ import IO
+ import Monad (when)
+ import Char (isSpace)
+ #if USE_READLINE
+-import Readline
++import System.Console.Readline
+ #else
+ #if defined(__HBC__)
+ import IOExts (IORef, newIORef, readIORef, writeIORef, unsafePerformIO)