summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-12-11 06:48:43 +0000
committerMark Wright <gienah@gentoo.org>2013-12-11 06:48:43 +0000
commit318aea26c3469ab5a25ac67803d1e56c4b2a3274 (patch)
tree6c4660998b321589226a571f1d839e015a99d1ac /dev-haskell/pandoc-citeproc
parentBump wai to 2.0.0 (diff)
downloadgentoo-2-318aea26c3469ab5a25ac67803d1e56c4b2a3274.tar.gz
gentoo-2-318aea26c3469ab5a25ac67803d1e56c4b2a3274.tar.bz2
gentoo-2-318aea26c3469ab5a25ac67803d1e56c4b2a3274.zip
Bump pandoc-citeproc to 0.2
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/pandoc-citeproc')
-rw-r--r--dev-haskell/pandoc-citeproc/ChangeLog7
-rw-r--r--dev-haskell/pandoc-citeproc/pandoc-citeproc-0.2.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/dev-haskell/pandoc-citeproc/ChangeLog b/dev-haskell/pandoc-citeproc/ChangeLog
index b938b3a3a049..598adf7a72ea 100644
--- a/dev-haskell/pandoc-citeproc/ChangeLog
+++ b/dev-haskell/pandoc-citeproc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/pandoc-citeproc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/pandoc-citeproc/ChangeLog,v 1.1 2013/11/20 14:35:43 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/pandoc-citeproc/ChangeLog,v 1.2 2013/12/11 06:48:43 gienah Exp $
+
+*pandoc-citeproc-0.2 (11 Dec 2013)
+
+ 11 Dec 2013; Mark Wright <gienah@gentoo.org> +pandoc-citeproc-0.2.ebuild:
+ Bump pandoc-citeproc to 0.2
*pandoc-citeproc-0.1.2.1 (20 Nov 2013)
diff --git a/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.2.ebuild b/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.2.ebuild
new file mode 100644
index 000000000000..2c284f62034f
--- /dev/null
+++ b/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.2.ebuild,v 1.1 2013/12/11 06:48:43 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.5.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Supports using pandoc with citeproc"
+HOMEPAGE="http://hackage.haskell.org/package/pandoc-citeproc"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+bibutils embed_data_files +hexpat +network +small_base unicode_collation"
+RESTRICT=test # missing files: locales-en-US.xml: openBinaryFile
+
+RDEPEND=">=app-text/pandoc-1.12.1:=[profile?]
+ dev-haskell/aeson:=[profile?]
+ dev-haskell/aeson-pretty:=[profile?]
+ dev-haskell/attoparsec:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/pandoc-types-1.12.3:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ dev-haskell/split:=[profile?]
+ dev-haskell/syb:=[profile?]
+ dev-haskell/tagsoup:=[profile?]
+ >=dev-haskell/temporary-1.1:=[profile?]
+ >=dev-haskell/texmath-0.6.4:=[profile?]
+ dev-haskell/text:=[profile?]
+ >=dev-haskell/vector-0.10:=[profile?] <dev-haskell/vector-0.11:=[profile?]
+ >=dev-haskell/yaml-0.8:=[profile?]
+ >=dev-lang/ghc-7.0.1:=
+ bibutils? ( >=dev-haskell/hs-bibutils-0.3:=[profile?] )
+ hexpat? ( >=dev-haskell/hexpat-0.20.2:=[profile?] )
+ !hexpat? ( dev-haskell/xml:=[profile?] )
+ network? ( >=dev-haskell/http-4000.0.9:=[profile?]
+ >=dev-haskell/network-2:=[profile?] )
+ unicode_collation? ( dev-haskell/text-icu:=[profile?] )
+ !unicode_collation? ( dev-haskell/rfc5051:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.12
+"
+
+src_configure() {
+ # workaround bug on ghc-7.6.3:
+ # > [13 of 24] Compiling Text.CSL.Input.Bibtex ...
+ # > stack overflow: use +RTS -K<size> to increase it
+ replace-hcflags -O[2-9] -O1
+
+ haskell-cabal_src_configure \
+ $(cabal_flag bibutils bibutils) \
+ $(cabal_flag embed_data_files embed_data_files) \
+ $(cabal_flag hexpat hexpat) \
+ $(cabal_flag network network) \
+ $(cabal_flag small_base small_base) \
+ $(cabal_flag unicode_collation unicode_collation)
+}