summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2013-08-26 10:50:52 +0000
committerAlexander Vershilov <qnikst@gentoo.org>2013-08-26 10:50:52 +0000
commita5c707accc757cd563b6a060c2ee4625071bae17 (patch)
treedd91a0599b15a6619896119a234482a0ad49d46e /dev-haskell/reflection
parentBump (diff)
downloadgentoo-2-a5c707accc757cd563b6a060c2ee4625071bae17.tar.gz
gentoo-2-a5c707accc757cd563b6a060c2ee4625071bae17.tar.bz2
gentoo-2-a5c707accc757cd563b6a060c2ee4625071bae17.zip
dev-haskell/reflection: initial layout
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0xEAD50D64D8D3571A!)
Diffstat (limited to 'dev-haskell/reflection')
-rw-r--r--dev-haskell/reflection/ChangeLog9
-rw-r--r--dev-haskell/reflection/metadata.xml49
-rw-r--r--dev-haskell/reflection/reflection-1.3.2.ebuild25
3 files changed, 83 insertions, 0 deletions
diff --git a/dev-haskell/reflection/ChangeLog b/dev-haskell/reflection/ChangeLog
new file mode 100644
index 000000000000..ab7b564d33ab
--- /dev/null
+++ b/dev-haskell/reflection/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-haskell/reflection
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/reflection/ChangeLog,v 1.1 2013/08/26 10:50:52 qnikst Exp $
+
+*reflection-1.3.2 (26 Aug 2013)
+
+ 26 Aug 2013; Alexander Vershilov <qnikst@gentoo.org> +metadata.xml,
+ +reflection-1.3.2.ebuild:
+ dev-haskell/reflection: initial layout
diff --git a/dev-haskell/reflection/metadata.xml b/dev-haskell/reflection/metadata.xml
new file mode 100644
index 000000000000..22b4525f4511
--- /dev/null
+++ b/dev-haskell/reflection/metadata.xml
@@ -0,0 +1,49 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ This package provides an implementation of the ideas presented in the paper
+ \&quot;Functional Pearl: Implicit Configurations\&quot; by Oleg Kiselyov and
+ Chung-chieh Shan. However, the API has been streamlined to improve performance.
+
+ The original paper can be obtained from
+ &lt;http://www.cs.rutgers.edu/~ccshan/prepose/prepose.pdf&gt;.
+
+ /Changes in 1.1.6/:
+
+ * Relaxed an unnecessary strictness annotation in the fast implementation
+
+ /Changes in 1.1.5/:
+
+ * Both implementations now work on Hugs; the fast implementation ascends
+ from the ranks of completely unportable black magic to being merely
+ /mostly/ unportable black magic.
+
+ /Changes from 0.5 to 1.1/:
+
+ * Much faster implementation available that is about 50 /times/ faster than
+ 0.9 and which runs purely on black magic. This version is now used by
+ default. To turn it off install with the @slow@ flag. If you encounter a
+ problem with the implementation, please contact the author.
+
+ * Removed @ReifiedNum@, @reflectNum@, and @reifyIntegral@; @reify@ and
+ @reflect@ are about 3 orders of magnitude faster than the special case
+ combinators were.
+
+ /Changes in 0.5/:
+
+ * Generalized the type signatures in reflect to allow you to pass any type
+ with kind @* -&gt; *@ wrapped around the desired type as the phantom type
+ argument rather than just a @Proxy@.
+
+ /Changes in 0.4/:
+
+ * Converted from `Data.Tagged` to using `Data.Proxy` for reflection. This
+ reduces the need for helper functions and scoped type variables in user
+ code.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/reflection/reflection-1.3.2.ebuild b/dev-haskell/reflection/reflection-1.3.2.ebuild
new file mode 100644
index 000000000000..438a9dcdb787
--- /dev/null
+++ b/dev-haskell/reflection/reflection-1.3.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/reflection/reflection-1.3.2.ebuild,v 1.1 2013/08/26 10:50:52 qnikst Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Reifies arbitrary terms into types that can be reflected back into terms"
+HOMEPAGE="http://github.com/ekmett/reflection"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/tagged-0.4.4:=[profile?]
+ <dev-haskell/tagged-1:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10"