summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2015-06-01 21:18:25 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2015-06-01 21:18:25 +0000
commit3a33b8fe3e3a3547de21e938e6f7ad2f30ffc755 (patch)
tree66711fb26d6af2269afb5b5cd4ef1cdb547795fb /dev-haskell/regex-applicative
parentInitial commit: Set and bag operations on ordered lists. A depend for dev-vcs... (diff)
downloadgentoo-2-3a33b8fe3e3a3547de21e938e6f7ad2f30ffc755.tar.gz
gentoo-2-3a33b8fe3e3a3547de21e938e6f7ad2f30ffc755.tar.bz2
gentoo-2-3a33b8fe3e3a3547de21e938e6f7ad2f30ffc755.zip
Initial commit: Regex-based parsing with applicative interface. A depend for dev-vcs/darcs-2.10.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell/regex-applicative')
-rw-r--r--dev-haskell/regex-applicative/ChangeLog10
-rw-r--r--dev-haskell/regex-applicative/metadata.xml9
-rw-r--r--dev-haskell/regex-applicative/regex-applicative-0.3.1.ebuild30
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-haskell/regex-applicative/ChangeLog b/dev-haskell/regex-applicative/ChangeLog
new file mode 100644
index 000000000000..c568afc1d6ff
--- /dev/null
+++ b/dev-haskell/regex-applicative/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-haskell/regex-applicative
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/regex-applicative/ChangeLog,v 1.1 2015/06/01 21:18:25 slyfox Exp $
+
+*regex-applicative-0.3.1 (01 Jun 2015)
+
+ 01 Jun 2015; Sergei Trofimovich <slyfox@gentoo.org> +metadata.xml,
+ +regex-applicative-0.3.1.ebuild:
+ Initial commit: Regex-based parsing with applicative interface. A depend for
+ dev-vcs/darcs-2.10.
diff --git a/dev-haskell/regex-applicative/metadata.xml b/dev-haskell/regex-applicative/metadata.xml
new file mode 100644
index 000000000000..0b61e5a475bf
--- /dev/null
+++ b/dev-haskell/regex-applicative/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ regex-applicative is a Haskell library for parsing using regular expressions.
+ Parsers can be built using Applicative interface.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/regex-applicative/regex-applicative-0.3.1.ebuild b/dev-haskell/regex-applicative/regex-applicative-0.3.1.ebuild
new file mode 100644
index 000000000000..ce2234d23aa2
--- /dev/null
+++ b/dev-haskell/regex-applicative/regex-applicative-0.3.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/regex-applicative/regex-applicative-0.3.1.ebuild,v 1.1 2015/06/01 21:18:25 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Regex-based parsing with applicative interface"
+HOMEPAGE="https://github.com/feuerbach/regex-applicative"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/transformers:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( >=dev-haskell/smallcheck-1.0
+ dev-haskell/tasty
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-smallcheck )
+"