summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-09-14 13:14:16 +0000
committerMark Wright <gienah@gentoo.org>2012-09-14 13:14:16 +0000
commit85c7343c4ee7a18a18e4867610c8f5826e704a3c (patch)
tree6070333e08af931495ec6c96a400a7284e4039a6 /dev-haskell/text
parentPatch happy 1.18.9 build for ghc 7.6.1 (diff)
downloadgentoo-2-85c7343c4ee7a18a18e4867610c8f5826e704a3c.tar.gz
gentoo-2-85c7343c4ee7a18a18e4867610c8f5826e704a3c.tar.bz2
gentoo-2-85c7343c4ee7a18a18e4867610c8f5826e704a3c.zip
Bump text to 0.11.2.3
(Portage version: 2.1.11.17/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/text')
-rw-r--r--dev-haskell/text/ChangeLog7
-rw-r--r--dev-haskell/text/text-0.11.2.3.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-haskell/text/ChangeLog b/dev-haskell/text/ChangeLog
index 31a8073dbef2..73dd4401837c 100644
--- a/dev-haskell/text/ChangeLog
+++ b/dev-haskell/text/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/text
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/text/ChangeLog,v 1.14 2012/09/12 15:01:15 qnikst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/text/ChangeLog,v 1.15 2012/09/14 13:14:16 gienah Exp $
+
+*text-0.11.2.3 (14 Sep 2012)
+
+ 14 Sep 2012; Mark Wright <gienah@gentoo.org> +text-0.11.2.3.ebuild:
+ Bump text to 0.11.2.3
12 Sep 2012; Alexander Vershilov <qnikst@gentoo.org> text-0.11.1.1.ebuild,
text-0.11.1.12.ebuild, text-0.11.1.13-r1.ebuild, text-0.11.2.0.ebuild,
diff --git a/dev-haskell/text/text-0.11.2.3.ebuild b/dev-haskell/text/text-0.11.2.3.ebuild
new file mode 100644
index 000000000000..ba67533bfe8b
--- /dev/null
+++ b/dev-haskell/text/text-0.11.2.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/text/text-0.11.2.3.ebuild,v 1.1 2012/09/14 13:14:16 gienah Exp $
+
+EAPI=4
+
+# ebuild generated by hackport 0.2.18.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="An efficient packed Unicode text type."
+HOMEPAGE="https://github.com/bos/text"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+# tests fail to build:
+# <command line>: cannot satisfy -package-id text-0.11.2.3-inplace:
+# text-0.11.2.3-inplace is shadowed by package text-0.11.2.3-db61832d0c4660614c4ceff234ed4abb
+# http://hackage.haskell.org/trac/hackage/ticket/807
+IUSE="test"
+
+RDEPEND=">=dev-haskell/deepseq-1.1.0.0[profile?]
+ >=dev-lang/ghc-6.10.1"
+DEPEND="${RDEPEND}
+ test? ( >=dev-haskell/hunit-1.2[profile?]
+ >=dev-haskell/quickcheck-2.4[profile?]
+ dev-haskell/random[profile?]
+ >=dev-haskell/test-framework-0.4[profile?]
+ >=dev-haskell/test-framework-hunit-0.2[profile?]
+ >=dev-haskell/test-framework-quickcheck2-0.2[profile?]
+ )
+ >=dev-haskell/cabal-1.8"
+
+src_configure() {
+ # the tests need a utf-8 locale
+ cabal_src_configure $(use test && use_enable test tests) #395351
+}