summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2013-08-26 08:20:07 +0000
committerAlexander Vershilov <qnikst@gentoo.org>2013-08-26 08:20:07 +0000
commit44f2554f1fbe6df8937b352bbb81ca1ca8dd2a9a (patch)
tree0687debcdfd93f8f131645324711fbc854ceeb96 /dev-haskell/tls
parentdev-haskell/zlib-conduit: new version (diff)
downloadgentoo-2-44f2554f1fbe6df8937b352bbb81ca1ca8dd2a9a.tar.gz
gentoo-2-44f2554f1fbe6df8937b352bbb81ca1ca8dd2a9a.tar.bz2
gentoo-2-44f2554f1fbe6df8937b352bbb81ca1ca8dd2a9a.zip
dev-haskell/tls: new version
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0xEAD50D64D8D3571A!)
Diffstat (limited to 'dev-haskell/tls')
-rw-r--r--dev-haskell/tls/ChangeLog9
-rw-r--r--dev-haskell/tls/metadata.xml25
-rw-r--r--dev-haskell/tls/tls-1.1.2.ebuild41
3 files changed, 75 insertions, 0 deletions
diff --git a/dev-haskell/tls/ChangeLog b/dev-haskell/tls/ChangeLog
new file mode 100644
index 000000000000..2686e94f29c4
--- /dev/null
+++ b/dev-haskell/tls/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-haskell/tls
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/tls/ChangeLog,v 1.1 2013/08/26 08:20:07 qnikst Exp $
+
+*tls-1.1.2 (26 Aug 2013)
+
+ 26 Aug 2013; Alexander Vershilov <qnikst@gentoo.org> +metadata.xml,
+ +tls-1.1.2.ebuild:
+ dev-haskell/tls: new version
diff --git a/dev-haskell/tls/metadata.xml b/dev-haskell/tls/metadata.xml
new file mode 100644
index 000000000000..e9e1f30e8074
--- /dev/null
+++ b/dev-haskell/tls/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Native Haskell TLS and SSL protocol implementation for server and client.
+
+ This provides a high-level implementation of a sensitive security protocol,
+ eliminating a common set of security issues through the use of the advanced
+ type system, high level constructions and common Haskell features.
+
+ Currently implement the SSL3.0, TLS1.0, TLS1.1 and TLS1.2 protocol,
+ with only RSA supported for Key Exchange.
+
+ Only core protocol available here, have a look at the
+ &lt;http://hackage.haskell.org/package/tls-extra/&gt; package for default
+ ciphers, compressions and certificates functions.
+ </longdescription>
+ <use>
+ <flag name="compat"> Accept SSLv2 compatible handshake</flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-haskell/tls/tls-1.1.2.ebuild b/dev-haskell/tls/tls-1.1.2.ebuild
new file mode 100644
index 000000000000..2564011dad4b
--- /dev/null
+++ b/dev-haskell/tls/tls-1.1.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/tls/tls-1.1.2.ebuild,v 1.1 2013/08/26 08:20:07 qnikst Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="TLS/SSL protocol native implementation (Server and Client)"
+HOMEPAGE="http://github.com/vincenthz/hs-tls"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+compat"
+
+RDEPEND=">=dev-haskell/cereal-0.3:=[profile?]
+ >=dev-haskell/certificate-1.3.0:=[profile?]
+ <dev-haskell/certificate-1.4.0:=[profile?]
+ dev-haskell/crypto-pubkey:=[profile?]
+ =dev-haskell/crypto-random-api-0.2*:=[profile?]
+ >=dev-haskell/cryptohash-0.6:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/network:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/cprng-aes
+ >=dev-haskell/quickcheck-2
+ dev-haskell/test-framework
+ dev-haskell/test-framework-quickcheck2
+ )"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag compat compat)
+}