summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-04-02 09:57:50 +0000
committerMark Wright <gienah@gentoo.org>2013-04-02 09:57:50 +0000
commita25837e6d52416217e345e92a86b998acf642339 (patch)
tree419b139a6f81a8958c845f08d3efe21ee424104a /dev-haskell/unix-compat
parentBump, tests restricted for now (diff)
downloadgentoo-2-a25837e6d52416217e345e92a86b998acf642339.tar.gz
gentoo-2-a25837e6d52416217e345e92a86b998acf642339.tar.bz2
gentoo-2-a25837e6d52416217e345e92a86b998acf642339.zip
Bump unix-compat to 0.4.1.1
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/unix-compat')
-rw-r--r--dev-haskell/unix-compat/ChangeLog8
-rw-r--r--dev-haskell/unix-compat/metadata.xml3
-rw-r--r--dev-haskell/unix-compat/unix-compat-0.4.1.1.ebuild28
3 files changed, 38 insertions, 1 deletions
diff --git a/dev-haskell/unix-compat/ChangeLog b/dev-haskell/unix-compat/ChangeLog
index e97c2cf42edc..14f23b7bb9b6 100644
--- a/dev-haskell/unix-compat/ChangeLog
+++ b/dev-haskell/unix-compat/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/unix-compat
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/unix-compat/ChangeLog,v 1.17 2013/03/31 09:59:05 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/unix-compat/ChangeLog,v 1.18 2013/04/02 09:57:50 gienah Exp $
+
+*unix-compat-0.4.1.1 (02 Apr 2013)
+
+ 02 Apr 2013; Mark Wright <gienah@gentoo.org> +unix-compat-0.4.1.1.ebuild,
+ metadata.xml:
+ Bump unix-compat to 0.4.1.1
31 Mar 2013; Agostino Sarubbo <ago@gentoo.org> unix-compat-0.4.1.0.ebuild:
Stable for sparc, wrt bug #457284
diff --git a/dev-haskell/unix-compat/metadata.xml b/dev-haskell/unix-compat/metadata.xml
index f1ea57d4a7bb..d2d84a960e7a 100644
--- a/dev-haskell/unix-compat/metadata.xml
+++ b/dev-haskell/unix-compat/metadata.xml
@@ -11,4 +11,7 @@
package when available. When it isn&#39;t available,
portable implementations are used.
</longdescription>
+<use>
+ <flag name='old-time'>build against old-time package</flag>
+</use>
</pkgmetadata>
diff --git a/dev-haskell/unix-compat/unix-compat-0.4.1.1.ebuild b/dev-haskell/unix-compat/unix-compat-0.4.1.1.ebuild
new file mode 100644
index 000000000000..fbaf5ca24999
--- /dev/null
+++ b/dev-haskell/unix-compat/unix-compat-0.4.1.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/unix-compat/unix-compat-0.4.1.1.ebuild,v 1.1 2013/04/02 09:57:50 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Portable POSIX-compatibility layer."
+HOMEPAGE="http://github.com/jystic/unix-compat"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="old-time"
+
+RDEPEND=">=dev-lang/ghc-6.12.1:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag old-time old-time)
+}