summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2013-02-09 19:22:16 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2013-02-09 19:22:16 +0000
commitc93ae7b90ac37113ddc5efb2cfe31d05cfa607c4 (patch)
treed4b8ec98609c2b47ec7587e0819735114aaafdce /dev-haskell/utf8-string
parentVersion bump. (diff)
downloadgentoo-2-c93ae7b90ac37113ddc5efb2cfe31d05cfa607c4.tar.gz
gentoo-2-c93ae7b90ac37113ddc5efb2cfe31d05cfa607c4.tar.bz2
gentoo-2-c93ae7b90ac37113ddc5efb2cfe31d05cfa607c4.zip
Switch to EAPI=5.
(Portage version: 2.2.0_alpha153_p6/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell/utf8-string')
-rw-r--r--dev-haskell/utf8-string/ChangeLog10
-rw-r--r--dev-haskell/utf8-string/utf8-string-0.3.7-r1.ebuild28
2 files changed, 36 insertions, 2 deletions
diff --git a/dev-haskell/utf8-string/ChangeLog b/dev-haskell/utf8-string/ChangeLog
index a62f392a2426..3ec58150a675 100644
--- a/dev-haskell/utf8-string/ChangeLog
+++ b/dev-haskell/utf8-string/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/utf8-string
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/utf8-string/ChangeLog,v 1.17 2012/09/12 15:29:18 qnikst Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/utf8-string/ChangeLog,v 1.18 2013/02/09 19:22:16 slyfox Exp $
+
+*utf8-string-0.3.7-r1 (09 Feb 2013)
+
+ 09 Feb 2013; Sergei Trofimovich <slyfox@gentoo.org>
+ +utf8-string-0.3.7-r1.ebuild:
+ Switch to EAPI=5.
12 Sep 2012; Alexander Vershilov <qnikst@gentoo.org> utf8-string-0.3.6.ebuild,
utf8-string-0.3.7.ebuild:
diff --git a/dev-haskell/utf8-string/utf8-string-0.3.7-r1.ebuild b/dev-haskell/utf8-string/utf8-string-0.3.7-r1.ebuild
new file mode 100644
index 000000000000..623189da0f72
--- /dev/null
+++ b/dev-haskell/utf8-string/utf8-string-0.3.7-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/utf8-string/utf8-string-0.3.7-r1.ebuild,v 1.1 2013/02/09 19:22:16 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Support for reading and writing UTF8 Strings"
+HOMEPAGE="http://github.com/glguy/utf8-string/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-bytestring-in-base
+}