summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2013-08-26 10:58:09 +0000
committerAlexander Vershilov <qnikst@gentoo.org>2013-08-26 10:58:09 +0000
commitca752d8f442916c5c492a3dfe9ef012a79570a24 (patch)
treec7bf72d58dbab1a5ce9d41e7abf90d6d5868b706 /dev-haskell/xml-conduit
parentCleanup. (diff)
downloadgentoo-2-ca752d8f442916c5c492a3dfe9ef012a79570a24.tar.gz
gentoo-2-ca752d8f442916c5c492a3dfe9ef012a79570a24.tar.bz2
gentoo-2-ca752d8f442916c5c492a3dfe9ef012a79570a24.zip
dev-haskell/xml-conduit: initial layout
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0xEAD50D64D8D3571A!)
Diffstat (limited to 'dev-haskell/xml-conduit')
-rw-r--r--dev-haskell/xml-conduit/ChangeLog9
-rw-r--r--dev-haskell/xml-conduit/metadata.xml23
-rw-r--r--dev-haskell/xml-conduit/xml-conduit-1.1.0.7.ebuild47
3 files changed, 79 insertions, 0 deletions
diff --git a/dev-haskell/xml-conduit/ChangeLog b/dev-haskell/xml-conduit/ChangeLog
new file mode 100644
index 000000000000..d23cfa701e19
--- /dev/null
+++ b/dev-haskell/xml-conduit/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-haskell/xml-conduit
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/xml-conduit/ChangeLog,v 1.1 2013/08/26 10:58:09 qnikst Exp $
+
+*xml-conduit-1.1.0.7 (26 Aug 2013)
+
+ 26 Aug 2013; Alexander Vershilov <qnikst@gentoo.org> +metadata.xml,
+ +xml-conduit-1.1.0.7.ebuild:
+ dev-haskell/xml-conduit: initial layout
diff --git a/dev-haskell/xml-conduit/metadata.xml b/dev-haskell/xml-conduit/metadata.xml
new file mode 100644
index 000000000000..19406702f12f
--- /dev/null
+++ b/dev-haskell/xml-conduit/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ This package provides parsing and rendering functions for XML. It is based on the datatypes found in the xml-types package. This package is broken up into the following modules:
+
+ * Text.XML: DOM-based parsing and rendering. This is the most commonly used module.
+
+ * Text.XML.Cursor: A wrapper around &quot;Text.XML&quot; which allows bidirectional traversing of the DOM, similar to XPath. (Note: Text.XML.Cursor.Generic is the same concept, but will work with any node representation.)
+
+ * Text.XML.Unresolved: A slight modification to &quot;Text.XML&quot; which does not require all entities to be resolved at parsing. The datatypes are slightly more complicated here, and therefore this module is only recommended when you need to deal directly with raw entities.
+
+ * Text.XML.Stream.Parse: Streaming parser, including some streaming parser combinators.
+
+ * Text.XML.Stream.Render: Streaming renderer.
+
+ Additionally, the xml-hamlet package &lt;http://hackage.haskell.org/package/xml-hamlet&gt; provides a more convenient syntax for creating XML documents. For a more thorough tutorial on this library, please see &lt;http://www.yesodweb.com/book/xml-enumerator&gt;.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/xml-conduit/xml-conduit-1.1.0.7.ebuild b/dev-haskell/xml-conduit/xml-conduit-1.1.0.7.ebuild
new file mode 100644
index 000000000000..7dc8dab5121b
--- /dev/null
+++ b/dev-haskell/xml-conduit/xml-conduit-1.1.0.7.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/xml-conduit/xml-conduit-1.1.0.7.ebuild,v 1.1 2013/08/26 10:58:09 qnikst Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Pure-Haskell utilities for dealing with XML with the conduit package."
+HOMEPAGE="http://github.com/snoyberg/xml"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/attoparsec-0.10:=[profile?]
+ >=dev-haskell/attoparsec-conduit-1.0:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ >=dev-haskell/blaze-builder-0.2:=[profile?] <dev-haskell/blaze-builder-0.4:=[profile?]
+ >=dev-haskell/blaze-builder-conduit-1.0:=[profile?]
+ >=dev-haskell/blaze-html-0.5:=[profile?]
+ >=dev-haskell/blaze-markup-0.5:=[profile?]
+ >=dev-haskell/conduit-1.0:=[profile?] <dev-haskell/conduit-1.1:=[profile?]
+ dev-haskell/data-default:=[profile?]
+ >=dev-haskell/deepseq-1.1.0.0:=[profile?]
+ >=dev-haskell/failure-0.1:=[profile?] <dev-haskell/failure-0.3:=[profile?]
+ >=dev-haskell/monad-control-0.3:=[profile?] <dev-haskell/monad-control-0.4:=[profile?]
+ >=dev-haskell/resourcet-0.3:=[profile?] <dev-haskell/resourcet-0.5:=[profile?]
+ >=dev-haskell/system-filepath-0.4:=[profile?] <dev-haskell/system-filepath-0.5:=[profile?]
+ >=dev-haskell/text-0.7:=[profile?] <dev-haskell/text-0.12:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.4:=[profile?]
+ >=dev-haskell/xml-types-0.3.4:=[profile?] <dev-haskell/xml-types-0.4:=[profile?]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-haskell/conduit
+ >=dev-haskell/hspec-1.3
+ dev-haskell/hunit
+ dev-haskell/text
+ dev-haskell/transformers
+ >=dev-haskell/xml-types-0.3.1 )
+ >=dev-haskell/cabal-1.8
+"