summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2015-04-05 01:23:23 +0000
committerMark Wright <gienah@gentoo.org>2015-04-05 01:23:23 +0000
commitb06eae83b813e224a3cd2e9c532cb1f72a6821d6 (patch)
tree0eeb9f701f97317b16d164d9697de5261b4c8515 /dev-haskell/yesod-auth
parentBump yesod to 1.4.1.4 (diff)
downloadgentoo-2-b06eae83b813e224a3cd2e9c532cb1f72a6821d6.tar.gz
gentoo-2-b06eae83b813e224a3cd2e9c532cb1f72a6821d6.tar.bz2
gentoo-2-b06eae83b813e224a3cd2e9c532cb1f72a6821d6.zip
Bump yesod-auth to 1.4.4
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/yesod-auth')
-rw-r--r--dev-haskell/yesod-auth/ChangeLog7
-rw-r--r--dev-haskell/yesod-auth/yesod-auth-1.4.4.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/dev-haskell/yesod-auth/ChangeLog b/dev-haskell/yesod-auth/ChangeLog
index 6a2bb312e40c..38ceec8c861b 100644
--- a/dev-haskell/yesod-auth/ChangeLog
+++ b/dev-haskell/yesod-auth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/yesod-auth
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/yesod-auth/ChangeLog,v 1.11 2015/02/08 18:53:27 qnikst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/yesod-auth/ChangeLog,v 1.12 2015/04/05 01:23:23 gienah Exp $
+
+*yesod-auth-1.4.4 (05 Apr 2015)
+
+ 05 Apr 2015; Mark Wright <gienah@gentoo.org> +yesod-auth-1.4.4.ebuild:
+ Bump yesod-auth to 1.4.4
*yesod-auth-1.4.1.1 (08 Feb 2015)
diff --git a/dev-haskell/yesod-auth/yesod-auth-1.4.4.ebuild b/dev-haskell/yesod-auth/yesod-auth-1.4.4.ebuild
new file mode 100644
index 000000000000..23565f64d476
--- /dev/null
+++ b/dev-haskell/yesod-auth/yesod-auth-1.4.4.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/yesod-auth/yesod-auth-1.4.4.ebuild,v 1.1 2015/04/05 01:23:23 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Authentication for Yesod"
+HOMEPAGE="http://www.yesodweb.com/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+network-uri"
+
+RDEPEND=">=dev-haskell/aeson-0.7:=[profile?]
+ >=dev-haskell/authenticate-1.3:=[profile?]
+ dev-haskell/base16-bytestring:=[profile?]
+ dev-haskell/base64-bytestring:=[profile?]
+ dev-haskell/binary:=[profile?]
+ dev-haskell/blaze-builder:=[profile?]
+ >=dev-haskell/blaze-html-0.5:=[profile?]
+ >=dev-haskell/blaze-markup-0.5.1:=[profile?]
+ dev-haskell/byteable:=[profile?]
+ dev-haskell/conduit:=[profile?]
+ dev-haskell/conduit-extra:=[profile?]
+ dev-haskell/cryptohash:=[profile?]
+ dev-haskell/data-default:=[profile?]
+ >=dev-haskell/email-validate-1.0:=[profile?]
+ dev-haskell/file-embed:=[profile?]
+ dev-haskell/http-client:=[profile?]
+ >=dev-haskell/http-conduit-1.5:=[profile?]
+ dev-haskell/http-types:=[profile?]
+ >=dev-haskell/lifted-base-0.1:=[profile?]
+ >=dev-haskell/mime-mail-0.3:=[profile?]
+ >=dev-haskell/persistent-2.1:=[profile?] <dev-haskell/persistent-2.2:=[profile?]
+ >=dev-haskell/persistent-template-2.1:=[profile?] <dev-haskell/persistent-template-2.2:=[profile?]
+ >=dev-haskell/random-1.0.0.2:=[profile?]
+ dev-haskell/resourcet:=[profile?]
+ dev-haskell/safe:=[profile?]
+ dev-haskell/shakespeare:=[profile?]
+ >=dev-haskell/text-0.7:=[profile?]
+ >=dev-haskell/transformers-0.2.2:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ >=dev-haskell/wai-1.4:=[profile?]
+ >=dev-haskell/yesod-core-1.4:=[profile?] <dev-haskell/yesod-core-1.5:=[profile?]
+ >=dev-haskell/yesod-form-1.4:=[profile?] <dev-haskell/yesod-form-1.5:=[profile?]
+ >=dev-haskell/yesod-persistent-1.4:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ network-uri? ( >=dev-haskell/network-uri-2.6:=[profile?] )
+ !network-uri? ( <dev-haskell/network-2.6:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag network-uri network-uri)
+}