summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2013-01-01 18:52:56 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2013-01-01 18:52:56 +0000
commit6ce62a870e48864cc3830ed19d8b2eb32ac55939 (patch)
treec1598e019e9451038f912a8455419caceadb0c74 /dev-haskell
parents390/sh stable wrt #441728 (diff)
downloadgentoo-2-6ce62a870e48864cc3830ed19d8b2eb32ac55939.tar.gz
gentoo-2-6ce62a870e48864cc3830ed19d8b2eb32ac55939.tar.bz2
gentoo-2-6ce62a870e48864cc3830ed19d8b2eb32ac55939.zip
Removed old.
(Portage version: 2.2.0_alpha149_p11/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/haddock/ChangeLog6
-rw-r--r--dev-haskell/haddock/haddock-2.10.0.ebuild70
-rw-r--r--dev-haskell/haddock/haddock-2.9.2.ebuild77
3 files changed, 5 insertions, 148 deletions
diff --git a/dev-haskell/haddock/ChangeLog b/dev-haskell/haddock/ChangeLog
index 616b30d58427..3dccc95ee5c4 100644
--- a/dev-haskell/haddock/ChangeLog
+++ b/dev-haskell/haddock/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-haskell/haddock
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haddock/ChangeLog,v 1.96 2013/01/01 18:49:17 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haddock/ChangeLog,v 1.97 2013/01/01 18:52:56 slyfox Exp $
+
+ 01 Jan 2013; Sergei Trofimovich <slyfox@gentoo.org> -haddock-2.10.0.ebuild,
+ -haddock-2.9.2.ebuild:
+ Removed old.
01 Jan 2013; Sergei Trofimovich <slyfox@gentoo.org>
-files/haddock-2.4.2-Setup.hs, -haddock-2.4.2.ebuild:
diff --git a/dev-haskell/haddock/haddock-2.10.0.ebuild b/dev-haskell/haddock/haddock-2.10.0.ebuild
deleted file mode 100644
index beb282b65cb3..000000000000
--- a/dev-haskell/haddock/haddock-2.10.0.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haddock/haddock-2.10.0.ebuild,v 1.4 2012/10/21 08:04:50 slyfox Exp $
-
-EAPI="4"
-
-CABAL_FEATURES="bin lib profile haddock hscolour nocabaldep"
-inherit eutils haskell-cabal pax-utils
-
-DESCRIPTION="A documentation-generation tool for Haskell libraries"
-HOMEPAGE="http://www.haskell.org/haddock/"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-# ia64 lost as we don't have ghc-7 there yet
-# ppc64 needs to be rekeyworded due to xhtml not being keyworded
-KEYWORDS="~alpha ~amd64 -ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
-IUSE=""
-
-RDEPEND="dev-haskell/ghc-paths[profile?]
- =dev-haskell/xhtml-3000.2*[profile?]
- >=dev-lang/ghc-7.4"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.14"
-
-RESTRICT="test" # avoid depends on QC
-
-CABAL_EXTRA_BUILD_FLAGS="--ghc-options=-rtsopts"
-
-src_prepare() {
- # we would like to avoid happy and alex depends
- epatch "${FILESDIR}"/${P}-drop-tools.patch
-
- for f in Lex Parse; do
- rm "src/Haddock/$f."*
- mv "dist/build/haddock/haddock-tmp/Haddock/$f.hs" src/Haddock/
- done
-}
-
-src_configure() {
- # create a fake haddock executable. it'll set the right version to cabal
- # configure, but will eventually get overwritten in src_compile by
- # the real executable.
- local exe="${S}/dist/build/haddock/haddock"
- mkdir -p $(dirname "${exe}")
- echo -e "#!/bin/sh\necho Haddock version ${PV}" > "${exe}"
- chmod +x "${exe}"
-
- # we use 'nocabaldep' to use ghc's bundled Cabal
- # as external one is likely to break our haddock
- # (known to work on 1.16.0 and breaks on 1.16.0.1!)
- haskell-cabal_src_configure \
- --with-haddock="${exe}" \
- --constraint="Cabal == $(cabal-version)"
-}
-
-src_compile() {
- # when building the (recursive..) haddock docs, change the datadir to the
- # current directory, as we're using haddock inplace even if it's built to be
- # installed into the system first.
- haddock_datadir="${S}" haskell-cabal_src_compile
-}
-
-src_install() {
- cabal_src_install
- # haddock uses GHC-api to process TH source.
- # TH requires GHCi which needs mmap('rwx') (bug #299709)
- pax-mark -m "${D}/usr/bin/${PN}"
-}
diff --git a/dev-haskell/haddock/haddock-2.9.2.ebuild b/dev-haskell/haddock/haddock-2.9.2.ebuild
deleted file mode 100644
index bef3be88c8f8..000000000000
--- a/dev-haskell/haddock/haddock-2.9.2.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haddock/haddock-2.9.2.ebuild,v 1.4 2012/09/14 07:03:20 qnikst Exp $
-
-# ebuild generated by hackport 0.2.9
-
-# haddock-2.8.{0,1} on hackage does not work with ghc-7.
-# this ebuild uses a tarball of what's distributed with ghc-7.
-
-EAPI="3"
-
-CABAL_FEATURES="bin lib profile haddock hscolour"
-inherit haskell-cabal pax-utils
-
-DESCRIPTION="A documentation-generation tool for Haskell libraries"
-HOMEPAGE="http://www.haskell.org/haddock/"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-# ia64 lost as we don't have ghc-7 there yet
-# ppc64 needs to be rekeyworded due to xhtml not being keyworded
-KEYWORDS="~alpha ~amd64 -ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
-IUSE=""
-
-RDEPEND="dev-haskell/ghc-paths
- =dev-haskell/xhtml-3000.2*
- >=dev-lang/ghc-7"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.10 <dev-haskell/cabal-1.14"
-
-CABAL_EXTRA_BUILD_FLAGS="--ghc-options=-rtsopts"
-
-# although haddock depends on alex and happy to build from scratch, we don't
-# want this ebuild to depend on those packages.
-# we use haddock to build the documentation enabled by USE="doc".
-# alex and happy only build executables, which does not require haddock.
-# however, happy depends on mtl which can be build with USE="doc", which would
-# create a circular dependency.
-# haddock upstream solved this by bundling preprocessed files.
-# unfortunately cabal has recently changed which directory it uses for these
-# intermediate files and thus the solution does not work anymore.
-# to fix this we move those preprocessed files back to the source tree.
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-cabal-1.10.patch
- for f in Lex Parse; do
- rm "src/Haddock/$f."*
- mv "dist/build/haddock/haddock-tmp/Haddock/$f.hs" src/Haddock/
- done
-}
-
-src_configure() {
- # create a fake haddock executable. it'll set the right version to cabal
- # configure, but will eventually get overwritten in src_compile by
- # the real executable.
- local exe="${S}/dist/build/haddock/haddock"
- mkdir -p $(dirname "${exe}")
- echo -e "#!/bin/sh\necho Haddock version ${PV}" > "${exe}"
- chmod +x "${exe}"
-
- haskell-cabal_src_configure --with-haddock="${exe}"
-}
-
-src_compile() {
- # when building the (recursive..) haddock docs, change the datadir to the
- # current directory, as we're using haddock inplace even if it's built to be
- # installed into the system first.
- haddock_datadir="${S}" haskell-cabal_src_compile
-}
-
-src_install() {
- cabal_src_install
- # haddock uses GHC-api to process TH source.
- # TH requires GHCi which needs mmap('rwx') (bug #299709)
- pax-mark -m "${D}/usr/bin/${PN}"
-}