summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Francisco Araujo <araujo@gentoo.org>2005-12-12 22:09:01 +0000
committerLuis Francisco Araujo <araujo@gentoo.org>2005-12-12 22:09:01 +0000
commit803f42e4380d899198089d432e446930139c9e53 (patch)
tree7ab96776f88f1a6199488599b47f1472bbc36f5f /dev-haskell
parentFixing libraries installation. (diff)
downloadgentoo-2-803f42e4380d899198089d432e446930139c9e53.tar.gz
gentoo-2-803f42e4380d899198089d432e446930139c9e53.tar.bz2
gentoo-2-803f42e4380d899198089d432e446930139c9e53.zip
Removing broken ebuild.
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/hs-plugins/files/digest-hs-plugins-0.9.102
-rw-r--r--dev-haskell/hs-plugins/hs-plugins-0.9.10.ebuild56
2 files changed, 0 insertions, 58 deletions
diff --git a/dev-haskell/hs-plugins/files/digest-hs-plugins-0.9.10 b/dev-haskell/hs-plugins/files/digest-hs-plugins-0.9.10
deleted file mode 100644
index 85172d151f3b..000000000000
--- a/dev-haskell/hs-plugins/files/digest-hs-plugins-0.9.10
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 501b9a2ee9da05ef65790ca4494e8da3 hs-plugins-0.9.10.tar.gz 220990
-MD5 2ba9b743f45c294bd32bd9e5ad44352b hs-plugins.html.tar.gz 24643
diff --git a/dev-haskell/hs-plugins/hs-plugins-0.9.10.ebuild b/dev-haskell/hs-plugins/hs-plugins-0.9.10.ebuild
deleted file mode 100644
index d5167c62881b..000000000000
--- a/dev-haskell/hs-plugins/hs-plugins-0.9.10.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hs-plugins/hs-plugins-0.9.10.ebuild,v 1.2 2005/11/02 07:34:11 swegener Exp $
-
-inherit ghc-package
-
-DESCRIPTION="Dynamically Loaded Haskell Plugins"
-HOMEPAGE="http://www.cse.unsw.edu.au/~dons/hs-plugins/"
-SRC_URI="ftp://ftp.cse.unsw.edu.au/pub/users/dons/${PN}/${P}.tar.gz
- doc? ( http://www.cse.unsw.edu.au/~dons/${PN}/${PN}.html.tar.gz )"
-
-LICENSE="as-is"
-SLOT="0"
-KEYWORDS="~x86 -amd64" # currently broken on amd64
-IUSE="doc"
-
-DEPEND="virtual/ghc
- >=dev-haskell/haskell-src-exts-0.2
- dev-haskell/cabal"
-
-src_unpack() {
- unpack ${A}
- # for package management
- sed -i 's:\$(GHC_PKG) -u:\${GHC_PKGF} -u:' ${S}/Makefile
-
- cabalversion=$(ghc-bestcabalversion)
-
- sed -i "s:-package Cabal:-package ${cabalversion}:" \
- ${S}/src/plugins/Makefile
-
- # Also specify an exact version of Cabal otherwise ghc-pkg defaults it to
- # the minimum version which is just wrong. Should be fixed in ghc-6.4.1
- sed -i "s/depends:\(.*\) Cabal/depends:\1 ${cabalversion}/" \
- ${S}/src/plugins/plugins.conf.in.cpp
-}
-
-src_compile() {
- econf
- # for package management
- echo 'GHC_PKGF = ${GHC_PKG} --force -f '"${S}/$(ghc-localpkgconf)" >> config.mk
- emake -j1
-}
-
-src_install() {
- emake PREFIX="${D}/usr" install
- ghc-setup-pkg
- emake PREFIX="${D}/usr" register # then we don't need --force in ghc-pkg
- ghc-install-pkg
-
- dodoc AUTHORS README TODO VERSION
-
- if use doc; then
- dohtml ${WORKDIR}/${PN}/*
- fi
-}
-