summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2015-04-05 01:22:45 +0000
committerMark Wright <gienah@gentoo.org>2015-04-05 01:22:45 +0000
commitaec4caa81b2ec3db4ce0e17d998021b2f7520761 (patch)
tree1ad728dde5b80eea41166df330ca74bb15bc02e9 /dev-haskell
parentBump xml-hamlet to 0.4.0.10 (diff)
downloadgentoo-2-aec4caa81b2ec3db4ce0e17d998021b2f7520761.tar.gz
gentoo-2-aec4caa81b2ec3db4ce0e17d998021b2f7520761.tar.bz2
gentoo-2-aec4caa81b2ec3db4ce0e17d998021b2f7520761.zip
Bump yesod to 1.4.1.4
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/yesod/ChangeLog7
-rw-r--r--dev-haskell/yesod/yesod-1.4.1.4.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-haskell/yesod/ChangeLog b/dev-haskell/yesod/ChangeLog
index 24322114d682..cde7d63acc77 100644
--- a/dev-haskell/yesod/ChangeLog
+++ b/dev-haskell/yesod/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/yesod
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/yesod/ChangeLog,v 1.10 2015/02/07 21:43:20 qnikst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/yesod/ChangeLog,v 1.11 2015/04/05 01:22:45 gienah Exp $
+
+*yesod-1.4.1.4 (05 Apr 2015)
+
+ 05 Apr 2015; Mark Wright <gienah@gentoo.org> +yesod-1.4.1.4.ebuild:
+ Bump yesod to 1.4.1.4
07 Feb 2015; Alexander Vershilov <qnikst@gentoo.org> -yesod-1.1.9.2.ebuild,
-yesod-1.2.0.1.ebuild, -yesod-1.2.1.1.ebuild, -yesod-1.2.1.ebuild,
diff --git a/dev-haskell/yesod/yesod-1.4.1.4.ebuild b/dev-haskell/yesod/yesod-1.4.1.4.ebuild
new file mode 100644
index 000000000000..852583ea7727
--- /dev/null
+++ b/dev-haskell/yesod/yesod-1.4.1.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/yesod/yesod-1.4.1.4.ebuild,v 1.1 2015/04/05 01:22:45 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Creation of type-safe, RESTful web applications"
+HOMEPAGE="http://www.yesodweb.com/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ >=dev-haskell/blaze-html-0.5:=[profile?]
+ >=dev-haskell/blaze-markup-0.5.1:=[profile?]
+ dev-haskell/conduit-extra:=[profile?]
+ dev-haskell/data-default:=[profile?]
+ dev-haskell/fast-logger:=[profile?]
+ >=dev-haskell/monad-control-0.3:=[profile?] <dev-haskell/monad-control-1.1:=[profile?]
+ dev-haskell/monad-logger:=[profile?]
+ dev-haskell/safe:=[profile?]
+ dev-haskell/semigroups:=[profile?]
+ dev-haskell/shakespeare:=[profile?]
+ dev-haskell/streaming-commons:=[profile?]
+ dev-haskell/text:=[profile?]
+ >=dev-haskell/transformers-0.2.2:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ >=dev-haskell/wai-1.3:=[profile?]
+ >=dev-haskell/wai-extra-1.3:=[profile?]
+ dev-haskell/wai-logger:=[profile?]
+ >=dev-haskell/warp-1.3:=[profile?]
+ dev-haskell/yaml:=[profile?]
+ >=dev-haskell/yesod-auth-1.4:=[profile?] <dev-haskell/yesod-auth-1.5:=[profile?]
+ >=dev-haskell/yesod-core-1.4:=[profile?] <dev-haskell/yesod-core-1.5:=[profile?]
+ >=dev-haskell/yesod-form-1.4:=[profile?] <dev-haskell/yesod-form-1.5:=[profile?]
+ >=dev-haskell/yesod-persistent-1.4:=[profile?] <dev-haskell/yesod-persistent-1.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"