summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-07-05 14:28:11 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-07-05 14:28:11 +0000
commitc8a9cbb4cf778c63e04b07ec3c62f41da96d478f (patch)
treef3c7147f6f5c579837138d72870aaa5cf768073c /dev-java/ant-testutil
parentVersion bump to 1.9.1. (diff)
downloadgentoo-2-c8a9cbb4cf778c63e04b07ec3c62f41da96d478f.tar.gz
gentoo-2-c8a9cbb4cf778c63e04b07ec3c62f41da96d478f.tar.bz2
gentoo-2-c8a9cbb4cf778c63e04b07ec3c62f41da96d478f.zip
Version bump to 1.9.1.
(Portage version: 2.1.12.11/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java/ant-testutil')
-rw-r--r--dev-java/ant-testutil/ChangeLog9
-rw-r--r--dev-java/ant-testutil/ant-testutil-1.9.1.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/dev-java/ant-testutil/ChangeLog b/dev-java/ant-testutil/ChangeLog
index e0d6960c2767..187ed23d98bd 100644
--- a/dev-java/ant-testutil/ChangeLog
+++ b/dev-java/ant-testutil/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/ant-testutil
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-testutil/ChangeLog,v 1.17 2012/12/05 17:33:44 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-testutil/ChangeLog,v 1.18 2013/07/05 14:28:11 tomwij Exp $
+
+*ant-testutil-1.9.1 (05 Jul 2013)
+
+ 05 Jul 2013; Tom Wijsman <TomWij@gentoo.org> +ant-testutil-1.9.1.ebuild:
+ Version bump to 1.9.1.
05 Dec 2012; Agostino Sarubbo <ago@gentoo.org> ant-testutil-1.8.4.ebuild:
Stable for ppc64, wrt bug #417909
diff --git a/dev-java/ant-testutil/ant-testutil-1.9.1.ebuild b/dev-java/ant-testutil/ant-testutil-1.9.1.ebuild
new file mode 100644
index 000000000000..295106017867
--- /dev/null
+++ b/dev-java/ant-testutil/ant-testutil-1.9.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-testutil/ant-testutil-1.9.1.ebuild,v 1.1 2013/07/05 14:28:11 tomwij Exp $
+
+EAPI="5"
+
+inherit ant-tasks
+
+DESCRIPTION="Apache Ant's optional test utility classes"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux \
+ ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris \
+ ~x64-solaris ~x86-solaris"
+
+CDEPEND="dev-java/ant-core:0"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.6
+ >=dev-java/junit-4.11:4
+ ~dev-java/ant-swing-${PV}
+ ~dev-java/ant-junit4-${PV}"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.6"
+
+# The build system builds much more than it actually packages, so there are many
+# build-only deps, but since those are quite common, it wasn't worth to patch it.
+
+src_unpack() {
+ ant-tasks_src_unpack base
+ java-pkg_jar-from --build-only junit-4,ant-junit4,ant-swing
+ java-pkg_jar-from --build-only ant-core ant-launcher.jar
+}
+
+src_compile() {
+ eant test-jar
+}