summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-16 18:22:16 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-16 18:22:16 +0000
commitf4493f98a873cd753dd8ef4282be3f381b69cfd5 (patch)
tree01c534b30f885df8c558214ee684b0bf84e36f06 /dev-java/antlr
parentVersion bump. (diff)
downloadgentoo-2-f4493f98a873cd753dd8ef4282be3f381b69cfd5.tar.gz
gentoo-2-f4493f98a873cd753dd8ef4282be3f381b69cfd5.tar.bz2
gentoo-2-f4493f98a873cd753dd8ef4282be3f381b69cfd5.zip
Use Python 2, fix deprecation warnings (bug #312147).
(Portage version: 2.2.0_alpha15_p10/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/antlr')
-rw-r--r--dev-java/antlr/ChangeLog6
-rw-r--r--dev-java/antlr/antlr-2.7.7-r1.ebuild35
-rw-r--r--dev-java/antlr/antlr-2.7.7.ebuild37
3 files changed, 60 insertions, 18 deletions
diff --git a/dev-java/antlr/ChangeLog b/dev-java/antlr/ChangeLog
index 33a981a0e2ae..9ef8e6e87622 100644
--- a/dev-java/antlr/ChangeLog
+++ b/dev-java/antlr/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/antlr
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/antlr/ChangeLog,v 1.80 2011/01/16 13:01:39 fordfrog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/antlr/ChangeLog,v 1.81 2011/01/16 18:22:16 arfrever Exp $
+
+ 16 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ antlr-2.7.7.ebuild, antlr-2.7.7-r1.ebuild:
+ Use Python 2, fix deprecation warnings (bug #312147).
*antlr-2.7.7-r1 (16 Jan 2011)
diff --git a/dev-java/antlr/antlr-2.7.7-r1.ebuild b/dev-java/antlr/antlr-2.7.7-r1.ebuild
index 6dbdab6b0d84..bacc0f65a7e4 100644
--- a/dev-java/antlr/antlr-2.7.7-r1.ebuild
+++ b/dev-java/antlr/antlr-2.7.7-r1.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/antlr/antlr-2.7.7-r1.ebuild,v 1.1 2011/01/16 13:01:39 fordfrog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/antlr/antlr-2.7.7-r1.ebuild,v 1.2 2011/01/16 18:22:16 arfrever Exp $
-EAPI=1
+EAPI="3"
+PYTHON_DEPEND="python? 2"
inherit base java-pkg-2 mono distutils multilib
@@ -17,19 +18,27 @@ IUSE="doc debug examples mono +cxx +java python script source"
# TODO do we actually need jdk at runtime?
RDEPEND=">=virtual/jdk-1.3
- mono? ( dev-lang/mono )
- python? ( dev-lang/python )"
+ mono? ( dev-lang/mono )"
DEPEND="${RDEPEND}
script? ( !dev-util/pccts )
source? ( app-arch/zip )"
PATCHES=( "${FILESDIR}/2.7.7-gcc-4.3.patch" "${FILESDIR}/2.7.7-gcc-4.4.patch" "${FILESDIR}/2.7.7-makefixes.patch" )
-src_unpack() {
- base_src_unpack
+pkg_setup() {
+ java-pkg-2_pkg_setup
+
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
}
-src_compile() {
+src_prepare() {
+ base_src_prepare
+}
+
+src_configure() {
# don't ask why, but this is needed for stuff to get built properly
# across the various JDKs
JAVACFLAGS="+ ${JAVACFLAGS}"
@@ -41,8 +50,10 @@ src_compile() {
$(use_enable debug) \
$(use_enable examples) \
$(use_enable cxx) \
- --enable-verbose || die "configure failed"
+ --enable-verbose
+}
+src_compile() {
emake || die "compile failed"
sed -e "s|@prefix@|/usr/|" \
@@ -103,3 +114,11 @@ src_install() {
newdoc "${S}"/README.txt README || die
}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}
diff --git a/dev-java/antlr/antlr-2.7.7.ebuild b/dev-java/antlr/antlr-2.7.7.ebuild
index e3684946eb0a..f14b79169615 100644
--- a/dev-java/antlr/antlr-2.7.7.ebuild
+++ b/dev-java/antlr/antlr-2.7.7.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/antlr/antlr-2.7.7.ebuild,v 1.16 2009/03/29 23:29:15 serkan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/antlr/antlr-2.7.7.ebuild,v 1.17 2011/01/16 18:22:16 arfrever Exp $
-EAPI=1
+EAPI="3"
+PYTHON_DEPEND="python? 2"
inherit base java-pkg-2 mono distutils multilib
@@ -17,19 +18,27 @@ IUSE="doc debug examples mono +cxx +java python script source"
# TODO do we actually need jdk at runtime?
RDEPEND=">=virtual/jdk-1.3
- mono? ( dev-lang/mono )
- python? ( dev-lang/python )"
+ mono? ( dev-lang/mono )"
DEPEND="${RDEPEND}
script? ( !dev-util/pccts )
source? ( app-arch/zip )"
PATCHES=( "${FILESDIR}/2.7.7-gcc-4.3.patch" "${FILESDIR}/2.7.7-gcc-4.4.patch" "${FILESDIR}/2.7.7-makefixes.patch" )
-src_unpack() {
- base_src_unpack
+pkg_setup() {
+ java-pkg-2_pkg_setup
+
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
}
-src_compile() {
+src_prepare() {
+ base_src_prepare
+}
+
+src_configure() {
# don't ask why, but this is needed for stuff to get built properly
# across the various JDKs
JAVACFLAGS="+ ${JAVACFLAGS}"
@@ -41,8 +50,10 @@ src_compile() {
$(use_enable debug) \
$(use_enable examples) \
$(use_enable cxx) \
- --enable-verbose || die "configure failed"
+ --enable-verbose
+}
+src_compile() {
emake || die "compile failed"
sed -e "s|@prefix@|/usr/|" \
@@ -103,3 +114,11 @@ src_install() {
newdoc "${S}"/README.txt README || die
}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}