summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2006-07-04 20:40:28 +0000
committerJoshua Nichols <nichoj@gentoo.org>2006-07-04 20:40:28 +0000
commit6fc17f4be592046074a9df4e8508c80ec28fe2c3 (patch)
treec48bd4e6eb57f8d7d146d06f5e6dd9958de395f1 /dev-java/commons-el/commons-el-1.0-r1.ebuild
parentRemoved phpgroupware, see bug #134637 (diff)
downloadgentoo-2-6fc17f4be592046074a9df4e8508c80ec28fe2c3.tar.gz
gentoo-2-6fc17f4be592046074a9df4e8508c80ec28fe2c3.tar.bz2
gentoo-2-6fc17f4be592046074a9df4e8508c80ec28fe2c3.zip
Revision bump to support new Java system.
(Portage version: 2.1.1_pre1)
Diffstat (limited to 'dev-java/commons-el/commons-el-1.0-r1.ebuild')
-rw-r--r--dev-java/commons-el/commons-el-1.0-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-java/commons-el/commons-el-1.0-r1.ebuild b/dev-java/commons-el/commons-el-1.0-r1.ebuild
new file mode 100644
index 000000000000..1c1d72660c22
--- /dev/null
+++ b/dev-java/commons-el/commons-el-1.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-el/commons-el-1.0-r1.ebuild,v 1.1 2006/07/04 20:40:28 nichoj Exp $
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="EL is the JSP 2.0 Expression Language Interpreter from Apache."
+HOMEPAGE="http://jakarta.apache.org/commons/el/"
+SRC_URI="mirror://apache/jakarta/commons/el/source/${P}-src.tar.gz"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="source"
+COMMON_DEP="~dev-java/servletapi-2.4"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.4
+ >=dev-java/ant-core-1.5
+ ${COMMON_DEP}
+ source? ( app-arch/zip )"
+
+S=${WORKDIR}/${P}-src
+
+ant_src_unpack() {
+ unpack ${A}
+ cd ${S}
+ mv build.properties build.properties.old
+
+ echo "servlet-api.jar=$(java-pkg_getjar servletapi-2.4 servlet-api.jar)" >> build.properties
+ echo "jsp-api.jar=$(java-pkg_getjar servletapi-2.4 jsp-api.jar)" >> build.properties
+ echo "junit.jar = $(java-pkg_getjars junit)" >> build.properties
+ echo "servletapi.build.notrequired = true" >> build.properties
+ echo "jspapi.build.notrequired = true" >> build.properties
+
+ # Build.xml is broken, fix it
+ sed -i "s:../LICENSE:./LICENSE.txt:" build.xml || die "sed failed"
+}
+
+src_compile() {
+ eant jar
+}
+
+src_install() {
+ java-pkg_dojar dist/${PN}.jar || die "Unable to install"
+ dodoc LICENSE.txt RELEASE-NOTES.txt
+ dohtml STATUS.html PROPOSAL.html
+
+ use source && java-pkg_dosrc src/java/org
+}