summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-05-17 20:25:30 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-05-17 20:25:30 +0000
commitf0acf130bce997254206b263cc2e1f795dc18ccb (patch)
tree941cd3909bad656ec075c1b956bb67068437c05d /dev-java/commons-validator
parentalpha stable wrt #163094 (diff)
downloadgentoo-2-f0acf130bce997254206b263cc2e1f795dc18ccb.tar.gz
gentoo-2-f0acf130bce997254206b263cc2e1f795dc18ccb.tar.bz2
gentoo-2-f0acf130bce997254206b263cc2e1f795dc18ccb.zip
Make ebuild work when commons-collections installs more than one jar.
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-java/commons-validator')
-rw-r--r--dev-java/commons-validator/ChangeLog6
-rw-r--r--dev-java/commons-validator/commons-validator-1.1.4-r1.ebuild11
2 files changed, 10 insertions, 7 deletions
diff --git a/dev-java/commons-validator/ChangeLog b/dev-java/commons-validator/ChangeLog
index 40754249210f..1361780992cc 100644
--- a/dev-java/commons-validator/ChangeLog
+++ b/dev-java/commons-validator/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/commons-validator
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-validator/ChangeLog,v 1.39 2007/05/07 15:44:07 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-validator/ChangeLog,v 1.40 2007/05/17 20:25:30 betelgeuse Exp $
+
+ 17 May 2007; Petteri Räty <betelgeuse@gentoo.org>
+ commons-validator-1.1.4-r1.ebuild:
+ Make ebuild work when commons-collections installs more than one jar.
07 May 2007; Vlastimil Babka <caster@gentoo.org>
commons-validator-1.1.4-r1.ebuild:
diff --git a/dev-java/commons-validator/commons-validator-1.1.4-r1.ebuild b/dev-java/commons-validator/commons-validator-1.1.4-r1.ebuild
index c6397f65c066..fdf61577b69a 100644
--- a/dev-java/commons-validator/commons-validator-1.1.4-r1.ebuild
+++ b/dev-java/commons-validator/commons-validator-1.1.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-validator/commons-validator-1.1.4-r1.ebuild,v 1.7 2007/05/07 15:44:07 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-validator/commons-validator-1.1.4-r1.ebuild,v 1.8 2007/05/17 20:25:30 betelgeuse Exp $
JAVA_PKG_IUSE="doc examples source"
inherit java-pkg-2 java-ant-2
@@ -44,14 +44,13 @@ src_unpack() {
src_compile() {
local antflags="compile"
- # Because the build.xml file uses <pathelement location="">
+ # Because the build.xml file uses <pathelement location="">
# we can only have only have one jar per property
antflags="${antflags} -Dcommons-logging.jar=$(java-pkg_getjar commons-logging commons-logging.jar)"
- antflags="${antflags} -Dcommons-collections.jar=$(java-pkg_getjars commons-collections)"
- use doc && antflags="${antflags} javadoc"
-
- eant ${antflags} || die "build failed"
+ local col=$(java-pkg_getjar commons-collections commons-collections.jar)
+ eant ${antflags} $(use_doc) \
+ -Dcommons-collections.jar="${col}" || die "build failed"
jar -cf ${PN}.jar -C target/classes/ . || die "could not create jar"
}