summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2010-04-03 10:57:25 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2010-04-03 10:57:25 +0000
commit24fe894cb83147a16ab40a0901d8d9228621b2e2 (patch)
tree54480df0313aac3f3553b62c1d897a18905f59e0 /dev-java/hessian/hessian-4.0.3.ebuild
parentadd cxx to use-depend for newer imagemagick use-flags changes (diff)
downloadgentoo-2-24fe894cb83147a16ab40a0901d8d9228621b2e2.tar.gz
gentoo-2-24fe894cb83147a16ab40a0901d8d9228621b2e2.tar.bz2
gentoo-2-24fe894cb83147a16ab40a0901d8d9228621b2e2.zip
Version bump.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/hessian/hessian-4.0.3.ebuild')
-rw-r--r--dev-java/hessian/hessian-4.0.3.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-java/hessian/hessian-4.0.3.ebuild b/dev-java/hessian/hessian-4.0.3.ebuild
new file mode 100644
index 000000000000..965fd6b216d9
--- /dev/null
+++ b/dev-java/hessian/hessian-4.0.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/hessian/hessian-4.0.3.ebuild,v 1.1 2010/04/03 10:57:25 nelchael Exp $
+
+EAPI=1
+JAVA_PKG_IUSE="source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Binary web service protocol."
+HOMEPAGE="http://hessian.caucho.com/"
+SRC_URI="http://hessian.caucho.com/download/${P}-src.jar"
+
+LICENSE="Apache-1.1"
+SLOT="4.0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE=""
+
+COMMON_DEP="java-virtuals/servlet-api:2.5"
+
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip
+ ${COMMON_DEP}"
+
+EANT_BUILD_TARGET="all"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack ${A}
+
+ mkdir -p "${S}/src"
+ mkdir -p "${S}/lib"
+
+ cp "${FILESDIR}/build.xml-${PV}" "${S}/build.xml"
+
+ cd "${S}/src"
+ mv ../com .
+
+ cd "${S}/lib"
+ java-pkg_jarfrom --virtual servlet-api:2.5
+}
+
+src_install() {
+ java-pkg_dojar "hessian.jar"
+ java-pkg_dojar "burlap.jar"
+ java-pkg_dojar "services.jar"
+
+ use source && java-pkg_dosrc src
+}