summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2013-11-11 07:05:55 +0000
committerVlastimil Babka <caster@gentoo.org>2013-11-11 07:05:55 +0000
commit7435c592d5c6812d2c216f2b8d217c19bf162f8b (patch)
treed562e06a67e75934985e651e860cafa9a233ad4b /dev-java/icedtea-web
parentdev-python/pympler: Readd old version, #490986 (diff)
downloadgentoo-2-7435c592d5c6812d2c216f2b8d217c19bf162f8b.tar.gz
gentoo-2-7435c592d5c6812d2c216f2b8d217c19bf162f8b.tar.bz2
gentoo-2-7435c592d5c6812d2c216f2b8d217c19bf162f8b.zip
Introduce icedtea7 USE flag, as it turns out that icedtea-web built with icedtea-6 is missing a class necessary for icedtea-7. When built with icedtea-7, it works with both versions.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 4E61DE84)
Diffstat (limited to 'dev-java/icedtea-web')
-rw-r--r--dev-java/icedtea-web/ChangeLog8
-rw-r--r--dev-java/icedtea-web/icedtea-web-1.4.1.ebuild16
-rw-r--r--dev-java/icedtea-web/metadata.xml1
3 files changed, 19 insertions, 6 deletions
diff --git a/dev-java/icedtea-web/ChangeLog b/dev-java/icedtea-web/ChangeLog
index b64aa4700e54..eab9f586c6fa 100644
--- a/dev-java/icedtea-web/ChangeLog
+++ b/dev-java/icedtea-web/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/icedtea-web
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-web/ChangeLog,v 1.36 2013/11/09 11:55:04 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-web/ChangeLog,v 1.37 2013/11/11 07:05:55 caster Exp $
+
+ 11 Nov 2013; Vlastimil Babka <caster@gentoo.org> icedtea-web-1.4.1.ebuild,
+ metadata.xml:
+ Introduce icedtea7 USE flag, as it turns out that icedtea-web built with
+ icedtea-6 is missing a class necessary for icedtea-7. When built with
+ icedtea-7, it works with both versions.
09 Nov 2013; Vlastimil Babka <caster@gentoo.org> icedtea-web-1.4.1.ebuild:
Correct VMHANDLE to make automatic nsplugin activation work.
diff --git a/dev-java/icedtea-web/icedtea-web-1.4.1.ebuild b/dev-java/icedtea-web/icedtea-web-1.4.1.ebuild
index d79c76032cd0..f3087d133656 100644
--- a/dev-java/icedtea-web/icedtea-web-1.4.1.ebuild
+++ b/dev-java/icedtea-web/icedtea-web-1.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-web/icedtea-web-1.4.1.ebuild,v 1.2 2013/11/09 11:55:04 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-web/icedtea-web-1.4.1.ebuild,v 1.3 2013/11/11 07:05:55 caster Exp $
# Build written by Andrew John Hughes (ahughes@redhat.com)
EAPI="5"
@@ -15,13 +15,16 @@ LICENSE="GPL-2 GPL-2-with-linking-exception LGPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc javascript +nsplugin test"
+IUSE="doc +icedtea7 javascript +nsplugin test"
COMMON_DEP="
- || (
+ icedtea7? ( || (
+ dev-java/icedtea:7 dev-java/icedtea-bin:7
+ ) )
+ !icedtea7? ( || (
dev-java/icedtea:7 dev-java/icedtea-bin:7
dev-java/icedtea:6 dev-java/icedtea-bin:6
- )
+ ) )
app-admin/eselect-java
nsplugin? (
>=dev-libs/glib-2.16
@@ -36,7 +39,10 @@ DEPEND="${COMMON_DEP}
# http://mail.openjdk.java.net/pipermail/distro-pkg-dev/2010-December/011221.html
pkg_setup() {
- JAVA_PKG_WANT_BUILD_VM="icedtea-7 icedtea-bin-7 icedtea-6 icedtea-bin-6"
+ JAVA_PKG_WANT_BUILD_VM="icedtea-7 icedtea-bin-7"
+ if ! use icedtea7; then
+ JAVA_PKG_WANT_BUILD_VM="${JAVA_PKG_WANT_BUILD_VM} icedtea-6 icedtea-bin-6"
+ fi
JAVA_PKG_WANT_SOURCE="1.6"
JAVA_PKG_WANT_TARGET="1.6"
diff --git a/dev-java/icedtea-web/metadata.xml b/dev-java/icedtea-web/metadata.xml
index 7ad86bf37b39..d2acb1b2f067 100644
--- a/dev-java/icedtea-web/metadata.xml
+++ b/dev-java/icedtea-web/metadata.xml
@@ -7,6 +7,7 @@
</longdescription>
<use>
<flag name="javascript">Enable support for using proxy auto config (PAC) files.</flag>
+ <flag name="icedtea7">Build icedtea-7 support in addition to icedtea-6 support. Requires icedtea{-bin}-7</flag>
<flag name="nsplugin">Enable the browser plugin (NPPlugin).</flag>
<flag name="gtk2">Use x11-libs/gtk+:2 instead of x11-libs/gtk+:3</flag>
<flag name="gtk3">Use x11-libs/gtk+:3 (default)</flag>