summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-05-15 21:34:43 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-05-15 21:34:43 +0000
commit1d7c27019b00d37ac2295dd5dc2272eaca933eb7 (patch)
tree13f8ec318c17a6e70e27b3ec0778cd4ba0eb41df /dev-java/jempbox/jempbox-0.2.0.ebuild
parentStable for HPPA (bug #158271). (diff)
downloadgentoo-2-1d7c27019b00d37ac2295dd5dc2272eaca933eb7.tar.gz
gentoo-2-1d7c27019b00d37ac2295dd5dc2272eaca933eb7.tar.bz2
gentoo-2-1d7c27019b00d37ac2295dd5dc2272eaca933eb7.zip
Fix installing with the doc use flag off. Fixes bug #178688.
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-java/jempbox/jempbox-0.2.0.ebuild')
-rw-r--r--dev-java/jempbox/jempbox-0.2.0.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-java/jempbox/jempbox-0.2.0.ebuild b/dev-java/jempbox/jempbox-0.2.0.ebuild
index aa9ca7e1f561..2de1feec79e6 100644
--- a/dev-java/jempbox/jempbox-0.2.0.ebuild
+++ b/dev-java/jempbox/jempbox-0.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jempbox/jempbox-0.2.0.ebuild,v 1.2 2007/05/15 09:43:17 ali_bush Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jempbox/jempbox-0.2.0.ebuild,v 1.3 2007/05/15 21:34:43 betelgeuse Exp $
JAVA_PKG_IUSE="doc source test"
WANT_ANT_TASKS="ant-nodeps"
@@ -49,8 +49,10 @@ src_compile() {
#install jar and javadoc.
mkdir gentoo-dist
cp "lib/${MY_P}.jar" "gentoo-dist/${MY_P}.jar" || die "Failed to copy jar."
- use doc && cp -R website/build/site/javadoc gentoo-dist || die \
- "Unable to copy javadoc"
+ if use doc; then
+ cp -R website/build/site/javadoc gentoo-dist || die \
+ "Unable to copy javadoc"
+ fi
}
src_test() {