summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-07-05 17:32:14 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-07-05 17:32:14 +0000
commit93e783f656e195b79688e81dbd8a970db90f4238 (patch)
tree01a3420ad3076d3f3b2e666ce5581f19d3899de6 /dev-java/jldap
parentUpdate DESCRIPTION and HOMEPAGE. Fix bug 553964. (diff)
downloadgentoo-2-93e783f656e195b79688e81dbd8a970db90f4238.tar.gz
gentoo-2-93e783f656e195b79688e81dbd8a970db90f4238.tar.bz2
gentoo-2-93e783f656e195b79688e81dbd8a970db90f4238.zip
Version bump. EAPI 5 bump. dev-java/commons-httpclient SLOT bump. Fix bug 442292 and bug 554030.
Signed-off-by: Patrice Clement <monsieurp@gentoo.org> (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 93491BB8)
Diffstat (limited to 'dev-java/jldap')
-rw-r--r--dev-java/jldap/ChangeLog13
-rw-r--r--dev-java/jldap/files/jldap-4.6-Debug.java.patch11
-rw-r--r--dev-java/jldap/files/jldap-4.6-build.xml.patch257
-rw-r--r--dev-java/jldap/jldap-4.6.ebuild69
-rw-r--r--dev-java/jldap/metadata.xml9
5 files changed, 353 insertions, 6 deletions
diff --git a/dev-java/jldap/ChangeLog b/dev-java/jldap/ChangeLog
index 52acffa70042..6ea13b99283c 100644
--- a/dev-java/jldap/ChangeLog
+++ b/dev-java/jldap/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-java/jldap
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jldap/ChangeLog,v 1.16 2007/10/24 05:17:08 wltjr Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jldap/ChangeLog,v 1.17 2015/07/05 17:32:14 monsieurp Exp $
+
+*jldap-4.6 (05 Jul 2015)
+
+ 05 Jul 2015; Patrice Clement <monsieurp@gentoo.org>
+ +files/jldap-4.6-Debug.java.patch, +files/jldap-4.6-build.xml.patch,
+ +jldap-4.6.ebuild, metadata.xml:
+ Version bump. EAPI 5 bump. dev-java/commons-httpclient SLOT bump. Fix bug
+ 442292 and bug 554030.
24 Oct 2007; William L. Thomson Jr. <wltjr@gentoo.org>
-jldap-20040730.ebuild:
@@ -64,4 +72,3 @@
30 Jul 2004; Thomas Matthijs <axxo@gentoo.org> :
initial import, bug 41276, ebuild submitted by Matthew Gregory Sr.
<matt.gregory@skyleach.com
-
diff --git a/dev-java/jldap/files/jldap-4.6-Debug.java.patch b/dev-java/jldap/files/jldap-4.6-Debug.java.patch
new file mode 100644
index 000000000000..9da540fd5536
--- /dev/null
+++ b/dev-java/jldap/files/jldap-4.6-Debug.java.patch
@@ -0,0 +1,11 @@
+--- com/novell/ldap/client/Debug.java.orig 2015-07-05 13:50:26.469000000 +0000
++++ com/novell/ldap/client/Debug.java 2015-07-05 13:53:12.456000000 +0000
+@@ -80,7 +80,7 @@
+ * The value for this variable is set during compile time
+ * TRUE = Debug build, FALSE = Release build
+ */
+- public static final boolean LDAP_DEBUG = true;
++ public static final boolean LDAP_DEBUG = false;
+
+ /**
+ * The string value used to enable all debug tracing.
diff --git a/dev-java/jldap/files/jldap-4.6-build.xml.patch b/dev-java/jldap/files/jldap-4.6-build.xml.patch
new file mode 100644
index 000000000000..f5bcefa507ff
--- /dev/null
+++ b/dev-java/jldap/files/jldap-4.6-build.xml.patch
@@ -0,0 +1,257 @@
+--- build.xml.orig 2015-07-05 18:20:19.947000000 +0000
++++ build.xml 2015-07-05 18:20:34.996000000 +0000
+@@ -42,12 +42,20 @@
+ <property name="src" value="."/>
+ <property name="ext" value="ext"/>
+ <property name="ldap" value="ldap"/>
++<property name="jldap" value ="jldap"/>
++
++
+
+ <property name="lib" value="lib"/>
+ <property name="lib.debug" value="lib_debug"/>
+
+ <property name="build" value="classes"/>
+ <property name="build.debug" value="classes_debug"/>
++<property name="build.testDir" value="tests/junit/"/>
++<property name="build.testOutputDir" value="${build.testDir}/test-classes"/>
++<property name="build.testResourceDir" value="src/test/resources"/>
++
++<property name="test.reports" value="${build}/test-reports"/>
+
+ <property name="doc" value="doc"/>
+ <property name="ietfdoc" value="ietfdoc"/>
+@@ -60,6 +68,9 @@
+ <property name="pkg.ietfdoc" value="${pkg}/${ietfdoc}"/>
+ <property name="pkg.wars" value="${pkg}/wars"/>
+
++<path id="build.test.classpath">
++</path>
++
+ <!-- =================================================================== -->
+ <!-- Initialization -->
+ <!-- =================================================================== -->
+@@ -166,12 +177,12 @@
+ <!-- =================================================================== -->
+ <!-- build Servlets -->
+ <!-- =================================================================== -->
+- <target name="servlet_stream" depends="debug, release">
++ <target name="servlet_stream" depends="debug">
+ <ant dir="${basedir}/com/novell/services/dsml/stream" target="all">
+ <property name="top" location="."/>
+ </ant>
+ </target>
+- <target name="servlet_dom" depends="debug, release">
++ <target name="servlet_dom" depends="debug">
+ <ant dir="${basedir}/com/novell/services/dsml/dom" target="all">
+ <property name="top" location="."/>
+ </ant>
+@@ -201,42 +212,152 @@
+
+ <target name="clone_wars" depends="wars"/>
+
++ <!-- Imported from javac.xml -->
++ <!-- START -->
++
+ <!-- =================================================================== -->
+ <!-- build debug classes -->
+ <!-- =================================================================== -->
+- <target name="debug" depends="init">
+- <ant antfile="javac.xml" target="debug">
+- <property name="DEBUG_VALUE" value="true"/>
+- </ant>
++ <target name="debug" >
++
++ <echo message="DEBUG compile in com/novell"/>
++ <mkdir dir="${build.debug}"/>
++ <javac
++ srcdir="${src}"
++ includes="com/novell/**/*.java,jldap/com/novell/security/sasl/*.java,org/ietf/**/*.java"
++ excludes="com/novell/services/**/*.java,${exclude.dsmlconnection},${exclude.spmlconnection}"
++ destdir="${build.debug}"
++ target="1.2"
++ deprecation="off"
++ debug="on"
++ optimize="off">
++ <classpath>
++ <pathelement location="external/ssl/domestic/nssl1.2_dom.jar"/>
++ <pathelement location="external/jsse/lib/jcert.jar"/>
++ <pathelement location="external/jsse/lib/jnet.jar"/>
++ <pathelement location="external/jsse/lib/jsse.jar"/>
++
++ <!-- Take care of optional components -->
++ <fileset dir="${ext}">
++ <include name="commons-httpclient-*.jar"/>
++ <include name="openspml*.jar"/>
++ </fileset>
++ </classpath>
++ </javac>
++
++ <echo message="Creating DEBUG ${lib.debug}/${ldap}.jar file"/>
++ <mkdir dir="${lib.debug}"/>
++ <jar
++ jarfile="${lib.debug}/${ldap}.jar"
++ basedir="${build.debug}"
++ />
+ </target>
+
+ <!-- =================================================================== -->
+ <!-- build release classes -->
+ <!-- =================================================================== -->
+- <target name="release" depends="init">
+- <ant antfile="javac.xml" target="release">
+- <property name="DEBUG_VALUE" value="false"/>
+- </ant>
++ <target name="release">
++
++ <echo message="RELEASE compile in com/novell"/>
++ <mkdir dir="${build}"/>
++ <javac
++ srcdir="."
++ includes="com/novell/**/*.java,jldap/com/novell/security/sasl/*.java,org/ietf/**/*.java"
++ excludes="com/novell/services/**/*.java"
++ destdir="${build}"
++ encoding="UTF-8"
++ target="1.6"
++ source="1.6"
++ deprecation="off"
++ debug="off"
++ optimize="on">
++ <classpath>
++ <pathelement location="external/ssl/domestic/nssl1.2_dom.jar"/>
++ <pathelement location="external/jsse/lib/jcert.jar"/>
++ <pathelement location="external/jsse/lib/jnet.jar"/>
++ <pathelement location="external/jsse/lib/jsse.jar"/>
++ <pathelement location="external/commons-httpclient-2.0-rc2.jar"/>
++ </classpath>
++ </javac>
++
++ <echo message="Creating RELEASE ${lib}/${ldap}.jar file"/>
++ <mkdir dir="${lib}"/>
++ <jar jarfile="${lib}/${jldap}.jar"
++ basedir="${build}"
++ />
+ </target>
+
+- <!-- =================================================================== -->
+- <!-- setup for javadoc -->
+- <!-- =================================================================== -->
+- <target name="setupDoc" depends="init">
+- <ant antfile="javac.xml" target="setupDebug">
+- <property name="DEBUG_VALUE" value="true"/>
+- </ant>
++ <!-- ====================================================================== -->
++ <!-- Test-compilation target -->
++ <!-- ====================================================================== -->
++
++ <target name="compile-tests"
++ description="Compile the test code">
++ <mkdir dir="${build.testOutputDir}"/>
++ <mkdir dir="${build.testResourceDir}"/>
++ <javac destdir="${build.testOutputDir}"
++ encoding="UTF-8"
++ nowarn="false"
++ debug="true"
++ optimize="false"
++ deprecation="true"
++ target="1.6"
++ verbose="false"
++ fork="false"
++ source="1.6">
++ <src>
++ <pathelement location="${build.testDir}"/>
++ </src>
++ <classpath>
++ <path refid="build.test.classpath"/>
++ <pathelement location="${build.outputDir}"/>
++ </classpath>
++ </javac>
++ <copy todir="${build.testOutputDir}">
++ <fileset dir="${build.testResourceDir}"/>
++ </copy>
+ </target>
+
+- <!-- =================================================================== -->
+- <!-- final is synonym for build release classes -->
+- <!-- =================================================================== -->
+- <target name="final" depends="release" />
++ <!-- ====================================================================== -->
++ <!-- Run all tests -->
++ <!-- ====================================================================== -->
++
++ <target name="test"
++ depends="compile-tests"
++ description="Run the test cases">
++ <mkdir dir="${test.reports}"/>
++ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
++ <sysproperty key="basedir" value="."/>
++ <formatter type="xml"/>
++ <formatter type="plain" usefile="false"/>
++ <classpath>
++ <path refid="build.test.classpath"/>
++ <pathelement location="${build.outputDir}"/>
++ <pathelement location="${build.testOutputDir}"/>
++ </classpath>
++ <batchtest todir="${test.reports}" unless="test">
++ <fileset dir="${build.testDir}">
++ <include name="**/Test*.java"/>
++ <include name="**/*Test.java"/>
++ <include name="**/*TestCase.java"/>
++ <exclude name="**/*Abstract*Test.java"/>
++ </fileset>
++ </batchtest>
++ <batchtest todir="${test.reports}" if="test">
++ <fileset dir="${build.testDir}">
++ <include name="**/${test}.java"/>
++ <exclude name="**/*Abstract*Test.java"/>
++ </fileset>
++ </batchtest>
++ </junit>
++ </target>
++
++ <!-- END -->
+
+ <!-- =================================================================== -->
+ <!-- build lib files -->
+ <!-- =================================================================== -->
+- <target name="lib" depends="debug, release"/>
++ <target name="lib" depends="debug"/>
+
+ <!-- =================================================================== -->
+ <!-- jar is synonym for build lib files -->
+@@ -284,7 +405,7 @@
+ <!-- =================================================================== -->
+ <!-- create javadoc for Novell ldap classes -->
+ <!-- =================================================================== -->
+- <target name="docnovellldap" depends="init, setupDoc">
++ <target name="docnovellldap" depends="init">
+ <delete dir="${pkg.doc}"/>
+ <echo message="Creating distribution ldap javadoc"/>
+ <mkdir dir="${pkg.doc}"/>
+@@ -305,7 +426,7 @@
+ <!-- =================================================================== -->
+ <!-- create javadoc for IETF ldap classes -->
+ <!-- =================================================================== -->
+- <target name="docietfldap" depends="init, setupDoc">
++ <target name="docietfldap" depends="init">
+ <delete dir="${pkg.ietfdoc}"/>
+ <echo message="Creating distribution ldap javadoc"/>
+ <mkdir dir="${pkg.ietfdoc}"/>
+@@ -326,7 +447,7 @@
+ <!-- =================================================================== -->
+ <!-- create javadoc for all LDAP classes for internal developer use only -->
+ <!-- =================================================================== -->
+- <target name="docdeveloper" depends="init, setupDoc">
++ <target name="docdeveloper" depends="init">
+ <delete dir="${pkg.developer}"/>
+ <echo message="Creating internal developer ldap javadoc"/>
+ <mkdir dir="${doc.developer}"/>
+@@ -335,6 +456,8 @@
+ destdir="${doc.developer}"
+ classpath="${lib.debug}/${ldap}.jar;external/jsse/lib/jcert.jar;external/jsse/lib/jnet.jar;external/jsse/lib/jsse.jar;external/jaxp/jaxp.jar;external/jaxp/xerces.jar"
+ packagenames="org.ietf.ldap,com.novell.security.sasl,com.novell.sasl.client,com.novell.ldap.asn1,com.novell.ldap.client,com.novell.ldap.rfc2251,com.novell.ldap.resources,com.novell.ldap.extensions,com.novell.ldap.controls,com.novell.ldap.util,com.novell.ldap"
++ encoding="UTF-8"
++ failonerror="no"
+ Windowtitle="LDAP Classes"
+ Splitindex="true"
+ Private="true"
diff --git a/dev-java/jldap/jldap-4.6.ebuild b/dev-java/jldap/jldap-4.6.ebuild
new file mode 100644
index 000000000000..c08f8e5fdea7
--- /dev/null
+++ b/dev-java/jldap/jldap-4.6.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jldap/jldap-4.6.ebuild,v 1.1 2015/07/05 17:32:14 monsieurp Exp $
+EAPI=5
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="LDAP Class Libraries for Java (JLDAP)"
+HOMEPAGE="http://www.openldap.org/jldap/"
+SRC_URI="http://dev.gentoo.org/~monsieurp/packages/${P}.tar.gz"
+
+LICENSE="OPENLDAP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc source"
+
+CDEPEND="dev-java/openspml:0
+ dev-java/openspml2:0
+ dev-java/commons-httpclient:3
+ dev-java/junit:0"
+
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+
+DEPEND=">=virtual/jdk-1.6
+ app-arch/zip
+ ${CDEPEND}"
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+EANT_GENTOO_CLASSPATH="openspml,openspml2,commons-httpclient-3"
+
+EANT_BUILD_TARGET="release"
+EANT_BUILD_XML="build.xml"
+
+EANT_DOC_TARGET="docdeveloper"
+
+# [0]: complete rewrite of build.xml
+# [1]: disable debugging at compile time
+PATCHES=(
+ "${FILESDIR}"/${P}-build.xml.patch
+ "${FILESDIR}"/${P}-Debug.java.patch
+)
+
+java_prepare() {
+ epatch ${PATCHES[@]}
+}
+
+EANT_TEST_GENTOO_CLASSPATH="${EANT_GENTOO_CLASSPATH},junit"
+EANT_TEST_TARGET="test"
+
+src_test() {
+ EANT_GENTOO_CLASSPATH_EXTRA="${S}/lib/${PN}.jar"
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_dojar lib/${PN}.jar
+
+ dodoc README README.dsml || die
+ dohtml *.html || die
+
+ if use doc; then
+ dodoc design/* || die
+ java-pkg_dojavadoc doc
+ fi
+
+ use source && java-pkg_dosrc org com
+}
diff --git a/dev-java/jldap/metadata.xml b/dev-java/jldap/metadata.xml
index 6f98a82ca60b..277fc50e2f5e 100644
--- a/dev-java/jldap/metadata.xml
+++ b/dev-java/jldap/metadata.xml
@@ -2,9 +2,12 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>java</herd>
+<maintainer>
+ <email>monsieurp@gentoo.org</email>
+</maintainer>
<longdescription>
-The LDAP Class Libraries for Java (JLDAP) enable you to write applications to
-access, manage, update, and search for information stored in directories
-accessible using LDAPv3. JLDAP was developed by Novell.
+ The LDAP Class Libraries for Java (JLDAP) enable you to write applications to
+ access, manage, update, and search for information stored in directories
+ accessible using LDAPv3. JLDAP was developed by Novell.
</longdescription>
</pkgmetadata>