summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2004-10-30 18:52:14 +0000
committerThomas Matthijs <axxo@gentoo.org>2004-10-30 18:52:14 +0000
commitb98d3900bbd842af08102cfc5be9ef68b8a08d7c (patch)
tree8dd6448daca4103dc597a8429a54479f228a38af /dev-java/jms/jms-1.1.ebuild
parentsun-bcla-jms (diff)
downloadgentoo-2-b98d3900bbd842af08102cfc5be9ef68b8a08d7c.tar.gz
gentoo-2-b98d3900bbd842af08102cfc5be9ef68b8a08d7c.tar.bz2
gentoo-2-b98d3900bbd842af08102cfc5be9ef68b8a08d7c.zip
inital import, ebuild contributed by Dan <dan@intuitivelyobvious.net>
Diffstat (limited to 'dev-java/jms/jms-1.1.ebuild')
-rw-r--r--dev-java/jms/jms-1.1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-java/jms/jms-1.1.ebuild b/dev-java/jms/jms-1.1.ebuild
new file mode 100644
index 000000000000..900c4537b43d
--- /dev/null
+++ b/dev-java/jms/jms-1.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jms/jms-1.1.ebuild,v 1.1 2004/10/30 18:52:14 axxo Exp $
+
+inherit java-pkg
+
+At="jms-${PV/./_}-fr-apidocs.zip"
+DESCRIPTION="The Java Message Service (JMS) API is a messaging standard that allows application components to create, send, receive, and read messages."
+HOMEPAGE="http://java.sun.com/products/jms/"
+SRC_URI="${At}"
+LICENSE="sun-bcla-jms"
+SLOT=0
+KEYWORDS="~x86 ~amd64"
+IUSE="jikes doc"
+RDEPEND=">=virtual/jre-1.3"
+DEPEND="app-arch/unzip
+ >=virtual/jdk-1.3"
+RESTRICT="fetch"
+
+S=${WORKDIR}/${PN}${PV}
+
+pkg_nofetch() {
+ einfo " "
+ einfo " Due to license restrictions, we cannot fetch the"
+ einfo " distributables automagically."
+ einfo " "
+ einfo " 1. Visit ${HOMEPAGE} and select 'Downloads'"
+ einfo " 2. Select 'Download the version 1.1 API Documentation, Jar and Source'"
+ einfo " 3. Download ${At}"
+ einfo " 4. Move file to ${DISTDIR}"
+ einfo " "
+}
+
+src_compile() {
+ mkdir build
+ cd src/share
+ javac_cmd="javac"
+ use jikes && java_cmd="jikes -bootclasspath ${JAVA_HOME}/jre/lib/rt.jar"
+
+ ${javac_cmd} -nowarn -d ${S}/build $(find -name "*.java")
+ if use doc ; then
+ mkdir ${S}/api
+ javadoc -d ${S}/api -quiet javax.jms
+ fi
+
+ cd ${S}
+ jar cf jms.jar -C build .
+}
+
+src_install() {
+ java-pkg_dojar jms.jar
+ use doc && java-pkg_dohtml -r api
+}
+