summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-01-31 18:42:40 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-01-31 18:42:40 +0000
commit6215f8e3bf9d4f206b502b2e2df1bf7fcff3dede (patch)
tree63c25330d95ac22316692561593798310925e4ed /dev-java/jss/jss-4.2.ebuild
parentAdded ~ppc64; bug #160285 (diff)
downloadgentoo-2-6215f8e3bf9d4f206b502b2e2df1bf7fcff3dede.tar.gz
gentoo-2-6215f8e3bf9d4f206b502b2e2df1bf7fcff3dede.tar.bz2
gentoo-2-6215f8e3bf9d4f206b502b2e2df1bf7fcff3dede.zip
Version bump. Fixes bug #164607 and hopefully bug #164056. Dropped amd64 keywords because I could not test if the changes work there.
(Portage version: 2.1.2-r5)
Diffstat (limited to 'dev-java/jss/jss-4.2.ebuild')
-rw-r--r--dev-java/jss/jss-4.2.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/dev-java/jss/jss-4.2.ebuild b/dev-java/jss/jss-4.2.ebuild
new file mode 100644
index 000000000000..6cbbd7529e3f
--- /dev/null
+++ b/dev-java/jss/jss-4.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jss/jss-4.2.ebuild,v 1.1 2007/01/31 18:42:40 betelgeuse Exp $
+
+inherit eutils java-pkg-2 versionator
+
+RTM_NAME="JSS_${PV//./_}_RTM"
+DESCRIPTION="Network Security Services for Java (JSS)"
+HOMEPAGE="http://www.mozilla.org/projects/security/pki/jss/"
+# To prepare this tarball
+# cvs -d :pserver:anonymous@cvs-mirror.mozilla.org:/cvsroot export \
+# -r JSS_4_2_RTM mozilla/security/corefonf
+# cvs -d :pserver:anonymous@cvs-mirror.mozilla.org:/cvsroot export \
+# -r JSS_4_2_RTM mozilla/security/jss
+# tar cvjf jss-4.2.tar.bz2 mozilla
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="MPL-1.1"
+SLOT="3.4"
+KEYWORDS="~x86"
+IUSE="doc examples source"
+
+RDEPEND=">=virtual/jre-1.4
+ >=dev-libs/nspr-4.3
+ >=dev-libs/nss-3.9.2"
+DEPEND=">=virtual/jdk-1.4
+ ${RDEPEND}
+ app-arch/zip
+ dev-util/pkgconfig
+ >=sys-apps/sed-4"
+
+S=${WORKDIR}/mozilla
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}/${PN}-3.4-target_source.patch"
+ epatch "${FILESDIR}/${PN}-4.2-pkg-config.patch"
+
+ echo "INCLUDES += -I${ROOT}usr/include/nss -I${ROOT}usr/include/nspr" \
+ >> "${S}"/security/coreconf/headers.mk || die
+}
+
+src_compile() {
+ export JAVA_GENTOO_OPTS="-target $(java-pkg_get-target) -source $(java-pkg_get-source)"
+ cd "${S}/security/coreconf" || die
+ emake -j1 BUILD_OPT=1 || die "coreconf make failed"
+
+ cd "${S}/security/jss" || die
+ emake -j1 BUILD_OPT=1 || die "jss make failed"
+ if use doc; then
+ emake -j1 BUILD_OPT=1 javadoc || die "failed to create javadocs"
+ fi
+}
+
+src_test() {
+ BUILD_OPT=1 perl security/jss/org/mozilla/jss/tests/all.pl dist \
+ "${S}"/dist/Linux*.OBJ/
+}
+
+src_install() {
+ java-pkg_dojar dist/*.jar
+ # Use this instead of the one in dist because it is a symlink
+ # and doso handles symlinks by just symlinking to the original
+ java-pkg_doso ./security/${PN}/lib/*/*.so
+ use doc && java-pkg_dojavadoc dist/jssdoc
+ use source && java-pkg_dosrc ./security/jss/org
+ if use examples; then
+ docinto examples
+ dodoc ./security/jss/samples/*
+ fi
+}