summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2008-12-06 13:32:57 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2008-12-06 13:32:57 +0000
commit72f3c64f94d6a383baf39179b91cee67820e2e23 (patch)
tree6e0c9fce141873a5f42d79eae630c76c71d0b84a /dev-java/sun-jdk
parentFix another cp command to POSIX. (diff)
downloadgentoo-2-72f3c64f94d6a383baf39179b91cee67820e2e23.tar.gz
gentoo-2-72f3c64f94d6a383baf39179b91cee67820e2e23.tar.bz2
gentoo-2-72f3c64f94d6a383baf39179b91cee67820e2e23.zip
Version bumps for security bug #250012.
(Portage version: 2.1.6_rc2/cvs/Linux 2.6.27-gentoo-r2 i686)
Diffstat (limited to 'dev-java/sun-jdk')
-rw-r--r--dev-java/sun-jdk/ChangeLog11
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.4.2.19.ebuild168
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.5.0.17.ebuild138
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.6.0.11.ebuild148
4 files changed, 464 insertions, 1 deletions
diff --git a/dev-java/sun-jdk/ChangeLog b/dev-java/sun-jdk/ChangeLog
index dfd0266593c6..216d64db496d 100644
--- a/dev-java/sun-jdk/ChangeLog
+++ b/dev-java/sun-jdk/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-java/sun-jdk
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/ChangeLog,v 1.248 2008/11/22 15:03:44 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/ChangeLog,v 1.249 2008/12/06 13:32:57 betelgeuse Exp $
+
+*sun-jdk-1.6.0.11 (06 Dec 2008)
+*sun-jdk-1.5.0.17 (06 Dec 2008)
+*sun-jdk-1.4.2.19 (06 Dec 2008)
+
+ 06 Dec 2008; Petteri Räty <betelgeuse@gentoo.org>
+ +sun-jdk-1.4.2.19.ebuild, +sun-jdk-1.5.0.17.ebuild,
+ +sun-jdk-1.6.0.11.ebuild:
+ Version bumps for security bug #250012.
22 Nov 2008; Markus Meier <maekke@gentoo.org> sun-jdk-1.6.0.10.ebuild:
x86 stable, bug #246995
diff --git a/dev-java/sun-jdk/sun-jdk-1.4.2.19.ebuild b/dev-java/sun-jdk/sun-jdk-1.4.2.19.ebuild
new file mode 100644
index 000000000000..07dc8c500f52
--- /dev/null
+++ b/dev-java/sun-jdk/sun-jdk-1.4.2.19.ebuild
@@ -0,0 +1,168 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.4.2.19.ebuild,v 1.1 2008/12/06 13:32:57 betelgeuse Exp $
+
+JAVA_SUPPORTS_GENERATION_1="true"
+inherit pax-utils java-vm-2 eutils
+
+MY_PV=${PV%.*}_${PV##*.}
+MY_PN=j2sdk
+MY_P=${MY_PN}${MY_PV}
+MY_PVB=${PV%.*}
+
+At="j2sdk-${PV//./_}-linux-i586.bin"
+jce_policy="jce_policy-${MY_PVB//./_}.zip"
+
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Sun's J2SE Development Kit"
+HOMEPAGE="http://java.sun.com/j2se/1.4.2/"
+SRC_URI="x86? ( ${At} )
+ jce? ( ${jce_policy} )"
+SLOT="1.4"
+LICENSE="sun-bcla-java-vm"
+KEYWORDS="~x86"
+# files are prestripped
+RESTRICT="fetch strip"
+IUSE="X alsa doc examples jce nsplugin odbc"
+
+DEPEND="sys-apps/sed
+ app-arch/unzip"
+
+RDEPEND="
+ alsa? ( media-libs/alsa-lib )
+ doc? ( =dev-java/java-sdk-docs-1.4.2* )
+ X? (
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXp
+ x11-libs/libXtst
+ x11-libs/libXt
+ x11-libs/libX11
+ )
+ odbc? ( dev-db/unixODBC )"
+
+JAVA_PROVIDE="jdbc-stdext"
+
+DL_PREFIX="https://cds.sun.com/is-bin/INTERSHOP.enfinity/WFS/CDS-CDS_Developer-Site/en_US/-/USD/ViewProductDetail-Start?ProductRef="
+DOWNLOAD_URL="${DL_PREFIX}${MY_PN}-${MY_PV}-oth-JPR@CDS-CDS_Developer"
+DOWNLOAD_URL_JCE="${DL_PREFIX}7503-jce-1.4.2-oth-JPR@CDS-CDS_Developer"
+
+QA_TEXTRELS_x86="opt/${P}/jre/lib/i386/libawt.so
+ opt/${P}/jre/plugin/i386/ns4/libjavaplugin.so
+ opt/${P}/jre/plugin/i386/ns610/libjavaplugin_oji.so
+ opt/${P}/jre/plugin/i386/ns610-gcc32/libjavaplugin_oji.so"
+
+pkg_nofetch() {
+ einfo "Please download ${At} from:"
+ einfo ${DOWNLOAD_URL}
+ einfo "and move it to ${DISTDIR}"
+ if use jce; then
+ echo
+ einfo "Also download ${jce_policy} from:"
+ einfo ${DOWNLOAD_URL_JCE}
+ einfo "Java(TM) Cryptography Extension (JCE) Unlimited Strength Jurisdiction Policy Files"
+ einfo "and move it to ${DISTDIR}"
+ fi
+}
+
+src_unpack() {
+ if [ ! -r "${DISTDIR}/${At}" ]; then
+ die "cannot read ${At}. Please check the permission and try again."
+ fi
+ if use jce; then
+ if [ ! -r "${DISTDIR}/${jce_policy}" ]; then
+ die "cannot read ${jce_policy}. Please check the permission and try again."
+ fi
+ fi
+ #Search for the ELF Header
+ testExp=$(echo -e '\0177\0105\0114\0106\0001\0001\0001')
+ startAt=`grep -aonm 1 ${testExp} ${DISTDIR}/${At} | cut -d: -f1`
+ tail -n +${startAt} "${DISTDIR}/${At}" > install.sfx
+ chmod +x install.sfx
+ ./install.sfx || die
+ rm install.sfx
+
+ if [[ -f ${S}/lib/unpack ]]; then
+ UNPACK_CMD=${S}/lib/unpack
+ chmod +x $UNPACK_CMD
+ sed -i 's#/tmp/unpack.log#/dev/null\x00\x00\x00\x00\x00\x00#g' $UNPACK_CMD
+ local PACKED_JARS="lib/tools.jar jre/lib/rt.jar jre/lib/jsse.jar \
+ jre/lib/charsets.jar jre/lib/ext/localedata.jar jre/lib/plugin.jar \
+ jre/javaws/javaws.jar"
+ for i in $PACKED_JARS; do
+ PACK_FILE=${S}/`dirname $i`/`basename $i .jar`.pack
+ if [ -f ${PACK_FILE} ]; then
+ echo " unpacking: $i"
+ $UNPACK_CMD ${PACK_FILE} "${S}"/$i
+ rm -f ${PACK_FILE}
+ fi
+ done
+ fi
+}
+
+src_install() {
+ local dirs="bin include jre lib man"
+ dodir /opt/${P}
+
+ cp -dPR ${dirs} "${D}/opt/${P}/"
+
+ # Set PaX markings on all JDK/JRE executables to allow code-generation on
+ # the heap by the JIT compiler.
+ pax-mark srpm $(list-paxables "${D}"/opt/${P}/{,/jre}/bin/*)
+
+ dodoc COPYRIGHT README THIRDPARTYLICENSEREADME.txt || die
+ dohtml README.html || die
+ if use examples; then
+ cp -pPR demo "${D}/opt/${P}/" || die
+ fi
+
+ cp -pPR src.zip "${D}/opt/${P}/" || die
+
+ if use jce ; then
+ # Using unlimited jce while still retaining the strong jce
+ # May have repercussions when you find you cannot symlink libraries
+ # in classpaths.
+ cd "${D}/opt/${P}/jre/lib/security"
+ unzip "${DISTDIR}/${jce_policy}"
+ mv jce unlimited-jce
+ dodir /opt/${P}/jre/lib/security/strong-jce
+ mv "${D}/opt/${P}/jre/lib/security/US_export_policy.jar" \
+ "${D}/opt/${P}/jre/lib/security/strong-jce" || die
+ mv "${D}/opt/${P}/jre/lib/security/local_policy.jar" \
+ "${D}/opt/${P}/jre/lib/security/strong-jce" || die
+ dosym /opt/${P}/jre/lib/security/unlimited-jce/US_export_policy.jar /opt/${P}/jre/lib/security/
+ dosym /opt/${P}/jre/lib/security/unlimited-jce/local_policy.jar /opt/${P}/jre/lib/security/
+ fi
+
+ if use nsplugin; then
+ local plugin_dir="ns610"
+ if has_version '>=sys-devel/gcc-3.2' ; then
+ plugin_dir="ns610-gcc32"
+ fi
+
+ install_mozilla_plugin /opt/${P}/jre/plugin/i386/${plugin_dir}/libjavaplugin_oji.so
+ fi
+
+ # bug #147259
+ dosym ../jre/javaws/javaws /opt/${P}/bin/javaws
+ dosym ../javaws/javaws /opt/${P}/jre/bin/javaws
+
+ # create dir for system preferences
+ dodir /opt/${P}/.systemPrefs
+ # Create files used as storage for system preferences.
+ touch "${D}/opt/${P}/.systemPrefs/.system.lock"
+ chmod 644 "${D}/opt/${P}/.systemPrefs/.system.lock"
+ touch "${D}/opt/${P}/.systemPrefs/.systemRootModFile"
+ chmod 644 "${D}/opt/${P}/.systemPrefs/.systemRootModFile"
+
+ # install control panel for Gnome/KDE
+ sed -e "s/INSTALL_DIR\/JRE_NAME_VERSION/\/opt\/${P}\/jre/" \
+ -e "s/\(Name=Java\)/\1 Control Panel ${SLOT}/" \
+ "${D}/opt/${P}/jre/plugin/desktop/sun_java.desktop" > \
+ "${T}/sun_java-${SLOT}.desktop"
+
+ domenu "${T}/sun_java-${SLOT}.desktop"
+
+ set_java_env
+ java-vm_revdep-mask
+}
diff --git a/dev-java/sun-jdk/sun-jdk-1.5.0.17.ebuild b/dev-java/sun-jdk/sun-jdk-1.5.0.17.ebuild
new file mode 100644
index 000000000000..66c156512e7a
--- /dev/null
+++ b/dev-java/sun-jdk/sun-jdk-1.5.0.17.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.5.0.17.ebuild,v 1.1 2008/12/06 13:32:57 betelgeuse Exp $
+
+inherit versionator java-vm-2 eutils pax-utils
+
+UPDATE="$(get_version_component_range 4)"
+UPDATE="${UPDATE#0}"
+MY_PV="$(get_version_component_range 2-3)u${UPDATE}"
+
+X86_AT="jdk-${MY_PV}-dlj-linux-i586.bin"
+AMD64_AT="jdk-${MY_PV}-dlj-linux-amd64.bin"
+
+DESCRIPTION="Sun's J2SE Development Kit, version 1.5"
+HOMEPAGE="http://java.sun.com/j2se/1.5.0/"
+SRC_URI="x86? ( http://download.java.net/dlj/binaries/${X86_AT} )
+ amd64? ( http://download.java.net/dlj/binaries/${AMD64_AT} )"
+SLOT="1.5"
+LICENSE="dlj-1.1"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="strip"
+IUSE="X alsa doc examples jce nsplugin odbc"
+
+QA_TEXTRELS_x86="opt/${P}/jre/lib/i386/motif21/libmawt.so opt/${P}/jre/lib/i386/libdeploy.so"
+
+DEPEND="jce? ( =dev-java/sun-jce-bin-1.5.0* )"
+RDEPEND="sys-libs/glibc
+ alsa? ( media-libs/alsa-lib )
+ doc? ( =dev-java/java-sdk-docs-1.5.0* )
+ X? (
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXp
+ x11-libs/libXtst
+ x11-libs/libXt
+ x11-libs/libX11
+ )
+ odbc? ( dev-db/unixODBC )"
+
+S="${WORKDIR}/jdk$(replace_version_separator 3 _)"
+
+JAVA_PROVIDE="jdbc-stdext jdbc-rowset"
+
+src_unpack() {
+ sh "${DISTDIR}/${A}" --accept-license --unpack || die "Failed to unpack"
+}
+
+src_compile() {
+ # Set PaX markings on all JDK/JRE executables to allow code-generation on
+ # the heap by the JIT compiler. This needs to be done before CDS - #215225
+ pax-mark m $(list-paxables "${S}"{,/jre}/bin/*)
+
+ # see bug #207282
+ if use x86; then
+ einfo "Creating the Class Data Sharing archives"
+ "${S}"/bin/java -client -Xshare:dump || die
+ fi
+}
+
+src_install() {
+ local dirs="bin include jre lib man"
+
+ dodir /opt/${P}
+
+ cp -pPR ${dirs} "${D}/opt/${P}/" || die "failed to copy"
+ dodoc COPYRIGHT README.html || die
+ dohtml README.html || die
+
+ cp -pP src.zip "${D}/opt/${P}/" || die
+
+ if use examples; then
+ cp -pPR demo "${D}/opt/${P}/" || die
+ cp -pPR sample "${D}/opt/${P}/" || die
+ fi
+
+ if use jce; then
+ cd "${D}"/opt/${P}/jre/lib/security || die
+ dodir /opt/${P}/jre/lib/security/strong-jce
+ mv "${D}"/opt/${P}/jre/lib/security/US_export_policy.jar \
+ "${D}"/opt/${P}/jre/lib/security/strong-jce || die
+ mv "${D}"/opt/${P}/jre/lib/security/local_policy.jar \
+ "${D}"/opt/${P}/jre/lib/security/strong-jce || die
+ local jcedir="/opt/sun-jce-bin-1.5.0/jre/lib/security/unlimited-jce/"
+ dosym ${jcedir}/US_export_policy.jar \
+ /opt/${P}/jre/lib/security/ || die
+ dosym ${jcedir}/local_policy.jar \
+ /opt/${P}/jre/lib/security/ || die
+ fi
+
+ if use nsplugin; then
+ local plugin_dir="ns7-gcc29"
+ if has_version '>=sys-devel/gcc-3' ; then
+ plugin_dir="ns7"
+ fi
+
+ if use x86 ; then
+ install_mozilla_plugin /opt/${P}/jre/plugin/i386/$plugin_dir/libjavaplugin_oji.so
+ else
+ eerror "No plugin available for amd64 arch"
+ fi
+ fi
+
+ # create dir for system preferences
+ dodir /opt/${P}/jre/.systemPrefs
+ # Create files used as storage for system preferences.
+ touch "${D}"/opt/${P}/jre/.systemPrefs/.system.lock
+ chmod 644 "${D}"/opt/${P}/jre/.systemPrefs/.system.lock
+ touch "${D}"/opt/${P}/jre/.systemPrefs/.systemRootModFile
+ chmod 644 "${D}"/opt/${P}/jre/.systemPrefs/.systemRootModFile
+
+ # install control panel for Gnome/KDE
+ if [[ -f ${D}/opt/${P}/jre/plugin/desktop/sun_java.desktop ]]; then
+ sed -e "s/INSTALL_DIR\/JRE_NAME_VERSION/\/opt\/${P}\/jre/" \
+ -e "s/\(Name=Java\)/\1 Control Panel ${SLOT}/" \
+ "${D}"/opt/${P}/jre/plugin/desktop/sun_java.desktop > \
+ "${T}"/sun_java-${SLOT}.desktop \
+ || die "Failed to sed .desktop file"
+
+ domenu "${T}"/sun_java-${SLOT}.desktop
+ fi
+
+ # bug #56444
+ insinto /opt/${P}/jre/lib/
+ newins "${FILESDIR}"/fontconfig.Gentoo.properties fontconfig.properties
+
+ set_java_env
+ java-vm_revdep-mask
+}
+
+pkg_postinst() {
+ # Set as default VM if none exists
+ java-vm-2_pkg_postinst
+
+ elog "The epoll-based implementation of SelectorProvider is not selected by"
+ elog "default."
+ elog "Use java -Djava.nio.channels.spi.SelectorProvider=sun.nio.ch.EPollSelectorProvider"
+ elog ""
+}
diff --git a/dev-java/sun-jdk/sun-jdk-1.6.0.11.ebuild b/dev-java/sun-jdk/sun-jdk-1.6.0.11.ebuild
new file mode 100644
index 000000000000..e250bcd937ed
--- /dev/null
+++ b/dev-java/sun-jdk/sun-jdk-1.6.0.11.ebuild
@@ -0,0 +1,148 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.6.0.11.ebuild,v 1.1 2008/12/06 13:32:57 betelgeuse Exp $
+
+inherit versionator java-vm-2 eutils pax-utils
+
+UPDATE="$(get_version_component_range 4)"
+UPDATE="${UPDATE#0}"
+MY_PV="$(get_version_component_range 2)u${UPDATE}"
+X86_AT="jdk-${MY_PV}-dlj-linux-i586.bin"
+AMD64_AT="jdk-${MY_PV}-dlj-linux-amd64.bin"
+
+DESCRIPTION="Sun's J2SE Development Kit, version ${PV}"
+HOMEPAGE="http://java.sun.com/javase/6/"
+URL_BASE="http://download.java.net/dlj/binaries"
+SRC_URI="x86? ( ${URL_BASE}/${X86_AT} )
+ amd64? ( ${URL_BASE}/${AMD64_AT} )"
+SLOT="1.6"
+LICENSE="dlj-1.1"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="strip"
+IUSE="X alsa doc examples jce nsplugin odbc"
+
+QA_TEXTRELS_x86="opt/${P}/jre/lib/i386/motif21/libmawt.so
+ opt/${P}/jre/lib/i386/libdeploy.so
+ opt/${P}/jre/lib/i386/client/libjvm.so
+ opt/${P}/jre/lib/i386/server/libjvm.so"
+
+DEPEND="jce? ( =dev-java/sun-jce-bin-1.6.0* )"
+RDEPEND="doc? ( =dev-java/java-sdk-docs-1.6.0* )
+ sys-libs/glibc
+ alsa? ( media-libs/alsa-lib )
+ X? (
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXp
+ x11-libs/libXtst
+ amd64? ( x11-libs/libXt )
+ x11-libs/libX11
+ )
+ odbc? ( dev-db/unixODBC )"
+
+JAVA_PROVIDE="jdbc-stdext jdbc-rowset"
+
+S="${WORKDIR}/jdk$(replace_version_separator 3 _)"
+
+src_unpack() {
+ sh "${DISTDIR}"/${A} --accept-license --unpack || die "Failed to unpack"
+}
+
+src_compile() {
+ # Set PaX markings on all JDK/JRE executables to allow code-generation on
+ # the heap by the JIT compiler. This needs to be done before CDS - #215225
+ pax-mark m $(list-paxables "${S}"{,/jre}/bin/*)
+
+ # see bug #207282
+ if use x86; then
+ einfo "Creating the Class Data Sharing archives"
+ "${S}"/bin/java -client -Xshare:dump || die
+ "${S}"/bin/java -server -Xshare:dump || die
+ fi
+}
+
+src_install() {
+ local dirs="bin include jre lib man"
+
+ dodir /opt/${P}
+
+ cp -pPR $dirs "${D}/opt/${P}/" || die "failed to copy"
+ dodoc COPYRIGHT || die
+ dohtml README.html || die
+
+ cp -pP src.zip "${D}/opt/${P}/" || die
+
+ if use examples; then
+ cp -pPR demo sample "${D}/opt/${P}/" || die
+ fi
+
+ if use jce; then
+ cd "${D}/opt/${P}/jre/lib/security"
+ dodir /opt/${P}/jre/lib/security/strong-jce
+ mv "${D}"/opt/${P}/jre/lib/security/US_export_policy.jar \
+ "${D}"/opt/${P}/jre/lib/security/strong-jce || die
+ mv "${D}"/opt/${P}/jre/lib/security/local_policy.jar \
+ "${D}"/opt/${P}/jre/lib/security/strong-jce || die
+ dosym /opt/sun-jce-bin-1.6.0/jre/lib/security/unlimited-jce/US_export_policy.jar /opt/${P}/jre/lib/security/
+ dosym /opt/sun-jce-bin-1.6.0/jre/lib/security/unlimited-jce/local_policy.jar /opt/${P}/jre/lib/security/
+ fi
+
+ if use nsplugin; then
+ local plugin_dir="ns7-gcc29"
+ if has_version '>=sys-devel/gcc-3' ; then
+ plugin_dir="ns7"
+ fi
+
+ if use x86 ; then
+ install_mozilla_plugin /opt/${P}/jre/plugin/i386/$plugin_dir/libjavaplugin_oji.so
+ install_mozilla_plugin /opt/${P}/jre/lib/i386/libnpjp2.so plugin2
+ else
+ eerror "No plugin available for amd64 arch"
+ fi
+ fi
+
+ # create dir for system preferences
+ dodir /opt/${P}/jre/.systemPrefs
+ # Create files used as storage for system preferences.
+ touch "${D}"/opt/${P}/jre/.systemPrefs/.system.lock
+ chmod 644 "${D}"/opt/${P}/jre/.systemPrefs/.system.lock
+ touch "${D}"/opt/${P}/jre/.systemPrefs/.systemRootModFile
+ chmod 644 "${D}"/opt/${P}/jre/.systemPrefs/.systemRootModFile
+
+ if [[ -f "${D}"/opt/${P}/jre/plugin/desktop/sun_java.desktop ]]; then
+ # install control panel for Gnome/KDE
+ # The jre also installs these so make sure that they do not have the same
+ # Name
+ sed -e "s/\(Name=\)Java/\1 Java Control Panel for Sun JDK ${SLOT}/" \
+ -e "s#Exec=.*#Exec=/opt/${P}/jre/bin/ControlPanel#" \
+ -e "s#Icon=.*#Icon=/opt/${P}/jre/plugin/desktop/sun_java.png#" \
+ "${D}"/opt/${P}/jre/plugin/desktop/sun_java.desktop > \
+ "${T}"/sun_jdk-${SLOT}.desktop
+
+ domenu "${T}"/sun_jdk-${SLOT}.desktop
+ fi
+
+ # bug #56444
+ insinto /opt/${P}/jre/lib/
+ newins "${FILESDIR}"/fontconfig.Gentoo.properties fontconfig.properties
+
+ set_java_env
+ java-vm_revdep-mask
+}
+
+pkg_postinst() {
+ # Set as default VM if none exists
+ java-vm-2_pkg_postinst
+
+ if use x86 && use nsplugin; then
+ elog
+ elog "Two variants of the nsplugin are available via eselect java-nsplugin:"
+ elog "${VMHANDLE} and ${VMHANDLE}-plugin2 (the Next-Generation Plug-In) "
+ ewarn "Note that the ${VMHANDLE}-plugin2 works only in Firefox 3!"
+ elog "For more info see https://jdk6.dev.java.net/plugin2/"
+ elog
+ fi
+
+ elog "Please reinstall eclipse-sdk if you have it installed and want"
+ elog "workaround for bug #215150."
+}