summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-07-23 22:35:18 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-07-23 22:35:18 +0000
commit71617458c97c5e907eff2475af9f951f3797aee0 (patch)
tree78b10c933352b5332d367b278f01ce469289f6b1 /dev-java/xsdlib/xsdlib-20050627-r1.ebuild
parentRemove old ebuilds. (diff)
downloadgentoo-2-71617458c97c5e907eff2475af9f951f3797aee0.tar.gz
gentoo-2-71617458c97c5e907eff2475af9f951f3797aee0.tar.bz2
gentoo-2-71617458c97c5e907eff2475af9f951f3797aee0.zip
Migrated to Generation 2.
(Portage version: 2.1.1_pre3-r3)
Diffstat (limited to 'dev-java/xsdlib/xsdlib-20050627-r1.ebuild')
-rw-r--r--dev-java/xsdlib/xsdlib-20050627-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-java/xsdlib/xsdlib-20050627-r1.ebuild b/dev-java/xsdlib/xsdlib-20050627-r1.ebuild
new file mode 100644
index 000000000000..67dee63f469a
--- /dev/null
+++ b/dev-java/xsdlib/xsdlib-20050627-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xsdlib/xsdlib-20050627-r1.ebuild,v 1.1 2006/07/23 22:35:18 nelchael Exp $
+
+inherit java-pkg-2 java-ant-2
+
+MY_P="${PN}.${PV}"
+DESCRIPTION="The Sun Multi-Schema XML Validator is a Java tool to validate XML documents against several kinds of XML schemata."
+HOMEPAGE="https://msv.dev.java.net/"
+SRC_URI="mirror://gentoo/${MY_P}.zip"
+
+LICENSE="as-is Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc source"
+
+RDEPEND=">=virtual/jre-1.3
+ >=dev-java/xerces-2.6
+ dev-java/relaxng-datatype"
+DEPEND=">=virtual/jdk-1.3
+ app-arch/unzip
+ dev-java/ant-core
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp ${FILESDIR}/build-${PVR}.xml build.xml
+
+ rm *.jar
+ mkdir lib && cd lib
+ java-pkg_jarfrom relaxng-datatype
+ java-pkg_jarfrom xerces-2
+}
+
+src_compile() {
+ local antflags="-Dproject.name=${PN} jar"
+ use doc && antflags="${antflags} javadoc"
+
+ eant ${antflags} || die "Compilation failed"
+}
+
+src_install() {
+ java-pkg_dojar dist/${PN}.jar
+
+ dodoc README.txt
+ dohtml HowToUse.html
+
+ use doc && java-pkg_dohtml -r dist/doc/api
+ use source && java-pkg_dosrc src/* src-apache/*
+}