summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Thomson <wltjr@gentoo.org>2008-02-15 19:49:17 +0000
committerWilliam Thomson <wltjr@gentoo.org>2008-02-15 19:49:17 +0000
commit041f8eff7e29de97a5de13d28f55095042baeb36 (patch)
tree78be7110579202c57a3c13819f3926849b1528f2 /dev-java
parentRemove qimageblitz dependency from kdeutils modules that don't use it. Upstre... (diff)
downloadgentoo-2-041f8eff7e29de97a5de13d28f55095042baeb36.tar.gz
gentoo-2-041f8eff7e29de97a5de13d28f55095042baeb36.tar.bz2
gentoo-2-041f8eff7e29de97a5de13d28f55095042baeb36.zip
Bumped to latest release
(Portage version: 2.1.4.1)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/tomcat-native/ChangeLog8
-rw-r--r--dev-java/tomcat-native/tomcat-native-1.1.13.ebuild43
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-java/tomcat-native/ChangeLog b/dev-java/tomcat-native/ChangeLog
index 242d489d0a51..752c324f3b2c 100644
--- a/dev-java/tomcat-native/ChangeLog
+++ b/dev-java/tomcat-native/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/tomcat-native
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/tomcat-native/ChangeLog,v 1.12 2008/01/15 03:52:30 wltjr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/tomcat-native/ChangeLog,v 1.13 2008/02/15 19:49:17 wltjr Exp $
+
+*tomcat-native-1.1.13 (15 Feb 2008)
+
+ 15 Feb 2008; William L. Thomson Jr. <wltjr@gentoo.org>
+ +tomcat-native-1.1.13.ebuild:
+ Bumped to latest release
*tomcat-native-1.1.12 (15 Jan 2008)
diff --git a/dev-java/tomcat-native/tomcat-native-1.1.13.ebuild b/dev-java/tomcat-native/tomcat-native-1.1.13.ebuild
new file mode 100644
index 000000000000..7f4fbf3ea361
--- /dev/null
+++ b/dev-java/tomcat-native/tomcat-native-1.1.13.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/tomcat-native/tomcat-native-1.1.13.ebuild,v 1.1 2008/02/15 19:49:17 wltjr Exp $
+
+inherit eutils java-pkg-2
+
+DESCRIPTION="Native APR library for Tomcat"
+
+SLOT="0"
+SRC_URI="mirror://apache/tomcat/tomcat-connectors/native/${P}-src.tar.gz"
+HOMEPAGE="http://tomcat.apache.org/"
+KEYWORDS="~amd64 ~x86"
+LICENSE="Apache-2.0"
+
+RDEPEND="=dev-libs/apr-1*
+ dev-libs/openssl
+ >=virtual/jre-1.5"
+
+DEPEND=">=virtual/jdk-1.5
+ ${RDEPEND}"
+
+S=${WORKDIR}/${P}-src
+
+src_compile(){
+ cd "${S}"/jni/native
+ econf --with-apr=/usr/bin/apr-1-config \
+ --with-ssl=/usr || die "Could not configure native sources"
+ emake || die "Could not build libtcnative-1.so"
+}
+
+src_install() {
+ cd "${S}"/jni/native
+ make DESTDIR="${D}" install || die "Could not install libtcnative-1.so"
+}
+
+pkg_postinst() {
+ elog
+ elog " APR should be available with Tomcat, for more information"
+ elog " please see http://tomcat.apache.org/tomcat-6.0-doc/apr.html"
+ elog
+ elog " Please report any bugs to http://bugs.gentoo.org/"
+ elog
+}