summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDylan Carlson <absinthe@gentoo.org>2003-03-22 11:47:39 +0000
committerDylan Carlson <absinthe@gentoo.org>2003-03-22 11:47:39 +0000
commit24b9c1872a31a8d90a2b8074288dc79671b2264a (patch)
tree2d7480705dd959a237e55d0a621e695da3235f3e /dev-java
parentVersion bump. Uses jakarta-commons eclass now. Keywords ~x86. (diff)
downloadgentoo-2-24b9c1872a31a8d90a2b8074288dc79671b2264a.tar.gz
gentoo-2-24b9c1872a31a8d90a2b8074288dc79671b2264a.tar.bz2
gentoo-2-24b9c1872a31a8d90a2b8074288dc79671b2264a.zip
Initial import. Keywords ~x86.
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/commons-discovery/commons-discovery-0.1.ebuild30
-rw-r--r--dev-java/commons-discovery/files/digest-commons-discovery-0.11
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-java/commons-discovery/commons-discovery-0.1.ebuild b/dev-java/commons-discovery/commons-discovery-0.1.ebuild
new file mode 100644
index 000000000000..9f641300cb81
--- /dev/null
+++ b/dev-java/commons-discovery/commons-discovery-0.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-discovery/commons-discovery-0.1.ebuild,v 1.1 2003/03/22 11:47:39 absinthe Exp $
+
+inherit jakarta-commons
+
+S="${WORKDIR}/${P}-src/discovery"
+DESCRIPTION="The Discovery component is about discovering, or finding, implementations for pluggable interfaces."
+HOMEPAGE="http://jakarta.apache.org/commons/discovery.html"
+SRC_URI="http://www.apache.org/dist/jakarta/commons/discovery/source/discovery-${PV}-src.tar.gz"
+DEPEND=">=virtual/jdk-1.3
+ >=dev-java/commons-logging-1.0
+ >=dev-java/ant-1.4"
+RDEPEND=">=virtual/jdk-1.3"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc jikes junit"
+
+src_compile() {
+ [ -f LICENSE.txt ] && cp LICENSE.txt ../LICENSE
+ echo "logger.jar=`java-config --classpath=commons-logging`" | sed s/\=.*:/\=/ >> build.properties
+ jakarta-commons_src_compile myconf make
+ use doc && jakarta-commons_src_compile makedoc
+
+ # UGLY HACK
+ mv ${S}/target/conf/MANIFEST.MF ${S}/target/classes/
+ cd ${S}/target/classes
+ zip -r ../${PN}-${PV}.jar org
+}
diff --git a/dev-java/commons-discovery/files/digest-commons-discovery-0.1 b/dev-java/commons-discovery/files/digest-commons-discovery-0.1
new file mode 100644
index 000000000000..5c71caca1c5d
--- /dev/null
+++ b/dev-java/commons-discovery/files/digest-commons-discovery-0.1
@@ -0,0 +1 @@
+MD5 265e2577fdac53e19a9ec3feaea57673 discovery-0.1-src.tar.gz 69344