summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-02-14 19:51:35 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-02-14 19:51:35 +0000
commit91344418f77ceac7b35af836d08a80e649609955 (patch)
tree1abb989492eb5b8b6c586910061478f6c32649f7 /dev-java
parentKeyworded ~sparc (diff)
downloadgentoo-2-91344418f77ceac7b35af836d08a80e649609955.tar.gz
gentoo-2-91344418f77ceac7b35af836d08a80e649609955.tar.bz2
gentoo-2-91344418f77ceac7b35af836d08a80e649609955.zip
Fix dependencies and add src_test.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/exolabcore/ChangeLog9
-rw-r--r--dev-java/exolabcore/exolabcore-0.3.7_p20050205-r1.ebuild39
-rw-r--r--dev-java/exolabcore/files/0.3.7_p20050205-r1-tests-junit.patch12
3 files changed, 46 insertions, 14 deletions
diff --git a/dev-java/exolabcore/ChangeLog b/dev-java/exolabcore/ChangeLog
index 4ad018a0b9bb..390a43961529 100644
--- a/dev-java/exolabcore/ChangeLog
+++ b/dev-java/exolabcore/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/exolabcore
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/exolabcore/ChangeLog,v 1.9 2006/12/21 19:15:38 betelgeuse Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/exolabcore/ChangeLog,v 1.10 2007/02/14 19:51:35 betelgeuse Exp $
+
+ 14 Feb 2007; Petteri Räty <betelgeuse@gentoo.org>
+ +files/0.3.7_p20050205-r1-tests-junit.patch,
+ exolabcore-0.3.7_p20050205-r1.ebuild:
+ Fix dependencies and add src_test.
*exolabcore-0.3.7_p20050205-r1 (21 Dec 2006)
diff --git a/dev-java/exolabcore/exolabcore-0.3.7_p20050205-r1.ebuild b/dev-java/exolabcore/exolabcore-0.3.7_p20050205-r1.ebuild
index 0680e9f527c1..acf2b4590b9f 100644
--- a/dev-java/exolabcore/exolabcore-0.3.7_p20050205-r1.ebuild
+++ b/dev-java/exolabcore/exolabcore-0.3.7_p20050205-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/exolabcore/exolabcore-0.3.7_p20050205-r1.ebuild,v 1.1 2006/12/21 19:15:38 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/exolabcore/exolabcore-0.3.7_p20050205-r1.ebuild,v 1.2 2007/02/14 19:51:35 betelgeuse Exp $
inherit eutils java-pkg-2 java-ant-2
@@ -15,21 +15,23 @@ SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
LICENSE="Exolab"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc source"
+IUSE="doc source test"
COMMON_DEP="
dev-java/cdegroot-db
- dev-java/commons-cli
dev-java/commons-logging
- dev-java/exolabtools
- =dev-java/jakarta-oro-2.0*
- =dev-java/xerces-1.3*"
+ =dev-java/jakarta-oro-2.0*"
RDEPEND=">=virtual/jre-1.4
${COMMON_DEP}"
DEPEND=">=virtual/jdk-1.4
${COMMON_DEP}
- dev-java/ant-core
+ dev-java/exolabtools
+ test? (
+ dev-java/commons-cli
+ dev-java/log4j
+ dev-java/junit
+ )
source? ( app-arch/zip )"
S="${WORKDIR}/${MY_P}"
@@ -39,15 +41,13 @@ src_unpack() {
cd "${S}/src"
epatch "${FILESDIR}/${P}-buildfile.patch"
+ epatch "${FILESDIR}/0.3.7_p20050205-r1-tests-junit.patch"
cd "${S}/lib"
- rm -f *.jar
+ java-pkg_jar-from --build-only exolabtools
java-pkg_jar-from cdegroot-db-1
- java-pkg_jar-from commons-cli-1
java-pkg_jar-from commons-logging
- java-pkg_jar-from exolabtools
java-pkg_jar-from jakarta-oro-2.0 jakarta-oro.jar oro.jar
- java-pkg_jar-from xerces-1.3
}
src_compile() {
@@ -55,6 +55,21 @@ src_compile() {
java-pkg-2_src_compile
}
+src_test() {
+ cd "${S}/lib"
+ java-pkg_jar-from junit
+ java-pkg_jar-from commons-cli-1
+ java-pkg_jar-from log4j
+
+ cd "${S}/src"
+ eant tests
+ cd ..
+ local deps
+ deps="junit,commons-cli-1,log4j,cdegroot-db-1,commons-logging,jakarta-oro-2.0"
+ java -cp "build/classes:build/tests:$(java-config -p ${deps})" \
+ org.exolab.core.test.CoreTestSuite -execute || die "Tests failed"
+}
+
src_install() {
java-pkg_newjar dist/${PN}-${MY_PV}.jar ${PN}.jar
diff --git a/dev-java/exolabcore/files/0.3.7_p20050205-r1-tests-junit.patch b/dev-java/exolabcore/files/0.3.7_p20050205-r1-tests-junit.patch
new file mode 100644
index 000000000000..02d1b56c3400
--- /dev/null
+++ b/dev-java/exolabcore/files/0.3.7_p20050205-r1-tests-junit.patch
@@ -0,0 +1,12 @@
+diff -ur src.old/tests/unit/org/exolab/core/test/CoreTestSuite.java src/tests/unit/org/exolab/core/test/CoreTestSuite.java
+--- src.old/tests/unit/org/exolab/core/test/CoreTestSuite.java 2007-02-14 20:39:01.000000000 +0200
++++ src/tests/unit/org/exolab/core/test/CoreTestSuite.java 2007-02-14 20:39:21.000000000 +0200
+@@ -177,7 +177,7 @@
+
+ // execute the test suite and print the results
+ TestResult results = harness.execute(suite);
+- harness.getTestRunner().print(results);
++ //harness.getTestRunner().print(results);
+ }
+ } else {
+ usage();