summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2008-06-16 18:59:17 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2008-06-16 18:59:17 +0000
commitb24604ecb0291b274747c39489c6bc6042e0dc1f (patch)
treebca548efbb57f3b70344db41c22dc7bbf5dd264c /dev-java
parentStable for HPPA (bug #227525). (diff)
downloadgentoo-2-b24604ecb0291b274747c39489c6bc6042e0dc1f.tar.gz
gentoo-2-b24604ecb0291b274747c39489c6bc6042e0dc1f.tar.bz2
gentoo-2-b24604ecb0291b274747c39489c6bc6042e0dc1f.zip
Revision bump with patch for upstream bug with the jar task. Fixes bug #227465.
(Portage version: 2.1.5.4)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/ant-core/ChangeLog8
-rw-r--r--dev-java/ant-core/ant-core-1.7.0-r2.ebuild95
-rw-r--r--dev-java/ant-core/files/ant-core-1.7.0-services.patch12
3 files changed, 114 insertions, 1 deletions
diff --git a/dev-java/ant-core/ChangeLog b/dev-java/ant-core/ChangeLog
index 3667a3fc2982..c162fd0f4b9d 100644
--- a/dev-java/ant-core/ChangeLog
+++ b/dev-java/ant-core/ChangeLog
@@ -1,11 +1,17 @@
# ChangeLog for dev-java/ant-core
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-core/ChangeLog,v 1.80 2008/04/12 10:28:19 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-core/ChangeLog,v 1.81 2008/06/16 18:59:17 betelgeuse Exp $
# Ant-core blocks lower/older versions of ant-tasks,
# since it will not run when there is a version mismatch betwean the 2 packages
# Please unemerge ant-tasks when updating ant-core.
+*ant-core-1.7.0-r2 (16 Jun 2008)
+
+ 16 Jun 2008; Petteri Räty <betelgeuse@gentoo.org>
+ +files/ant-core-1.7.0-services.patch, +ant-core-1.7.0-r2.ebuild:
+ Revision bump with patch for upstream bug with the jar task. Fixes bug #227465.
+
12 Apr 2008; nixnut <nixnut@gentoo.org> ant-core-1.7.0-r1.ebuild:
Stable on ppc wrt bug 216258
diff --git a/dev-java/ant-core/ant-core-1.7.0-r2.ebuild b/dev-java/ant-core/ant-core-1.7.0-r2.ebuild
new file mode 100644
index 000000000000..9ee7ba30dab8
--- /dev/null
+++ b/dev-java/ant-core/ant-core-1.7.0-r2.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-core/ant-core-1.7.0-r2.ebuild,v 1.1 2008/06/16 18:59:17 betelgeuse Exp $
+
+# don't depend on itself
+JAVA_ANT_DISABLE_ANT_CORE_DEP=true
+# rewriting build.xml files for the testcases has no reason atm
+JAVA_PKG_BSFIX_ALL=no
+inherit java-pkg-2 java-ant-2
+
+MY_P="apache-ant-${PV}"
+
+DESCRIPTION="Java-based build tool similar to 'make' that uses XML configuration files."
+HOMEPAGE="http://ant.apache.org/"
+SRC_URI="mirror://apache/ant/source/${MY_P}-src.tar.bz2
+ mirror://gentoo/ant-${PV}-gentoo.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="doc source"
+
+# 1.7.0 instead of $PV in blocks is intentional, >1.7.0 upgrades should
+# be block free (but these fixed blocks should stay there for users upgrading
+# from <1.7.0 of course)
+RDEPEND=">=virtual/jdk-1.4
+ !<dev-java/ant-tasks-1.7.0
+ !<dev-java/ant-1.7.0
+ !dev-java/ant-optional"
+DEPEND="${RDEPEND}
+ source? ( app-arch/zip )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/ant-core-1.7.0-services.patch"
+
+ # remove bundled xerces
+ rm -v lib/*.jar
+
+ # use our split-ant build.xml
+ mv -f "${WORKDIR}/build.xml" .
+}
+
+src_compile() {
+ export ANT_HOME=""
+
+ local bsyscp
+
+ # this ensures that when building ant with bootstrapped ant,
+ # only the source is used for resolving references, and not
+ # the classes in bootstrapped ant
+ # but jikes in kaffe has issues with this...
+ if ! java-pkg_current-vm-matches kaffe; then
+ bsyscp="-Dbuild.sysclasspath=ignore"
+ fi
+
+ ./build.sh ${bsyscp} jars-core $(use_doc javadocs) \
+ || die "build failed"
+}
+
+src_install() {
+ newbin "${FILESDIR}/${PV}-ant" ant || die "failed to install wrapper"
+
+ dodir /usr/share/${PN}/bin
+ for each in antRun runant.pl runant.py complete-ant-cmd.pl ; do
+ dobin "${S}/src/script/${each}"
+ dosym /usr/bin/${each} /usr/share/${PN}/bin/${each}
+ done
+
+ echo "ANT_HOME=\"/usr/share/${PN}\"" > "${T}/20ant"
+ doenvd "${T}/20ant" || die "failed to install env.d file"
+
+ java-pkg_dojar build/lib/ant.jar
+ java-pkg_dojar build/lib/ant-bootstrap.jar
+ java-pkg_dojar build/lib/ant-launcher.jar
+
+ use source && java-pkg_dosrc src/main/*
+
+ dodoc README WHATSNEW KEYS
+
+ if use doc; then
+ dohtml welcome.html
+ dohtml -r docs/*
+ java-pkg_dojavadoc --symlink manual/api build/javadocs
+ fi
+}
+
+pkg_postinst() {
+ elog "The way of packaging ant in Gentoo has changed significantly since"
+ elog "the 1.7.0 version, For more information, please see:"
+ elog "http://www.gentoo.org/proj/en/java/ant-guide.xml"
+}
diff --git a/dev-java/ant-core/files/ant-core-1.7.0-services.patch b/dev-java/ant-core/files/ant-core-1.7.0-services.patch
new file mode 100644
index 000000000000..423e066d2c04
--- /dev/null
+++ b/dev-java/ant-core/files/ant-core-1.7.0-services.patch
@@ -0,0 +1,12 @@
+diff -r -U3 apache-ant-1.7.0/src/main/org/apache/tools/ant/taskdefs/Jar.java apache-ant-1.7.0.my/src/main/org/apache/tools/ant/taskdefs/Jar.java
+--- apache-ant-1.7.0/src/main/org/apache/tools/ant/taskdefs/Jar.java 2006-12-13 13:16:21.000000000 +0100
++++ apache-ant-1.7.0.my/src/main/org/apache/tools/ant/taskdefs/Jar.java 2008-06-16 17:58:08.000000000 +0200
+@@ -397,7 +397,7 @@
+ service = (Service) serviceIterator.next();
+ //stolen from writeManifest
+ super.zipFile(service.getAsStream(), zOut,
+- "META-INF/service/" + service.getType(),
++ "META-INF/services/" + service.getType(),
+ System.currentTimeMillis(), null,
+ ZipFileSet.DEFAULT_FILE_MODE);
+ }