summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-01 06:27:13 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-01 06:27:13 +0000
commitf58856538ab85b00d725b3569ed60bdd4ed556a5 (patch)
tree72ceb0d9eb33d511dc26ec9b7ba4a31d3b1fdd76 /dev-java
parentAdded dependencies (diff)
downloadgentoo-2-f58856538ab85b00d725b3569ed60bdd4ed556a5.tar.gz
gentoo-2-f58856538ab85b00d725b3569ed60bdd4ed556a5.tar.bz2
gentoo-2-f58856538ab85b00d725b3569ed60bdd4ed556a5.zip
Added dependencies
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/fesi/fesi-1.ebuild4
-rw-r--r--dev-java/jndi/jndi-1.2.1-r1.ebuild6
-rw-r--r--dev-java/mysql-jdbc/mysql-jdbc-1.2.3-r1.ebuild4
-rw-r--r--dev-java/xt/xt-1.ebuild6
4 files changed, 14 insertions, 6 deletions
diff --git a/dev-java/fesi/fesi-1.ebuild b/dev-java/fesi/fesi-1.ebuild
index 50b0bc03b9e3..7261e6514208 100644
--- a/dev-java/fesi/fesi-1.ebuild
+++ b/dev-java/fesi/fesi-1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-java/fesi/fesi-1.ebuild,v 1.2 2000/10/05 00:12:58 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/fesi/fesi-1.ebuild,v 1.3 2000/11/01 06:27:07 achim Exp $
P=fesi
A="fesikit.zip"
@@ -9,6 +9,8 @@ S=${WORKDIR}/${P}
DESCRIPTION="JavaScript Interpreter writte in Java"
SRC_URI="http://home.worldcom.ch/jmlugrin/fesi/fesikit.zip"
+DEPEND=">=dev-lang/jdk-1.2.2"
+
src_unpack() {
# jar -xf ${DISTDIR}/fesisrc.zip
jar -xf ${DISTDIR}/fesikit.zip
diff --git a/dev-java/jndi/jndi-1.2.1-r1.ebuild b/dev-java/jndi/jndi-1.2.1-r1.ebuild
index b595c4d5906b..c4067907801f 100644
--- a/dev-java/jndi/jndi-1.2.1-r1.ebuild
+++ b/dev-java/jndi/jndi-1.2.1-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jndi/jndi-1.2.1-r1.ebuild,v 1.2 2000/08/16 04:37:56 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jndi/jndi-1.2.1-r1.ebuild,v 1.3 2000/11/01 06:27:08 achim Exp $
P=jndi-1.2.1
A=jndi1_2_1.zip
@@ -10,12 +10,14 @@ DESCRIPTION="Java Naming and Directory Interface"
SRC_URI="ftp://"${A}
HOMEPAGE="http://java.sun.com/products/jndi/"
+DEPEND=">=dev-lang/jdk-1.2.2"
+
#Please download the sources from sun
src_unpack() {
mkdir ${S}
cd ${S}
- unzip ${DISTDIR}/${A}
+ jar -xf ${DISTDIR}/${A}
}
src_compile() {
diff --git a/dev-java/mysql-jdbc/mysql-jdbc-1.2.3-r1.ebuild b/dev-java/mysql-jdbc/mysql-jdbc-1.2.3-r1.ebuild
index c430bcdb2683..2fe3842ff320 100644
--- a/dev-java/mysql-jdbc/mysql-jdbc-1.2.3-r1.ebuild
+++ b/dev-java/mysql-jdbc/mysql-jdbc-1.2.3-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-java/mysql-jdbc/mysql-jdbc-1.2.3-r1.ebuild,v 1.1 2000/08/16 14:31:08 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/mysql-jdbc/mysql-jdbc-1.2.3-r1.ebuild,v 1.2 2000/11/01 06:27:08 achim Exp $
P=mysql-jdbc-1.2c
A=mm.mysql.jdbc-1.2c.tar.gz
@@ -10,6 +10,8 @@ DESCRIPTION="JDBC Driver for MySQL"
SRC_URI="http://www.mysql.com/Downloads/Contrib/"${A}
HOMEPAGE="http://www.mysql.com/"
+DEPEND=">=dev-lang/jdk-1.2.2"
+
src_unpack() {
unpack ${A}
}
diff --git a/dev-java/xt/xt-1.ebuild b/dev-java/xt/xt-1.ebuild
index a057ee0d1ec9..51c03c2c7920 100644
--- a/dev-java/xt/xt-1.ebuild
+++ b/dev-java/xt/xt-1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-java/xt/xt-1.ebuild,v 1.1 2000/08/16 18:55:59 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xt/xt-1.ebuild,v 1.2 2000/11/01 06:27:08 achim Exp $
P=xt
A=${P}.zip
@@ -9,10 +9,12 @@ S=${WORKDIR}/${P}
DESCRIPTION="Java Implementation of XSL-Transformations"
SRC_URI="ftp://ftp.jclark.com/pub/xml/"${A}
+DEPEND=">=dev-lang/jdk-1.2.2"
+
src_unpack() {
mkdir ${S}
cd ${S}
- unzip ${DISTDIR}/${A}
+ jar -xf ${DISTDIR}/${A}
}
src_compile() {