summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2007-10-06 14:21:28 +0000
committerMarkus Dittrich <markusle@gentoo.org>2007-10-06 14:21:28 +0000
commit7407361be54c98299c2aecef9764888e77d64cef (patch)
tree0d5622641adbf9f29851b3533f7e12c968c2b18f /dev-lang/R
parentFix from Paul Bredbury to make sure we respect CPPFLAGS #194264. (diff)
downloadgentoo-2-7407361be54c98299c2aecef9764888e77d64cef.tar.gz
gentoo-2-7407361be54c98299c2aecef9764888e77d64cef.tar.bz2
gentoo-2-7407361be54c98299c2aecef9764888e77d64cef.zip
Version bump (fixes bug #194767). Also removed obsolete versions and patches
(Portage version: 2.1.3.11)
Diffstat (limited to 'dev-lang/R')
-rw-r--r--dev-lang/R/ChangeLog8
-rw-r--r--dev-lang/R/R-2.4.1.ebuild116
-rw-r--r--dev-lang/R/R-2.6.0.ebuild (renamed from dev-lang/R/R-2.5.0.ebuild)6
-rw-r--r--dev-lang/R/files/R-2.2.0-ifc-configure.patch23
-rw-r--r--dev-lang/R/files/R-2.4.0-as-needed-gentoo.patch12
-rw-r--r--dev-lang/R/files/R-2.4.1-as-needed-gentoo.patch12
-rw-r--r--dev-lang/R/files/digest-R-2.4.13
-rw-r--r--dev-lang/R/files/digest-R-2.5.03
-rw-r--r--dev-lang/R/files/digest-R-2.6.03
9 files changed, 15 insertions, 171 deletions
diff --git a/dev-lang/R/ChangeLog b/dev-lang/R/ChangeLog
index 008ff69391fa..027ce192ed86 100644
--- a/dev-lang/R/ChangeLog
+++ b/dev-lang/R/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/R
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.89 2007/09/11 12:52:59 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.90 2007/10/06 14:21:27 markusle Exp $
+
+*R-2.6.0 (06 Oct 2007)
+
+ 06 Oct 2007; Markus Dittrich <markusle@gentoo.org> -R-2.4.1.ebuild, -R-2.5.0.ebuild, -files/R-2.4.0-as-needed-gentoo.patch, -files/R-2.4.1-as-needed-gentoo.patch, -files/R-2.2.0-ifc-configure.patch, +R-2.6.0.ebuild:
+ Version bump (fixes bug #194767). Also removed obsolete versions
+ and patches.
11 Sep 2007; Markus Dittrich <markusle@gentoo.org> R-2.5.1.ebuild:
Fixed messed up paths in libR.pc pkgconfig file (see bug #191986).
diff --git a/dev-lang/R/R-2.4.1.ebuild b/dev-lang/R/R-2.4.1.ebuild
deleted file mode 100644
index eb0f32253cfc..000000000000
--- a/dev-lang/R/R-2.4.1.ebuild
+++ /dev/null
@@ -1,116 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.4.1.ebuild,v 1.2 2007/07/22 08:47:37 graaff Exp $
-
-inherit fortran toolchain-funcs flag-o-matic
-
-DESCRIPTION="R is GNU S - A language and environment for statistical computing and graphics."
-HOMEPAGE="http://www.r-project.org/"
-SRC_URI="mirror://cran/src/base/R-2/${P}.tar.gz"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="blas jpeg nls png readline tk X lapack"
-
-RDEPEND=">=dev-lang/perl-5.6.1-r3
- readline? ( >=sys-libs/readline-4.1-r3 )
- jpeg? ( >=media-libs/jpeg-6b-r2 )
- png? ( >=media-libs/libpng-1.2.1 )
- blas? ( virtual/blas )
- lapack? ( virtual/lapack )
- tk? ( dev-lang/tk
- dev-lang/tcl )
- X? ( x11-libs/libX11 )"
-DEPEND="${RDEPEND}
- X? ( x11-proto/xproto
- x11-libs/libXt
- x11-libs/libX11 )"
-
-pkg_setup() {
- # Test for a 64 bit architecture - f2c won't work on 64 bit archs with R.
- # Thanks to vapier for providing the test.
- cd "${T}"
- echo 'int main(){}' > test.c
- $(tc-getCC) -c test.c -o test.o
- if file test.o | grep -qs 64-bit ; then
- einfo "64 bit architecture detected, using g77 or gfortran."
- FORTRAN="gfortran g77 ifc"
- else
- FORTRAN="gfortran g77 f2c"
- fi
- rm -f test.{c,o}
- fortran_pkg_setup
-
- filter-ldflags -Wl,-Bdirect -Bdirect
-
- # this is needed to properly compile additional R packages
- # (see bug #152379)
- append-flags -std=gnu99
-}
-
-src_unpack() {
- unpack ${A}
- sed -i -e "s:-fpic:-fPIC:g" ${S}/configure
- epatch "${FILESDIR}"/${P}-as-needed-gentoo.patch
-}
-
-src_compile() {
- local myconf="--enable-R-profiling --enable-R-shlib --enable-linux-lfs"
-
- if use tk; then
- #configure needs to find the files tclConfig.sh and tkConfig.sh
- myconf="${myconf} --with-tcltk --with-tcl-config=/usr/lib/tclConfig.sh
- --with-tk-config=/usr/lib/tkConfig.sh"
- else
- myconf="${myconf} --without-tcltk"
- fi
-
- econf \
- $(use_enable nls) \
- $(use_with blas) \
- $(use_with lapack) \
- $(use_with jpeg jpeglib) \
- $(use_with png libpng) \
- $(use_with readline) \
- $(use_with X x) \
- ${myconf} || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- make \
- prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- rhome=${D}/usr/$(get_libdir)/R \
- install || die "Installation Failed"
-
- # fix the R wrapper script to have the correct R_HOME_DIR
- # sed regexp borrowed from included debian rules
- sed \
- -e "/^R_HOME_DIR=.*/s::R_HOME_DIR=/usr/$(get_libdir)/R:" \
- -i ${D}/usr/$(get_libdir)/R/bin/R \
- || die "sed failed."
-
- # The same kinds of seds are needed for these variables too, see bug 115140
- sed \
- -e "/^R_SHARE_DIR=.*/s::R_SHARE_DIR=/usr/$(get_libdir)/R/share:" \
- -e "/^R_INCLUDE_DIR=.*/s::R_INCLUDE_DIR=/usr/$(get_libdir)/R/include:" \
- -e "/^R_DOC_DIR=.*/s::R_DOC_DIR=/usr/$(get_libdir)/R/doc:" \
- -i ${D}/usr/$(get_libdir)/R/bin/R \
- || die "sed failed."
-
- # R installs two identical wrappers under /usr/bin and /usr/lib/R/bin/
- # the 2nd one is corrected by above sed, the first is replaced by a symlink
- cd ${D}/usr/bin/
- rm R
- dosym ../$(get_libdir)/R/bin/R /usr/bin/R
- dodir /etc/env.d
- echo -n \
- "LDPATH=\"/usr/$(get_libdir)/R/lib\"" \
- > ${D}/etc/env.d/99R
- cd ${S}
-
- dodoc ChangeLog *NEWS README VERSION
-}
diff --git a/dev-lang/R/R-2.5.0.ebuild b/dev-lang/R/R-2.6.0.ebuild
index ebaec0900d14..ccc8274ff3ef 100644
--- a/dev-lang/R/R-2.5.0.ebuild
+++ b/dev-lang/R/R-2.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.5.0.ebuild,v 1.6 2007/07/22 08:47:37 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.6.0.ebuild,v 1.1 2007/10/06 14:21:27 markusle Exp $
inherit fortran toolchain-funcs flag-o-matic
@@ -105,6 +105,10 @@ src_install() {
-i ${D}/usr/$(get_libdir)/R/bin/R \
|| die "sed failed."
+ # fix paths in libR.pc pkgconfig file
+ sed -e "s:${D}::" -i ${D}/usr/$(get_libdir)/pkgconfig/libR.pc \
+ || die "Failed to fix libR.pc file"
+
# R installs two identical wrappers under /usr/bin and /usr/lib/R/bin/
# the 2nd one is corrected by above sed, the first is replaced by a symlink
cd ${D}/usr/bin/
diff --git a/dev-lang/R/files/R-2.2.0-ifc-configure.patch b/dev-lang/R/files/R-2.2.0-ifc-configure.patch
deleted file mode 100644
index 14401b9599b9..000000000000
--- a/dev-lang/R/files/R-2.2.0-ifc-configure.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- configure.ac.orig 2005-11-22 15:48:56.000000000 +0100
-+++ configure.ac 2005-11-22 15:49:50.000000000 +0100
-@@ -942,7 +942,7 @@
- rm -f Imakefile Makefile
- fi
-
--## Step 2. GNU compilers.
-+## Step 2. GNU and Intel compilers.
- if test "${GCC}" = yes; then
- cpicflags="-fPIC"
- shlib_ldflags="-shared"
-@@ -954,6 +954,11 @@
- cxxpicflags="-fPIC"
- shlib_cxxldflags="-shared"
- fi
-+case "${F77}" in
-+ ifc|ifort)
-+ fpicflags="-fPIC"
-+ ;;
-+esac
-
- ## Step 3. Individual platform overrides.
- case "${host_os}" in
diff --git a/dev-lang/R/files/R-2.4.0-as-needed-gentoo.patch b/dev-lang/R/files/R-2.4.0-as-needed-gentoo.patch
deleted file mode 100644
index ececae4ba63d..000000000000
--- a/dev-lang/R/files/R-2.4.0-as-needed-gentoo.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur R-2.4.0/src/modules/lapack/Makefile.in R-2.4.0-new/src/modules/lapack/Makefile.in
---- R-2.4.0/src/modules/lapack/Makefile.in 2006-09-04 10:41:35.000000000 -0400
-+++ R-2.4.0-new/src/modules/lapack/Makefile.in 2006-10-23 22:40:05.000000000 -0400
-@@ -78,7 +78,7 @@
- ## Include BLAS here, as with (static) ATLAS that pulls all the
- ## BLAS routines into one place.
- $(Rlapack_la): $(LIBOBJECTS)
-- $(DYLIB_LINK) -o $@ $(LIBOBJECTS) @BLAS_LIBS@ $(Rlapack_la_LIBADD)
-+ $(DYLIB_LINK) -o $@ $(LIBOBJECTS) @BLAS_LIBS@ $(Rlapack_la_LIBADD) $(FLIBS)
-
- Rlapack_install: $(Rlapack_la)
- @$(MKINSTALLDIRS) $(Rexeclibdir)
diff --git a/dev-lang/R/files/R-2.4.1-as-needed-gentoo.patch b/dev-lang/R/files/R-2.4.1-as-needed-gentoo.patch
deleted file mode 100644
index bfb539624817..000000000000
--- a/dev-lang/R/files/R-2.4.1-as-needed-gentoo.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur R-2.4.1/src/modules/lapack/Makefile.in R-2.4.1-new/src/modules/lapack/Makefile.in
---- R-2.4.1/src/modules/lapack/Makefile.in 2006-09-04 10:41:35.000000000 -0400
-+++ R-2.4.1-new/src/modules/lapack/Makefile.in 2006-12-18 21:14:05.000000000 -0500
-@@ -78,7 +78,7 @@
- ## Include BLAS here, as with (static) ATLAS that pulls all the
- ## BLAS routines into one place.
- $(Rlapack_la): $(LIBOBJECTS)
-- $(DYLIB_LINK) -o $@ $(LIBOBJECTS) @BLAS_LIBS@ $(Rlapack_la_LIBADD)
-+ $(DYLIB_LINK) -o $@ $(LIBOBJECTS) @BLAS_LIBS@ $(Rlapack_la_LIBADD) $(FLIBS)
-
- Rlapack_install: $(Rlapack_la)
- @$(MKINSTALLDIRS) $(Rexeclibdir)
diff --git a/dev-lang/R/files/digest-R-2.4.1 b/dev-lang/R/files/digest-R-2.4.1
deleted file mode 100644
index 538afe17a2c9..000000000000
--- a/dev-lang/R/files/digest-R-2.4.1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 92b33fd2c3e770d595c1a472889230d5 R-2.4.1.tar.gz 14570344
-RMD160 2a03cc81b870d594a695e9eb1e77720379c60194 R-2.4.1.tar.gz 14570344
-SHA256 4ff92cfd29064db59978ef11c95dd88a4040ed4984fdce29fcb5d5783fe9028b R-2.4.1.tar.gz 14570344
diff --git a/dev-lang/R/files/digest-R-2.5.0 b/dev-lang/R/files/digest-R-2.5.0
deleted file mode 100644
index 7dd3572ac450..000000000000
--- a/dev-lang/R/files/digest-R-2.5.0
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 b9088663fc539c059acfaf19d6d90a69 R-2.5.0.tar.gz 15117375
-RMD160 ae14775281b53a2ffc582977eec4c36c6bdc504f R-2.5.0.tar.gz 15117375
-SHA256 52504c7700f8f880891b34622f73a41dde66e0752a8552d2b8df5c85756a8eef R-2.5.0.tar.gz 15117375
diff --git a/dev-lang/R/files/digest-R-2.6.0 b/dev-lang/R/files/digest-R-2.6.0
new file mode 100644
index 000000000000..e5de22d6bc74
--- /dev/null
+++ b/dev-lang/R/files/digest-R-2.6.0
@@ -0,0 +1,3 @@
+MD5 97e5d2542349925962b7469456d45731 R-2.6.0.tar.gz 15447985
+RMD160 54b3d183dfb15af7f861e7b62904998865ad194c R-2.6.0.tar.gz 15447985
+SHA256 8a916e653affa83584119dc08a8b12e30e430dee19a398513515003c43d791da R-2.6.0.tar.gz 15447985