summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2011-11-08 09:01:19 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2011-11-08 09:01:19 +0000
commita4786c63db30df6daa5e76733726e0491d843287 (patch)
tree97173dd6d47d42a8de1f6597e271e026959930a6 /dev-lang/ekopath
parentversion bump (diff)
downloadgentoo-2-a4786c63db30df6daa5e76733726e0491d843287.tar.gz
gentoo-2-a4786c63db30df6daa5e76733726e0491d843287.tar.bz2
gentoo-2-a4786c63db30df6daa5e76733726e0491d843287.zip
Version bump with bulldozer support
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/ekopath')
-rw-r--r--dev-lang/ekopath/ChangeLog8
-rw-r--r--dev-lang/ekopath/ekopath-4.0.12_pre20111108.ebuild82
2 files changed, 89 insertions, 1 deletions
diff --git a/dev-lang/ekopath/ChangeLog b/dev-lang/ekopath/ChangeLog
index 000f2b5aefe3..e409242a11fa 100644
--- a/dev-lang/ekopath/ChangeLog
+++ b/dev-lang/ekopath/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/ekopath
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ekopath/ChangeLog,v 1.8 2011/08/04 16:54:41 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ekopath/ChangeLog,v 1.9 2011/11/08 09:01:19 xarthisius Exp $
+
+*ekopath-4.0.12_pre20111108 (08 Nov 2011)
+
+ 08 Nov 2011; Kacper Kowalik <xarthisius@gentoo.org>
+ +ekopath-4.0.12_pre20111108.ebuild:
+ Version bump with bulldozer support
*ekopath-4.0.11_pre20110804-r1 (04 Aug 2011)
diff --git a/dev-lang/ekopath/ekopath-4.0.12_pre20111108.ebuild b/dev-lang/ekopath/ekopath-4.0.12_pre20111108.ebuild
new file mode 100644
index 000000000000..5c2082315c76
--- /dev/null
+++ b/dev-lang/ekopath/ekopath-4.0.12_pre20111108.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ekopath/ekopath-4.0.12_pre20111108.ebuild,v 1.1 2011/11/08 09:01:19 xarthisius Exp $
+
+EAPI=4
+
+inherit versionator
+
+MY_PV=$(get_version_component_range 1-3)
+DATE=$(get_version_component_range 4)
+DATE=${DATE/pre}
+DATE=${DATE:0:4}-${DATE:4:2}-${DATE:6}
+
+DESCRIPTION="PathScale EKOPath Compiler Suite"
+HOMEPAGE="http://www.pathscale.com/ekopath-compiler-suite"
+SRC_URI="http://c591116.r16.cf2.rackcdn.com/${PN}/nightly/Linux/${PN}-${DATE}-installer.run
+ -> ${P}.run"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RESTRICT="mirror"
+
+S=${WORKDIR}
+
+QA_PREBUILT="
+ opt/${PN}/lib/${MY_PV}/x8664/*
+ opt/${PN}/bin/path*
+ opt/${PN}/bin/funclookup
+ opt/${PN}/bin/doctool
+ opt/${PN}/bin/subclient
+ opt/${PN}/bin/subserver
+ opt/${PN}/bin/assign"
+
+pkg_pretend() {
+ if has_version app-arch/rpm ; then
+ ewarn "You have app-arch/rpm installed on your system. Therefore"
+ ewarn "${PN} will fail to install due to sandbox violation."
+ ewarn "As this cannot be fixed on distribution level, please use"
+ ewarn "following workaround:"
+ ewarn " emerge -C rpm && emerge -1 ${PN} && emerge -1 rpm"
+ die
+ fi
+}
+
+src_unpack() {
+ cp "${DISTDIR}"/${A} "${S}" || die
+ chmod +x "${S}"/${P}.run
+}
+
+src_prepare() {
+ cat > "99${PN}" <<-EOF
+ PATH=/opt/${PN}/bin
+ ROOTPATH=/opt/${PN}/bin
+ LDPATH=/opt/${PN}/lib:/opt/${PN}/lib/${MY_PV}/x8664/64
+ EOF
+}
+
+src_install() {
+ # You must paxmark -m EI_PAX (not PT_PAX) to run the installer
+ # on a pax enabled kernel. Adding PT_PAX breaks the binary.
+ /usr/bin/scanelf -Xxz m ${P}.run >> /dev/null
+
+ ./${P}.run \
+ --prefix "${D}/opt/${PN}" \
+ --disable-components subscriptionmanager \
+ --mode unattended || die
+
+ # This is a temporary/partial fix to remove a RWX GNU STACK header
+ # from libstl.so. It still leaves libstl.a in bad shape.
+ # The correct fix is in the assembly atomic-cxx.S, which we don't get
+ # See http://www.gentoo.org/proj/en/hardened/gnu-stack.xml
+ # Section 6. How to fix the stack (in practice)
+ /usr/bin/scanelf -Xe "${D}/opt/ekopath/lib/4.0.11/x8664/64/libstl.so"
+
+ rm -rf "${D}"/opt/${PN}/uninstall || die
+ rm -rf "${D}"/opt/${PN}/bin/{pathdb,funclookup} || die #libtinfo
+ rm -rf "${D}"/opt/${PN}/lib/${MY_PV}/x8664/coco || die #DT_PATH
+ doenvd "99${PN}"
+}