summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2005-11-16 10:45:43 +0000
committerAkinori Hattori <hattya@gentoo.org>2005-11-16 10:45:43 +0000
commite70fa66237d36bd13db78e6fcd0a4e841f8ff524 (patch)
tree9a4f78f693380422531507a3d6ed3e21a21d07da /dev-lang/gauche/gauche-0.8.6-r1.ebuild
parentNew version. (diff)
downloadgentoo-2-e70fa66237d36bd13db78e6fcd0a4e841f8ff524.tar.gz
gentoo-2-e70fa66237d36bd13db78e6fcd0a4e841f8ff524.tar.bz2
gentoo-2-e70fa66237d36bd13db78e6fcd0a4e841f8ff524.zip
fixes bug #112577.
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'dev-lang/gauche/gauche-0.8.6-r1.ebuild')
-rw-r--r--dev-lang/gauche/gauche-0.8.6-r1.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/dev-lang/gauche/gauche-0.8.6-r1.ebuild b/dev-lang/gauche/gauche-0.8.6-r1.ebuild
new file mode 100644
index 000000000000..9a8e867b8195
--- /dev/null
+++ b/dev-lang/gauche/gauche-0.8.6-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gauche/gauche-0.8.6-r1.ebuild,v 1.1 2005/11/16 10:45:43 hattya Exp $
+
+inherit eutils flag-o-matic
+
+IUSE="ipv6"
+
+MY_P="${P/g/G}"
+
+DESCRIPTION="A Unix system friendly Scheme Interpreter"
+HOMEPAGE="http://gauche.sf.net/"
+SRC_URI="mirror://sourceforge/gauche/${MY_P}.tgz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+SLOT="0"
+S="${WORKDIR}/${MY_P}"
+
+DEPEND=">=sys-libs/gdbm-1.8.0"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-gdbm-gentoo.diff
+ epatch ${FILESDIR}/${PN}-gauche.m4-cc.diff
+ epatch ${FILESDIR}/${PN}-runpath.diff
+ autoconf
+
+}
+
+src_compile() {
+
+ local myconf="--enable-threads=pthreads --enable-multibyte=utf8"
+
+ use ipv6 && myconf="${myconf} --enable-ipv6"
+
+ strip-flags
+ econf ${myconf} || die
+ emake || die
+
+}
+
+src_test() {
+
+ make -s check || die
+
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS COPYING ChangeLog HACKING INSTALL INSTALL.eucjp README
+
+}
+
+pkg_postinst() {
+
+ echo
+ ewarn "As of version 0.8.6, Gauche switched the default character"
+ ewarn "encoding from euc-jp to utf-8."
+ echo
+
+}