summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-26 13:44:04 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-26 13:44:04 +0000
commit9f36f9e609dce63e22d27f64a91a1b3e511ebabb (patch)
tree2cc1f47638a098d59a5b6c49e651e9e49c67f3b6 /dev-lang/gforth
parentUse tc-getCC() - bug #68980 (diff)
downloadgentoo-2-9f36f9e609dce63e22d27f64a91a1b3e511ebabb.tar.gz
gentoo-2-9f36f9e609dce63e22d27f64a91a1b3e511ebabb.tar.bz2
gentoo-2-9f36f9e609dce63e22d27f64a91a1b3e511ebabb.zip
use $(tc-getCC)
Diffstat (limited to 'dev-lang/gforth')
-rw-r--r--dev-lang/gforth/gforth-0.6.2.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-lang/gforth/gforth-0.6.2.ebuild b/dev-lang/gforth/gforth-0.6.2.ebuild
index e573959364a2..191b8747155e 100644
--- a/dev-lang/gforth/gforth-0.6.2.ebuild
+++ b/dev-lang/gforth/gforth-0.6.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gforth/gforth-0.6.2.ebuild,v 1.8 2004/09/03 15:04:48 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gforth/gforth-0.6.2.ebuild,v 1.9 2004/10/26 13:39:13 vapier Exp $
-inherit elisp-common eutils
+inherit elisp-common eutils toolchain-funcs
DESCRIPTION="GNU Forth is a fast and portable implementation of the ANSI Forth language"
HOMEPAGE="http://www.gnu.org/software/gforth"
@@ -24,7 +24,7 @@ src_unpack() {
}
src_compile() {
- econf CC="gcc -fno-reorder-blocks -fno-inline" --enable-force-reg || die "econf failed"
+ econf CC="$(tc-getCC) -fno-reorder-blocks -fno-inline" --enable-force-reg || die "econf failed"
make || die
use emacs && emacs --batch -f batch-byte-compile --no-site-file --no-init-file *.el
}