summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Gabert <pappy@gentoo.org>2003-11-11 19:42:42 +0000
committerAlexander Gabert <pappy@gentoo.org>2003-11-11 19:42:42 +0000
commit98770b14944902cb0289cbd294390b62c4202e18 (patch)
treedaf8836c8e62687fae14d1b0c2264ce969d0d561 /dev-lang/ghc/ghc-5.04.3-r1.ebuild
parentadded ghc-6.0.1 bugfix from ghc-5.04.3-r1 bug30789 (diff)
downloadgentoo-2-98770b14944902cb0289cbd294390b62c4202e18.tar.gz
gentoo-2-98770b14944902cb0289cbd294390b62c4202e18.tar.bz2
gentoo-2-98770b14944902cb0289cbd294390b62c4202e18.zip
added ghc-6.0.1 bugfix from ghc-5.04.3-r1 bug30789
Diffstat (limited to 'dev-lang/ghc/ghc-5.04.3-r1.ebuild')
-rw-r--r--dev-lang/ghc/ghc-5.04.3-r1.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/dev-lang/ghc/ghc-5.04.3-r1.ebuild b/dev-lang/ghc/ghc-5.04.3-r1.ebuild
index fb6c9bdc3919..3e2995e458c2 100644
--- a/dev-lang/ghc/ghc-5.04.3-r1.ebuild
+++ b/dev-lang/ghc/ghc-5.04.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-5.04.3-r1.ebuild,v 1.7 2003/10/22 12:34:49 kosmikus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-5.04.3-r1.ebuild,v 1.8 2003/11/11 19:42:36 pappy Exp $
#Some explanation of bootstrap logic:
#
@@ -127,6 +127,16 @@ src_compile() {
mkdir ${STAGE2_B} || die
${LNDIR} ${S} ${STAGE2_B} || die
+# disable the automatic PIC building which is considered as Prologue Junk by the Haskell Compiler
+ if has_version "sys-devel/hardened-gcc"
+ then
+ # fix proposed by Peter simons according to bug #30789
+ echo "SRC_CC_OPTS+=-yet_exec -yno_propolice" >> ${STAGE1_B}/mk/build.mk
+ echo "SRC_HC_OPTS+=-optc-yet_exec -optc-yno_propolice" >> ${STAGE1_B}/mk/build.mk
+ echo "SRC_CC_OPTS+=-yet_exec -yno_propolice" >> ${STAGE2_B}/mk/build.mk
+ echo "SRC_HC_OPTS+=-optc-yet_exec -optc-yno_propolice" >> ${STAGE2_B}/mk/build.mk
+ fi
+
use opengl && myconf="--enable-hopengl" || myconf="--disable-hopengl"
if test x$need_stage1 = xyes; then