summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2006-08-02 19:31:09 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2006-08-02 19:31:09 +0000
commit0e54c3c1f39f395bab894a75cb05d983dd50d93c (patch)
tree154e9a97cc3cab3d509be03233178ceddf509e97 /dev-lang/ghc
parentmasked dev-tex/cweb_latex for bug # 142572 (diff)
downloadgentoo-2-0e54c3c1f39f395bab894a75cb05d983dd50d93c.tar.gz
gentoo-2-0e54c3c1f39f395bab894a75cb05d983dd50d93c.tar.bz2
gentoo-2-0e54c3c1f39f395bab894a75cb05d983dd50d93c.zip
Dont strip binaries on install. See QA warnings in bug #140369. Also dep on freealut now that it's been split out of openal.
(Portage version: 2.1-r1)
Diffstat (limited to 'dev-lang/ghc')
-rw-r--r--dev-lang/ghc/ChangeLog6
-rw-r--r--dev-lang/ghc/ghc-6.4.2.ebuild7
2 files changed, 10 insertions, 3 deletions
diff --git a/dev-lang/ghc/ChangeLog b/dev-lang/ghc/ChangeLog
index f599d1f771c7..710783537113 100644
--- a/dev-lang/ghc/ChangeLog
+++ b/dev-lang/ghc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/ghc
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.108 2006/07/24 17:27:03 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.109 2006/08/02 19:31:09 dcoutts Exp $
+
+ 02 Aug 2006; Duncan Coutts <dcoutts@gentoo.org> ghc-6.4.2.ebuild:
+ Dont strip binaries on install. See QA warnings in bug #140369.
+ Also dep on freealut now that it's been split out of openal.
24 Jul 2006; Gustavo Zacarias <gustavoz@gentoo.org> ghc-6.4.2.ebuild:
Stable on sparc wrt #140369
diff --git a/dev-lang/ghc/ghc-6.4.2.ebuild b/dev-lang/ghc/ghc-6.4.2.ebuild
index 30cb577ca1ae..633a41dd3edc 100644
--- a/dev-lang/ghc/ghc-6.4.2.ebuild
+++ b/dev-lang/ghc/ghc-6.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.4.2.ebuild,v 1.10 2006/07/24 17:27:03 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.4.2.ebuild,v 1.11 2006/08/02 19:31:09 dcoutts Exp $
# Brief explanation of the bootstrap logic:
#
@@ -59,7 +59,7 @@ RDEPEND="
X? ( || ( x11-libs/libX11 virtual/x11 ) )
opengl? ( virtual/opengl
virtual/glu virtual/glut
- openal? ( media-libs/openal ) )"
+ openal? ( media-libs/openal media-libs/freealut ) )"
# ghc cannot usually be bootstrapped using later versions ...
DEPEND="${RDEPEND}
@@ -178,6 +178,9 @@ src_unpack() {
# Patch to fix a mis-compilation in the rts due to strict aliasing,
# should be fixed upstream for 6.4.3 and 6.6. Fixes bug #135651.
echo 'GC_HC_OPTS += -optc-fno-strict-aliasing' >> "${S}/ghc/rts/Makefile"
+
+ # Don't strip binaries on install. See QA warnings in bug #140369.
+ sed -i -e 's/SRC_INSTALL_BIN_OPTS += -s//' ${S}/mk/config.mk.in
}
src_compile() {