summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2014-07-30 13:20:16 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2014-07-30 13:20:16 +0000
commit64433862059c3d31892a3181db9ab6e35dcbe07e (patch)
tree092037a9f5551ccc2a30f15e155a4c5743d0263f /dev-lang/ghc
parentVersion bump; removing hard requirement for GNU .init_array section support, ... (diff)
downloadgentoo-2-64433862059c3d31892a3181db9ab6e35dcbe07e.tar.gz
gentoo-2-64433862059c3d31892a3181db9ab6e35dcbe07e.tar.bz2
gentoo-2-64433862059c3d31892a3181db9ab6e35dcbe07e.zip
Fix pax-marking command for final ghc binary.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-lang/ghc')
-rw-r--r--dev-lang/ghc/ChangeLog5
-rw-r--r--dev-lang/ghc/ghc-7.8.3.ebuild4
2 files changed, 6 insertions, 3 deletions
diff --git a/dev-lang/ghc/ChangeLog b/dev-lang/ghc/ChangeLog
index 723ed99df37a..5b283617c949 100644
--- a/dev-lang/ghc/ChangeLog
+++ b/dev-lang/ghc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/ghc
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.260 2014/07/30 11:47:32 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.261 2014/07/30 13:20:16 slyfox Exp $
+
+ 30 Jul 2014; Sergei Trofimovich <slyfox@gentoo.org> ghc-7.8.3.ebuild:
+ Fix pax-marking command for final ghc binary.
30 Jul 2014; Sergei Trofimovich <slyfox@gentoo.org>
+files/ghc-7.8.3-prim-lm.patch, ghc-7.8.3.ebuild:
diff --git a/dev-lang/ghc/ghc-7.8.3.ebuild b/dev-lang/ghc/ghc-7.8.3.ebuild
index 1b2e55eeb0f3..adbfdab1b83d 100644
--- a/dev-lang/ghc/ghc-7.8.3.ebuild
+++ b/dev-lang/ghc/ghc-7.8.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-7.8.3.ebuild,v 1.3 2014/07/30 11:47:32 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-7.8.3.ebuild,v 1.4 2014/07/30 13:20:16 slyfox Exp $
EAPI=5
@@ -528,7 +528,7 @@ src_install() {
# ghci uses mmap with rwx protection at it implements dynamic
# linking on it's own (bug #299709)
# so mark resulting binary
- pax-mark -m "${ED}/usr/$(get_libdir)/${GHC_P}/ghc"
+ pax-mark -m "${ED}/usr/$(get_libdir)/${GHC_P}/bin/ghc"
if [[ ! -f "${S}/VERSION" ]]; then
echo "${GHC_PV}" > "${S}/VERSION" \