summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2006-06-15 12:18:36 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2006-06-15 12:18:36 +0000
commitfdd495c8931d7a228e21bf55d6a84d4ce0317566 (patch)
treed208618c23bb06c0e272c860cada0700528af967 /dev-lang/ghc
parentAdd patch to fix Jabber MUC invitations, as reported by Raymond Lewis Rebbeck... (diff)
downloadgentoo-2-fdd495c8931d7a228e21bf55d6a84d4ce0317566.tar.gz
gentoo-2-fdd495c8931d7a228e21bf55d6a84d4ce0317566.tar.bz2
gentoo-2-fdd495c8931d7a228e21bf55d6a84d4ce0317566.zip
Patch to fix a mis-compilation in the rts due to strict aliasing, should be fixed upstream for 6.4.3 and 6.6. Fixes bug #135651.
(Portage version: 2.1_rc4-r3)
Diffstat (limited to 'dev-lang/ghc')
-rw-r--r--dev-lang/ghc/ChangeLog7
-rw-r--r--dev-lang/ghc/ghc-6.4.1-r3.ebuild6
-rw-r--r--dev-lang/ghc/ghc-6.4.2.ebuild6
3 files changed, 16 insertions, 3 deletions
diff --git a/dev-lang/ghc/ChangeLog b/dev-lang/ghc/ChangeLog
index 00500f65d6ec..d91e341d99b4 100644
--- a/dev-lang/ghc/ChangeLog
+++ b/dev-lang/ghc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/ghc
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.104 2006/05/21 17:25:22 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.105 2006/06/15 12:18:36 dcoutts Exp $
+
+ 15 Jun 2006; Duncan Coutts <dcoutts@gentoo.org> ghc-6.4.1-r3.ebuild,
+ ghc-6.4.2.ebuild:
+ Patch to fix a mis-compilation in the rts due to strict aliasing,
+ should be fixed upstream for 6.4.3 and 6.6. Fixes bug #135651.
21 May 2006; Markus Rothe <corsair@gentoo.org> ghc-6.4.1-r2.ebuild:
Stable on ppc64
diff --git a/dev-lang/ghc/ghc-6.4.1-r3.ebuild b/dev-lang/ghc/ghc-6.4.1-r3.ebuild
index e50a2fce915e..2d59eb03db3e 100644
--- a/dev-lang/ghc/ghc-6.4.1-r3.ebuild
+++ b/dev-lang/ghc/ghc-6.4.1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.4.1-r3.ebuild,v 1.8 2006/05/19 16:06:10 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.4.1-r3.ebuild,v 1.9 2006/06/15 12:18:36 dcoutts Exp $
# Brief explanation of the bootstrap logic:
#
@@ -172,6 +172,10 @@ src_unpack() {
# Patch to fix make-3.81 hanging (backport of the fix in ghc-6.4.2)
sed -i -e 's/.SECONDARY://' "${S}/mk/suffix.mk"
+
+ # Patch to fix a mis-compilation in the rts due to strict aliasing,
+ # should be fixed upstream for 6.4.3 and 6.6. Fixes bug #135651.
+ echo 'GC_HC_OPTS += -optc-fno-strict-aliasing' >> "${S}/ghc/rts/Makefile"
}
src_compile() {
diff --git a/dev-lang/ghc/ghc-6.4.2.ebuild b/dev-lang/ghc/ghc-6.4.2.ebuild
index a4f24b7eda54..ab1b32ca8ca0 100644
--- a/dev-lang/ghc/ghc-6.4.2.ebuild
+++ b/dev-lang/ghc/ghc-6.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.4.2.ebuild,v 1.6 2006/05/19 16:06:10 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.4.2.ebuild,v 1.7 2006/06/15 12:18:36 dcoutts Exp $
# Brief explanation of the bootstrap logic:
#
@@ -174,6 +174,10 @@ src_unpack() {
# if we turn down the optimisations in one problematic module.
use ia64 && sed -i -e 's/OPTIONS_GHC/OPTIONS_GHC -O0 -optc-O/' \
"${S}/libraries/base/GHC/Float.lhs"
+
+ # Patch to fix a mis-compilation in the rts due to strict aliasing,
+ # should be fixed upstream for 6.4.3 and 6.6. Fixes bug #135651.
+ echo 'GC_HC_OPTS += -optc-fno-strict-aliasing' >> "${S}/ghc/rts/Makefile"
}
src_compile() {