summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2010-08-29 19:18:34 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2010-08-29 19:18:34 +0000
commit3d7d29b957fa0db266ad8e57f479308ede4c077c (patch)
tree7d123cd4a3c342227fba95fd51337046b35cf133 /dev-lang/helium
parentMoved from sunrise overlay. Bug #313643. Thanks to Fabiano Francesconi (elbry... (diff)
downloadgentoo-2-3d7d29b957fa0db266ad8e57f479308ede4c077c.tar.gz
gentoo-2-3d7d29b957fa0db266ad8e57f479308ede4c077c.tar.bz2
gentoo-2-3d7d29b957fa0db266ad8e57f479308ede4c077c.zip
Removed old version
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/helium')
-rw-r--r--dev-lang/helium/ChangeLog6
-rw-r--r--dev-lang/helium/files/helium-1.1-readline.patch48
-rw-r--r--dev-lang/helium/helium-1.1.ebuild73
3 files changed, 5 insertions, 122 deletions
diff --git a/dev-lang/helium/ChangeLog b/dev-lang/helium/ChangeLog
index 04c70b9788d0..b7cefc60ebc9 100644
--- a/dev-lang/helium/ChangeLog
+++ b/dev-lang/helium/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/helium
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/helium/ChangeLog,v 1.25 2010/08/29 18:30:50 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/helium/ChangeLog,v 1.26 2010/08/29 19:18:34 slyfox Exp $
+
+ 29 Aug 2010; Sergei Trofimovich <slyfox@gentoo.org> -helium-1.1.ebuild,
+ -files/helium-1.1-readline.patch:
+ Removed old version
29 Aug 2010; Sergei Trofimovich <slyfox@gentoo.org> helium-1.6.ebuild,
+files/helium-1.6-respect-cflags-ldflags-nostrip.patch:
diff --git a/dev-lang/helium/files/helium-1.1-readline.patch b/dev-lang/helium/files/helium-1.1-readline.patch
deleted file mode 100644
index 0efe1564bb80..000000000000
--- a/dev-lang/helium/files/helium-1.1-readline.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-diff -Naur helium-1.1.old/heliumNT/src/Makefile.in helium-1.1/heliumNT/src/Makefile.in
---- helium-1.1.old/heliumNT/src/Makefile.in 2003-03-12 22:35:28.000000000 +0000
-+++ helium-1.1/heliumNT/src/Makefile.in 2003-03-12 22:33:19.000000000 +0000
-@@ -200,7 +200,7 @@
-
- texthint: texthint/Main.hs utils/OSSpecific.hs
- # GHC HeliumInterpreter
-- $(HC) --make -iutils -o $(HELIUMBINDIR)/texthint$(EXE) texthint/Main.hs
-+ $(HC) --make -package util -iutils -o $(HELIUMBINDIR)/texthint$(EXE) texthint/Main.hs
- $(STRIP) $(HELIUMBINDIR)/texthint$(EXE)
-
- # AG sources
-diff -Naur helium-1.1.old/heliumNT/src/texthint/Main.hs helium-1.1/heliumNT/src/texthint/Main.hs
---- helium-1.1.old/heliumNT/src/texthint/Main.hs 2003-03-06 14:45:13.000000000 +0000
-+++ helium-1.1/heliumNT/src/texthint/Main.hs 2003-03-12 22:38:29.000000000 +0000
-@@ -2,6 +2,7 @@
-
- import Char
- import List(isPrefixOf, isSuffixOf)
-+import Readline
- import Monad(when)
- import IO(stdout, hFlush)
- import System(system, getEnv, getArgs, exitWith, ExitCode(..))
-@@ -64,6 +65,11 @@
- cmdLoadModule (head args) initialState
- else
- return initialState
-+
-+ -- Initialize readline
-+ initialize
-+ -- Deactivate filename completion
-+ setCompletionEntryFunction (Just (const $ return []))
-
- -- Enter read-eval-print loop
- loop stateAfterLoad
-@@ -79,9 +85,9 @@
-
- loop :: State -> IO State
- loop state = do
-- putStr (prompt state)
-- hFlush stdout
-- command' <- getLine
-+ command'' <- readline (prompt state)
-+ let command' = maybe ":q" id command''
-+ addHistory command'
- let command = trim command'
- newState <- case command of
- (':':cmd:rest) ->
diff --git a/dev-lang/helium/helium-1.1.ebuild b/dev-lang/helium/helium-1.1.ebuild
deleted file mode 100644
index 595416dcfaaf..000000000000
--- a/dev-lang/helium/helium-1.1.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/helium/helium-1.1.ebuild,v 1.21 2009/04/17 20:07:20 caster Exp $
-
-inherit java-pkg-2
-
-DESCRIPTION="Helium (for learning Haskell)"
-HOMEPAGE="http://www.cs.uu.nl/helium"
-SRC_URI="http://www.cs.uu.nl/helium/distr/${P}-src.tar.gz
- http://www.cs.uu.nl/helium/distr/Hint.jar"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 -sparc"
-IUSE="readline"
-
-DEPEND="<dev-lang/ghc-6.4
- !>=dev-lang/ghc-6.4
- readline? ( sys-libs/readline )"
-RDEPEND=">=virtual/jre-1.4
- dev-libs/gmp
- readline? ( sys-libs/readline )"
-
-src_unpack() {
- unpack ${P}-src.tar.gz
-
- # patch for readline support if requested
- if use readline; then
- patch -p0 -i ${FILESDIR}/${P}-readline.patch || die
- fi
- # fix one file due to GHC 6.0's Template Haskell extension
- einfo modifying ParsecPerm to ensure compatibility with GHC 6.0
- cd ${S}/parsec
- mv ParsecPerm.hs ParsecPerm.hs.orig
- sed -e 's/(\$/(\$ /' ParsecPerm.hs.orig > ParsecPerm.hs
-
- cp "${DISTDIR}/Hint.jar" "${WORKDIR}"
-}
-
-src_compile() {
- pushd lvm || die
- pushd src || die
- ./configure
- popd
- popd
- pushd heliumNT || die
- econf --without-upx || die "econf failed"
- pushd src || die
- make depend || die
- make || die # emake doesn't work safely
-}
-
-src_install() {
- cd heliumNT/src || die
- make prefix=${D}/usr \
- bindir=${D}/usr/lib/helium/bin \
- libdir=${D}/usr/lib/helium/lib \
- demodir=${D}/usr/lib/helium/demo \
- install || die
- # install hint
- java-pkg_dojar "${WORKDIR}/Hint.jar"
- # create wrappers
- dobin ${FILESDIR}/helium-wrapper
- dosym /usr/bin/helium-wrapper /usr/bin/helium
- dosym /usr/bin/helium-wrapper /usr/bin/lvmrun
- dosym /usr/bin/helium-wrapper /usr/bin/texthint
- dosym /usr/bin/helium-wrapper /usr/bin/hint
-}
-
-pkg_postinst() {
- elog "hi is now called texthint"
- elog "hint is a new GUI-based interpreter"
-}