summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-08-08 01:53:17 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-08-08 01:53:17 +0000
commitb0c2c476b55d8460afe6220981745f9a57efa123 (patch)
treed22c538126efb82c7e40a398c0600e728074109e /dev-lang/hugs98/hugs98-2000.12-r1.ebuild
parentnew package spice: a general-purpose circuit simulation program (diff)
downloadgentoo-2-b0c2c476b55d8460afe6220981745f9a57efa123.tar.gz
gentoo-2-b0c2c476b55d8460afe6220981745f9a57efa123.tar.bz2
gentoo-2-b0c2c476b55d8460afe6220981745f9a57efa123.zip
Fixes #6135.
Diffstat (limited to 'dev-lang/hugs98/hugs98-2000.12-r1.ebuild')
-rw-r--r--dev-lang/hugs98/hugs98-2000.12-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-lang/hugs98/hugs98-2000.12-r1.ebuild b/dev-lang/hugs98/hugs98-2000.12-r1.ebuild
new file mode 100644
index 000000000000..b2cffe583c58
--- /dev/null
+++ b/dev-lang/hugs98/hugs98-2000.12-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/hugs98/hugs98-2000.12-r1.ebuild,v 1.1 2002/08/08 01:53:17 karltk Exp $
+
+MY_P="hugs98-Dec2001"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="The HUGS98 Haskell interpreter"
+SRC_URI="http://cvs.haskell.org/Hugs/downloads/${MY_P}.tar.gz"
+HOMEPAGE="http://www.haskell.org/hugs"
+
+SLOT="0"
+KEYWORDS="x86"
+LICENSE="as-is"
+
+DEPEND="virtual/glibc
+ readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )"
+
+src_compile() {
+ local myc
+ use readline && myc="${myc} --with-readline" || myc="${myc} --without-readline"
+
+ cd ${S}/src/unix || die
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myc} || die "./configure failed"
+ cd ..
+ emake || die
+}
+
+src_install () {
+ cd ${S}/src || die
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+ dodoc Credits License Readme Install
+}