summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-08-23 11:00:33 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-08-23 11:00:33 +0000
commit86b0d4eb36057929b86debb0080c5629dce9e376 (patch)
treee1cceaf562a5ee85724dcc7fc4e871fe40f832de /dev-lang/icc/icc-10.1.017-r1.ebuild
parentcodegen patch doesn't work properly without eautomake, bug #233337.. (diff)
downloadgentoo-2-86b0d4eb36057929b86debb0080c5629dce9e376.tar.gz
gentoo-2-86b0d4eb36057929b86debb0080c5629dce9e376.tar.bz2
gentoo-2-86b0d4eb36057929b86debb0080c5629dce9e376.zip
Changed wrong patch to a conditional one, thanks to Harald van Dijk, bug #235496
(Portage version: 2.2_rc8/cvs/Linux 2.6.23-gentoo-r9 x86_64)
Diffstat (limited to 'dev-lang/icc/icc-10.1.017-r1.ebuild')
-rw-r--r--dev-lang/icc/icc-10.1.017-r1.ebuild14
1 files changed, 12 insertions, 2 deletions
diff --git a/dev-lang/icc/icc-10.1.017-r1.ebuild b/dev-lang/icc/icc-10.1.017-r1.ebuild
index 1a08c1de1245..d89863b593e4 100644
--- a/dev-lang/icc/icc-10.1.017-r1.ebuild
+++ b/dev-lang/icc/icc-10.1.017-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/icc-10.1.017-r1.ebuild,v 1.1 2008/08/22 17:16:46 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/icc-10.1.017-r1.ebuild,v 1.2 2008/08/23 11:00:33 bicatali Exp $
inherit rpm eutils check-reqs
@@ -56,7 +56,6 @@ src_unpack() {
einfo "Extracting $(basename ${x})..."
rpm_unpack "${S}/${x}" || die "rpm_unpack ${x} failed"
done
- epatch "${FILESDIR}/icc-add-amd64-preprocessor-directives.patch"
einfo "Fixing paths and tagging"
cd "${S}"/${INSTALL_DIR}/bin
@@ -71,6 +70,17 @@ src_unpack() {
-i *support \
|| die "sed support file failed"
chmod 644 *support
+
+ if use amd64; then
+ cat <<-EOF >>"${S}"/${INSTALL_DIR}/bin/icc.cfg
+ -D__amd64=__x86_64
+ -D__amd64__=__x86_64__
+ EOF
+ cat <<-EOF >>"${S}"/${INSTALL_DIR}/bin/icpc.cfg
+ -D__amd64=__x86_64
+ -D__amd64__=__x86_64__
+ EOF
+ fi
}
src_install() {