summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Portnoy <avenj@gentoo.org>2002-12-08 21:47:50 +0000
committerJon Portnoy <avenj@gentoo.org>2002-12-08 21:47:50 +0000
commit8fa37d999ac7c444ba4eb1d27ff7e9cfbe453cf9 (patch)
tree461e840b4d8f76e67edeefc60a73440f1ec72298 /dev-lang/icc
parentadded 0.58 to portage as per bug 11315 (diff)
downloadgentoo-2-8fa37d999ac7c444ba4eb1d27ff7e9cfbe453cf9.tar.gz
gentoo-2-8fa37d999ac7c444ba4eb1d27ff7e9cfbe453cf9.tar.bz2
gentoo-2-8fa37d999ac7c444ba4eb1d27ff7e9cfbe453cf9.zip
Ebuild for ICC 7.0 plus related files.
Diffstat (limited to 'dev-lang/icc')
-rw-r--r--dev-lang/icc/ChangeLog22
-rw-r--r--dev-lang/icc/files/7.0/05icc-ifc6
-rw-r--r--dev-lang/icc/files/digest-icc-7.01
-rw-r--r--dev-lang/icc/icc-7.0.ebuild97
4 files changed, 125 insertions, 1 deletions
diff --git a/dev-lang/icc/ChangeLog b/dev-lang/icc/ChangeLog
index f663995e8074..cc7aec567861 100644
--- a/dev-lang/icc/ChangeLog
+++ b/dev-lang/icc/ChangeLog
@@ -1,6 +1,26 @@
# ChangeLog for dev-lang/icc
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/ChangeLog,v 1.3 2002/05/14 03:46:13 sandymac Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/ChangeLog,v 1.4 2002/12/08 21:47:50 avenj Exp $
+
+*icc-7.0 (8 Dec 2002)
+
+ 8 Dec 20002 Jon Portnoy <avenj@gentoo.org> icc-7.0.ebuild :
+
+ Added a warning about the behavior of the main executable.
+ 'icc' will return errors; 'iccbin' works fine.
+
+ Fixed the warning messages to fit a standard terminal.
+
+ Fixed the old version checking statement to avoid matching
+ the current version.
+
+ 5 Dec 2002 William McArthur <sandymac@gentoo.org> icc-7.0.ebuild :
+
+ Included some improvments from Jon Portnoy from http://bugs.gentoo.org/show_bug.cgi?id=11211
+
+ 25 Nov 2002 William McArthur <sandymac@gentoo.org> icc-7.0.ebuild :
+
+ Basicly just updated the icc-6.0-r1 with new urls and changed the message at the end.
*icc-6.0-r1 (13 May 2002)
diff --git a/dev-lang/icc/files/7.0/05icc-ifc b/dev-lang/icc/files/7.0/05icc-ifc
new file mode 100644
index 000000000000..7134ac814afd
--- /dev/null
+++ b/dev-lang/icc/files/7.0/05icc-ifc
@@ -0,0 +1,6 @@
+IA32ROOT=/opt/intel/compiler70/ia32
+INTEL_FLEXLM_LICENSE=/opt/intel/licenses
+LDPATH=/opt/intel/compiler70/ia32/lib
+MANPATH=/opt/intel/compiler70/man
+PATH=/opt/intel/compiler70/ia32/bin
+ROOTPATH=/opt/intel/compiler70/ia32/bin
diff --git a/dev-lang/icc/files/digest-icc-7.0 b/dev-lang/icc/files/digest-icc-7.0
new file mode 100644
index 000000000000..26c60237a081
--- /dev/null
+++ b/dev-lang/icc/files/digest-icc-7.0
@@ -0,0 +1 @@
+MD5 e16414a571ac8cc9b69fad3a886049f1 l_cc_p_7.0.065.tar 64921600
diff --git a/dev-lang/icc/icc-7.0.ebuild b/dev-lang/icc/icc-7.0.ebuild
new file mode 100644
index 000000000000..479fe46183ac
--- /dev/null
+++ b/dev-lang/icc/icc-7.0.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/icc-7.0.ebuild,v 1.1 2002/12/08 21:47:50 avenj Exp $
+
+S=${WORKDIR}
+
+DESCRIPTION="Intel C++ Compiler - The Pentium optimized compiler for Linux"
+
+SRC_URI1="ftp://download.intel.com/software/products/compilers/downloads/l_cc_p_7.0.065.tar"
+SRC_URI2="ftp://download.intel.co.jp/software/products/compilers/downloads/l_cc_p_7.0.065.tar"
+SRC_URI="${SRC_URI1} ${SRC_URI2}"
+
+HOMEPAGE="http://www.intel.com/software/products/compilers/clin/"
+
+LICENSE="icc-7.0"
+
+DEPEND=">=virtual/linux-sources-2.4
+ >=sys-libs/glibc-2.2.4
+ sys-apps/cpio
+ app-arch/rpm"
+
+RDEPEND=">=virtual/linux-sources-2.4
+ >=sys-libs/glibc-2.2.4"
+
+SLOT="7"
+KEYWORDS="~x86 -ppc -sparc -sparc64"
+IUSE=""
+
+src_compile() {
+ # Keep disk space to a minimum
+ rm -f intel-*.ia64.rpm
+
+ mkdir opt
+
+ for x in intel-*.i386.rpm
+ do
+ einfo "Extracting: ${x}"
+ rpm2cpio ${x} | cpio --extract --make-directories --unconditional
+ done
+
+ # From UNTAG_CFG_FILES in 'install'
+ SD=${S}/opt/intel # Build DESTINATION
+ RD=/opt/intel # Real DESTINATION
+ for FILE in $(find $SD/compiler*/ia??/bin/ -regex '.*[ei][cf]p?c$\|.*cfg$\|.*pcl$\|.*vars[^/]*.c?sh$' 2>/dev/null)
+ do
+ sed s@\<INSTALLDIR\>@$RD@g ${FILE} > ${FILE}.abs
+ mv -f ${FILE}.abs ${FILE}
+ chmod 755 ${FILE}
+ done
+
+ # From UNTAG_SUPPORT in 'install'
+ eval `grep "^[ ]*COMBOPACKAGEID=" install`
+
+ for SUPPORTFILE in ${SD}/compiler*/docs/*support
+ do
+ einfo "Untagging: ${SUPPORTFILE}"
+ sed s@\<INSTALLTIMECOMBOPACKAGEID\>@$COMBOPACKAGEID@g $SUPPORTFILE > $SUPPORTFILE.abs
+ mv $SUPPORTFILE.abs $SUPPORTFILE
+ chmod 644 $SUPPORTFILE
+ done
+}
+
+src_install () {
+ dodoc lgpltext
+ dodoc clicense
+ cp -a opt ${D}
+
+ # icc enviroment
+ insinto /etc/env.d
+ doins ${FILESDIR}/${PVR}/05icc-ifc
+}
+
+pkg_postinst () {
+ einfo
+ einfo "http://www.intel.com/software/products/compilers/clin/noncom.htm"
+ einfo "From the above url you can get a free, non-commercial"
+ einfo "license to use the Intel C++ Compiler emailed to you."
+ einfo "You cannot run icc without this license file."
+ einfo "Read the website for more information on this license."
+ einfo
+ einfo "Documentation can be found in /opt/intel/compiler70/docs/"
+ einfo
+ einfo "You will need to place your license in /opt/intel/licenses/"
+ einfo
+ if [ -d /opt/intel/compiler[56]0 ]
+ then
+ ewarn
+ ewarn "Packages compiled with older versions of icc will need"
+ ewarn "to be recompiled. Until you do that, old packages will"
+ ewarn "work if you edit /etc/ld.so.conf and change 'compiler70'"
+ ewarn "to 'compiler60' and run 'ldconfig.' Note that this edit"
+ ewarn "won't persist and will require you to re-edit after each"
+ ewarn "package you re-install."
+ fi
+ ewarn "Due to a bug in icc 7.0, the primary executable (icc) may not work."
+ ewarn "Instead of invoking the compiler as icc, use iccbin."
+}