summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-10-02 11:33:06 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-10-02 11:33:06 +0000
commit46c36db99b038a57b74647802dbb9d786cec0c8b (patch)
treee2a093beba0ad9c2eaa7c0575ebc0cddb9fbacba /dev-lang/ifc
parentremoved debugger local use flag for dev-lang/ifc (diff)
downloadgentoo-2-46c36db99b038a57b74647802dbb9d786cec0c8b.tar.gz
gentoo-2-46c36db99b038a57b74647802dbb9d786cec0c8b.tar.bz2
gentoo-2-46c36db99b038a57b74647802dbb9d786cec0c8b.zip
Split debugger into dev-lang/idb, remove IA32ROOT env, added more log comments.
(Portage version: 2.1.3.9)
Diffstat (limited to 'dev-lang/ifc')
-rw-r--r--dev-lang/ifc/ChangeLog8
-rw-r--r--dev-lang/ifc/files/digest-ifc-10.0.026-r1 (renamed from dev-lang/ifc/files/digest-ifc-10.0.026)0
-rw-r--r--dev-lang/ifc/ifc-10.0.026-r1.ebuild (renamed from dev-lang/ifc/ifc-10.0.026.ebuild)66
-rw-r--r--dev-lang/ifc/metadata.xml15
4 files changed, 29 insertions, 60 deletions
diff --git a/dev-lang/ifc/ChangeLog b/dev-lang/ifc/ChangeLog
index 052f4d5207f0..eb56b47cb3f3 100644
--- a/dev-lang/ifc/ChangeLog
+++ b/dev-lang/ifc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/ifc
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ifc/ChangeLog,v 1.27 2007/09/30 10:34:44 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ifc/ChangeLog,v 1.28 2007/10/02 11:33:05 bicatali Exp $
+
+*ifc-10.0.026-r1 (02 Oct 2007)
+
+ 02 Oct 2007; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml,
+ -ifc-10.0.026.ebuild, +ifc-10.0.026-r1.ebuild:
+ Split debugger into dev-lang/idb, remove IA32ROOT env, added more log comments.
*ifc-10.0.026 (30 Sep 2007)
diff --git a/dev-lang/ifc/files/digest-ifc-10.0.026 b/dev-lang/ifc/files/digest-ifc-10.0.026-r1
index 5e6031c3abe8..5e6031c3abe8 100644
--- a/dev-lang/ifc/files/digest-ifc-10.0.026
+++ b/dev-lang/ifc/files/digest-ifc-10.0.026-r1
diff --git a/dev-lang/ifc/ifc-10.0.026.ebuild b/dev-lang/ifc/ifc-10.0.026-r1.ebuild
index 4701edc8b212..a4b7866861f0 100644
--- a/dev-lang/ifc/ifc-10.0.026.ebuild
+++ b/dev-lang/ifc/ifc-10.0.026-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ifc/ifc-10.0.026.ebuild,v 1.1 2007/09/30 10:34:44 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ifc/ifc-10.0.026-r1.ebuild,v 1.1 2007/10/02 11:33:05 bicatali Exp $
-inherit rpm elisp-common
+inherit rpm
PID=787
PB=fc
@@ -24,39 +24,20 @@ LICENSE="Intel-SDP"
SLOT="0"
RESTRICT="test strip mirror"
-IUSE="emacs debugger"
-
+IUSE=""
DEPEND=""
-RDEPEND="debugger? (
- x11-libs/libXt
- x11-libs/libXft
- dev-libs/libxml2
- virtual/libstdc++ )"
-
-if use x86; then
- MY_P="${PACKAGEID}_ia32"
-elif use amd64; then
- MY_P="${PACKAGEID}_intel64"
-elif use ia64; then
- MY_P="${PACKAGEID}_ia64"
-fi
-
-S="${WORKDIR}/${MY_P}"
src_unpack() {
unpack ${A}
+ mv "${WORKDIR}"/l_* "${S}"
cd "${S}"
local ext=
use amd64 && ext=e
INSTALL_DIR=/opt/intel/${PB}${ext}/${PV}
- if use debugger && [[ ! -x /opt/intel/idb${ext}/${PV}/bin/idb ]]; then
- INSTALL_IDB_DIR=/opt/intel/idb${ext}/${PV}
- else
- use debugger && einfo "Debugger already installed"
- rm -f data/intel*idb*.rpm
- fi
+ # debugger installed with dev-lang/idb
+ rm -f data/intel*idb*.rpm
for x in data/intel*.rpm; do
einfo "Extracting $(basename ${x})..."
@@ -91,36 +72,19 @@ src_install() {
echo "LDPATH=${INSTALL_DIR}/lib" >> ${env_file}
echo "MANPATH=${INSTALL_DIR}/man" >> ${env_file}
echo "INCLUDE=${INSTALL_DIR}/include" >> ${env_file}
- echo "IA32ROOT=${INSTALL_DIR}" >> ${env_file}
doenvd ${env_file} || die "doenvd ${env_file} failed"
-
- if [[ -n ${INSTALL_IDB_DIR} ]]; then
- dodir ${INSTALL_IDB_DIR}
- cp -pPR \
- "${S}"/${INSTALL_IDB_DIR}/* \
- "${D}"/${INSTALL_IDB_DIR}/ \
- || die "copying debugger failed"
- local idb_env_file=06idb
- echo "PATH=${INSTALL_IDB_DIR}/bin" > ${idb_env_file}
- echo "ROOTPATH=${INSTALL_IDB_DIR}/bin" >> ${idb_env_file}
- echo "MANPATH=${INSTALL_IDB_DIR}/man" >> ${idb_env_file}
- doenvd ${idb_env_file} || die "doenvd ${idb_env_file} failed"
- use emacs && \
- elisp-site-file-install "${S}"${INSTALL_IDB_DIR}/bin/*.el
- fi
}
pkg_postinst () {
- elog "Make sure you have recieved the restrictive"
- elog "non-commercial license ${PN} by registering at:"
+ # remove left over from unpacking
+ rm -f "${ROOT}"/opt/intel/{intel_sdp_products.db,.*.log} || die "remove logs failed"
+
+ elog "Make sure you have recieved the a license for ${PN}"
+ elog "To receive a restrictive non-commercial licenses , you need to register at:"
elog "http://www.intel.com/cd/software/products/asmo-na/eng/download/download/219771.htm"
- elog "You cannot run ${PN} without this license file."
elog "Read the website for more information on this license."
- elog "To use ${PN} now, issue first \n\tsource /etc/profile"
- use emacs && elisp-site-regen
- rm -f "${ROOT}"/opt/intel/{intel_sdp_products.db,.*.log}
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
+ elog "You cannot run ${PN} without a license file."
+ elog "Then put the license file into ${ROOT}/opt/intel/licenses"
+ elog "\nTo use ${PN} issue first \n\tsource /etc/profile"
+ elog "Debugger is installed with dev-lang/idb"
}
diff --git a/dev-lang/ifc/metadata.xml b/dev-lang/ifc/metadata.xml
index 7a5df05b4d4a..009dd228c20a 100644
--- a/dev-lang/ifc/metadata.xml
+++ b/dev-lang/ifc/metadata.xml
@@ -7,13 +7,12 @@
<name>Danny van Dyk</name>
</maintainer>
<longdescription lang="en">
-The Intel® Fortran Compiler is a full features FORTRAN 77/95 and
-substantial FORTRAN 2003 compiler for Intel based architectures.
-It is here offered as a non-commercial (please see web site to see
-terms of qualifications).
-The compiler supports multi-threading, and processor support that includes automatic
-processor dispatch, vectorization, auto-parallelization, OpenMP, data
-prefetching, loop unrolling. The package come with a debugger and
-large documentation.
+The Intel® Fortran Compiler is a full featured FORTRAN 77/95 and
+substantial FORTRAN 2003 compiler for Intel based architectures. The
+compiler supports multi-threading with automatic processor dispatch,
+vectorization, auto-parallelization, OpenMP, data prefetching, loop
+unrolling. The package comes with extensive documentation.
+The product can be installed as a non-commercial as well. License,
+terms of qualifications can be found on the web site.
</longdescription>
</pkgmetadata>