summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJurek Bartuszek <jurek@gentoo.org>2007-06-25 21:30:23 +0000
committerJurek Bartuszek <jurek@gentoo.org>2007-06-25 21:30:23 +0000
commit1823f2a7ea5beaeb280a78d3958da3d5a9b51d05 (patch)
treefd42e2bb5060ae089a9fe01070b1f76a07afa3e9 /dev-lang/mono
parentMarked ppc stable for bug #182391. (diff)
downloadgentoo-2-1823f2a7ea5beaeb280a78d3958da3d5a9b51d05.tar.gz
gentoo-2-1823f2a7ea5beaeb280a78d3958da3d5a9b51d05.tar.bz2
gentoo-2-1823f2a7ea5beaeb280a78d3958da3d5a9b51d05.zip
dev-lang/mono: added warnings regarding build failures on systems with active SELinux/PIE+SSP/grsec/PAX and other security enhancements (addressing bug #153781)
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-lang/mono')
-rw-r--r--dev-lang/mono/ChangeLog10
-rw-r--r--dev-lang/mono/mono-1.1.16.1.ebuild12
-rw-r--r--dev-lang/mono/mono-1.2.2.1.ebuild16
-rw-r--r--dev-lang/mono/mono-1.2.3.1.ebuild12
-rw-r--r--dev-lang/mono/mono-1.2.4.ebuild12
5 files changed, 51 insertions, 11 deletions
diff --git a/dev-lang/mono/ChangeLog b/dev-lang/mono/ChangeLog
index c599f4bfe449..2b28efead9ec 100644
--- a/dev-lang/mono/ChangeLog
+++ b/dev-lang/mono/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/mono
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.117 2007/06/16 11:58:25 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.118 2007/06/25 21:30:23 jurek Exp $
+
+ 25 Jun 2007; Jurek Bartuszek <jurek@gentoo.org> mono-1.1.16.1.ebuild,
+ mono-1.2.2.1.ebuild, mono-1.2.3.1.ebuild, mono-1.2.4.ebuild:
+ Added warnings regarding build failures on systems with active
+ SELinux/PIE+SSP/grsec/PAX and other security enhancements
+ (addressing bug #153781)
16 Jun 2007; Tobias Scherbaum <dertobi123@gentoo.org> mono-1.2.4.ebuild:
ppc stable, bug #181921
@@ -56,7 +62,7 @@
-mono-1.1.18-r1.ebuild, -mono-1.2.ebuild, -mono-1.2.1.ebuild:
Long overdue cleaning of mono ebuilds. 1.1.16.1 left for visual basic
- 14 Jan 2007; Olivier Crête <tester@gentoo.org> mono-1.2.2.1.ebuild:
+ 14 Jan 2007; Olivier CrĂŞte <tester@gentoo.org> mono-1.2.2.1.ebuild:
Stable on amd64 per bug #159886
08 Jan 2007; Tobias Scherbaum <dertobi123@gentoo.org> mono-1.2.2.1.ebuild:
diff --git a/dev-lang/mono/mono-1.1.16.1.ebuild b/dev-lang/mono/mono-1.1.16.1.ebuild
index d38fb8038804..e3b24c78ee6a 100644
--- a/dev-lang/mono/mono-1.1.16.1.ebuild
+++ b/dev-lang/mono/mono-1.1.16.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.1.16.1.ebuild,v 1.3 2007/05/31 19:29:27 jurek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.1.16.1.ebuild,v 1.4 2007/06/25 21:30:23 jurek Exp $
inherit eutils mono flag-o-matic multilib autotools
@@ -79,7 +79,15 @@ src_compile() {
# Force LC_ALL=C and the use of internal mcs/mono to prevent issues with
# I18N.dll (bug #146424)
- LC_ALL=C emake -j1 EXTERNAL_MCS=false EXTERNAL_MONO=false || die "compile failed"
+ LC_ALL=C emake -j1 EXTERNAL_MCS=false EXTERNAL_MONO=false
+
+ if [[ "$?" -ne "0" ]]; then
+ ewarn "If you are using any hardening features such as"
+ ewarn "PIE+SSP/SELinux/grsec/PAX then most probably this is the reason"
+ ewarn "why build has failed. In this case turn any active security"
+ ewarn "enhancements off and try emerging the package again"
+ die
+ fi
}
src_install() {
diff --git a/dev-lang/mono/mono-1.2.2.1.ebuild b/dev-lang/mono/mono-1.2.2.1.ebuild
index a5922a184143..993255fe0af4 100644
--- a/dev-lang/mono/mono-1.2.2.1.ebuild
+++ b/dev-lang/mono/mono-1.2.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.2.2.1.ebuild,v 1.6 2007/01/14 03:00:50 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.2.2.1.ebuild,v 1.7 2007/06/25 21:30:23 jurek Exp $
inherit eutils flag-o-matic multilib autotools
@@ -85,9 +85,19 @@ src_compile() {
# Force the use of monolite mcs to prevent issues with classlibs (bug #118062)
touch ${S}/mcs/build/deps/use-monolite
-
econf ${myconf} || die "configure failed"
- emake || die "compile failed"
+
+ # Force LC_ALL=C and the use of internal mcs/mono to prevent issues with
+ # I18N.dll (bug #146424)
+ LC_ALL=C emake EXTERNAL_MCS=false EXTERNAL_MONO=false
+
+ if [[ "$?" -ne "0" ]]; then
+ ewarn "If you are using any hardening features such as"
+ ewarn "PIE+SSP/SELinux/grsec/PAX then most probably this is the reason"
+ ewarn "why build has failed. In this case turn any active security"
+ ewarn "enhancements off and try emerging the package again"
+ die
+ fi
}
src_install() {
diff --git a/dev-lang/mono/mono-1.2.3.1.ebuild b/dev-lang/mono/mono-1.2.3.1.ebuild
index 2bc2ba48c6ef..7487271605ee 100644
--- a/dev-lang/mono/mono-1.2.3.1.ebuild
+++ b/dev-lang/mono/mono-1.2.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.2.3.1.ebuild,v 1.3 2007/05/31 19:29:27 jurek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.2.3.1.ebuild,v 1.4 2007/06/25 21:30:23 jurek Exp $
inherit eutils flag-o-matic multilib autotools
@@ -90,7 +90,15 @@ src_compile() {
# Force LC_ALL=C and the use of internal mcs/mono to prevent issues with
# I18N.dll (bug #146424)
- LC_ALL=C emake EXTERNAL_MCS=false EXTERNAL_MONO=false || die "compile failed"
+ LC_ALL=C emake EXTERNAL_MCS=false EXTERNAL_MONO=false
+
+ if [[ "$?" -ne "0" ]]; then
+ ewarn "If you are using any hardening features such as"
+ ewarn "PIE+SSP/SELinux/grsec/PAX then most probably this is the reason"
+ ewarn "why build has failed. In this case turn any active security"
+ ewarn "enhancements off and try emerging the package again"
+ die
+ fi
}
src_install() {
diff --git a/dev-lang/mono/mono-1.2.4.ebuild b/dev-lang/mono/mono-1.2.4.ebuild
index 3815f6cc33c8..c277a40a53ef 100644
--- a/dev-lang/mono/mono-1.2.4.ebuild
+++ b/dev-lang/mono/mono-1.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.2.4.ebuild,v 1.6 2007/06/16 11:58:25 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.2.4.ebuild,v 1.7 2007/06/25 21:30:23 jurek Exp $
inherit eutils flag-o-matic multilib autotools
@@ -86,7 +86,15 @@ src_compile() {
# Force LC_ALL=C and the use of internal mcs/mono to prevent issues with
# I18N.dll (bug #146424)
- LC_ALL=C emake EXTERNAL_MCS=false EXTERNAL_MONO=false || die "compile failed"
+ LC_ALL=C emake EXTERNAL_MCS=false EXTERNAL_MONO=false
+
+ if [[ "$?" -ne "0" ]]; then
+ ewarn "If you are using any hardening features such as"
+ ewarn "PIE+SSP/SELinux/grsec/PAX then most probably this is the reason"
+ ewarn "why build has failed. In this case turn any active security"
+ ewarn "enhancements off and try emerging the package again"
+ die
+ fi
}
src_install() {