summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJurek Bartuszek <jurek@gentoo.org>2007-11-03 00:38:41 +0000
committerJurek Bartuszek <jurek@gentoo.org>2007-11-03 00:38:41 +0000
commit2a9dd764cfcf021c7567f93aa43286e1196a1600 (patch)
tree645789caf6f3b1debd7835073d592c2c83f9022f /dev-lang/mono
parentVersion bump. (diff)
downloadgentoo-2-2a9dd764cfcf021c7567f93aa43286e1196a1600.tar.gz
gentoo-2-2a9dd764cfcf021c7567f93aa43286e1196a1600.tar.bz2
gentoo-2-2a9dd764cfcf021c7567f93aa43286e1196a1600.zip
dev-lang/mono: Version bump (bug #197067)
(Portage version: 2.1.3.16)
Diffstat (limited to 'dev-lang/mono')
-rw-r--r--dev-lang/mono/ChangeLog8
-rw-r--r--dev-lang/mono/files/digest-mono-1.2.5.1-r13
-rw-r--r--dev-lang/mono/files/mono-biginteger_overflow.diff22
-rw-r--r--dev-lang/mono/mono-1.2.5.1-r1.ebuild125
4 files changed, 157 insertions, 1 deletions
diff --git a/dev-lang/mono/ChangeLog b/dev-lang/mono/ChangeLog
index 8216656d6b37..a4c46ea4478e 100644
--- a/dev-lang/mono/ChangeLog
+++ b/dev-lang/mono/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/mono
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.127 2007/09/20 23:18:31 jurek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.128 2007/11/03 00:38:41 jurek Exp $
+
+*mono-1.2.5.1-r1 (03 Nov 2007)
+
+ 03 Nov 2007; Jurek Bartuszek <jurek@gentoo.org>
+ +files/mono-biginteger_overflow.diff, +mono-1.2.5.1-r1.ebuild:
+ Version bump (bug #197067)
*mono-1.2.5.1 (20 Sep 2007)
diff --git a/dev-lang/mono/files/digest-mono-1.2.5.1-r1 b/dev-lang/mono/files/digest-mono-1.2.5.1-r1
new file mode 100644
index 000000000000..69021308d2e0
--- /dev/null
+++ b/dev-lang/mono/files/digest-mono-1.2.5.1-r1
@@ -0,0 +1,3 @@
+MD5 dfede0c8c29384a8f8a6953a9bd06224 mono-1.2.5.1.tar.bz2 17492757
+RMD160 8000374d9aaa3149599ba83079959303a6bae014 mono-1.2.5.1.tar.bz2 17492757
+SHA256 434f91032e48c03e1202ba3cef1648e2708eeefcf51143d3547e34acc9c68a96 mono-1.2.5.1.tar.bz2 17492757
diff --git a/dev-lang/mono/files/mono-biginteger_overflow.diff b/dev-lang/mono/files/mono-biginteger_overflow.diff
new file mode 100644
index 000000000000..17d077249e9f
--- /dev/null
+++ b/dev-lang/mono/files/mono-biginteger_overflow.diff
@@ -0,0 +1,22 @@
+--- mcs/class/corlib/Mono.Math/BigInteger.cs 2007-09-19 19:06:06.000000000 +0200
++++ mcs/class/corlib/Mono.Math/BigInteger.cs 2007-10-25 23:46:55.000000000 +0200
+@@ -1607,7 +1607,7 @@
+ uint j = 1;
+
+ // Multiply and add
+- for (; j < m.length; j++) {
++ for (; j < m.length && j < A.length; j++) {
+ c += (ulong)u_i * (ulong)*(mP++) + *(aSP++);
+ *(aDP++) = (uint)c;
+ c >>= 32;
+--- mcs/class/Mono.Security/Mono.Math/BigInteger.cs 2007-07-24 23:48:50.000000000 +0200
++++ mcs/class/Mono.Security/Mono.Math/BigInteger.cs 2007-10-25 23:45:01.000000000 +0200
+@@ -1601,7 +1601,7 @@
+ uint j = 1;
+
+ // Multiply and add
+- for (; j < m.length; j++) {
++ for (; j < m.length && j < A.length; j++) {
+ c += (ulong)u_i * (ulong)*(mP++) + *(aSP++);
+ *(aDP++) = (uint)c;
+ c >>= 32;
diff --git a/dev-lang/mono/mono-1.2.5.1-r1.ebuild b/dev-lang/mono/mono-1.2.5.1-r1.ebuild
new file mode 100644
index 000000000000..ea00bd682afa
--- /dev/null
+++ b/dev-lang/mono/mono-1.2.5.1-r1.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.2.5.1-r1.ebuild,v 1.1 2007/11/03 00:38:41 jurek Exp $
+
+inherit eutils flag-o-matic multilib autotools
+
+DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
+HOMEPAGE="http://www.go-mono.com"
+SRC_URI="http://www.go-mono.com/sources/mono/${P}.tar.bz2"
+
+LICENSE="|| ( GPL-2 LGPL-2 X11 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="X nptl"
+
+RDEPEND="!<dev-dotnet/pnet-0.6.12
+ >=dev-libs/glib-2.6
+ nptl? ( >=sys-devel/gcc-3.3.5-r1 )
+ ppc? (
+ >=sys-devel/gcc-3.2.3-r4
+ >=sys-libs/glibc-2.3.3_pre20040420
+ )
+ X? ( >=dev-dotnet/libgdiplus-1.2.4 )"
+DEPEND="${RDEPEND}
+ sys-devel/bc
+ >=dev-util/pkgconfig-0.19"
+PDEPEND="dev-dotnet/pe-format"
+
+# Parallel build unfriendly
+MAKEOPTS="${MAKEOPTS} -j1"
+
+RESTRICT="test"
+
+function get-memory-total() {
+ cat /proc/meminfo | grep MemTotal | sed -r "s/[^0-9]*([[0-9]+).*/\1/"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Fix the install path, install into $(libdir)
+ sed -i -e 's:$(prefix)/lib:$(libdir):' \
+ -i -e 's:$(exec_prefix)/lib:$(libdir):' \
+ -i -e "s:'mono_libdir=\${exec_prefix}/lib':\"mono_libdir=\$libdir\":" \
+ ${S}/{scripts,mono/metadata}/Makefile.am ${S}/configure.in \
+ || die "sed failed"
+
+ sed -i -e 's:^libdir.*:libdir=@libdir@:' \
+ -i -e 's:${prefix}/lib/:${libdir}/:g' \
+ ${S}/{scripts,}/*.pc.in \
+ || die "sed failed"
+
+ epatch ${FILESDIR}/${PN}-1.2.4-pic.patch || die "patch failed"
+
+ # Remove dummy ltconfig and let libtool handle it
+ rm -f ${S}/libgc/ltconfig
+
+ epatch ${FILESDIR}/mono-biginteger_overflow.diff
+
+ einfo "Regenerating the build files, this will take some time..."
+ eautoreconf
+}
+
+src_compile() {
+ # mono's build system is finiky, strip the flags
+ strip-flags
+
+ # Enable the 2.0 FX, use the system glib and the gc
+ local myconf="--with-preview=yes --with-glib=system --with-gc=included"
+
+ # Threading support
+ if use amd64 || use nptl ; then
+ # force __thread on amd64 (bug #83770)
+ myconf="${myconf} --with-tls=__thread"
+ else
+ myconf="${myconf} --with-tls=pthread"
+ fi
+
+ # Enable large heaps if memory is more than >=3GB
+ if [[ $(get-memory-total) -ge 3145728 ]] ; then
+ myconf="${myconf} --with-large-heap=yes"
+ fi
+
+ # Force the use of monolite mcs to prevent issues with classlibs (bug #118062)
+ touch ${S}/mcs/build/deps/use-monolite
+
+ econf ${myconf} || die "configure failed"
+ emake EXTERNAL_MCS=false EXTERNAL_MONO=false
+
+ if [[ "$?" -ne "0" ]]; then
+ ewarn "If you are using any hardening features such as"
+ ewarn "PIE+SSP/SELinux/grsec/PAX then most probably this is the reason"
+ ewarn "why build has failed. In this case turn any active security"
+ ewarn "enhancements off and try emerging the package again"
+ die
+ fi
+}
+
+src_test() {
+ vecho ">>> Test phase [check]: ${CATEGORY}/${PF}"
+
+ mkdir -p "${T}/home/mono" || die "mkdir home failed"
+
+ export HOME="${T}/home/mono"
+ export XDG_CONFIG_HOME="${T}/home/mono"
+ export XDG_DATA_HOME="${T}/home/mono"
+
+ if ! LC_ALL=C emake -j1 check; then
+ hasq test $FEATURES && die "Make check failed. See above for details."
+ hasq test $FEATURES || eerror "Make check failed. See above for details."
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README
+
+ docinto docs
+ dodoc docs/*
+
+ docinto libgc
+ dodoc libgc/ChangeLog
+}