summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-03-05 16:35:18 +0000
committerPacho Ramos <pacho@gentoo.org>2011-03-05 16:35:18 +0000
commitc0a871e1af280416cb1dfd7578eb3528bb122b21 (patch)
tree052552283fac6b49d4a5721769031fa32a7a119e /dev-lang/mono
parentalpha/arm/ia64/sh stable wrt #354513 (diff)
downloadgentoo-2-c0a871e1af280416cb1dfd7578eb3528bb122b21.tar.gz
gentoo-2-c0a871e1af280416cb1dfd7578eb3528bb122b21.tar.bz2
gentoo-2-c0a871e1af280416cb1dfd7578eb3528bb122b21.zip
Fix building on hardened (bug #347365 by onox). Thanks a lot to Anders Hellgren and Magnus Granberg for their help.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/mono')
-rw-r--r--dev-lang/mono/ChangeLog7
-rw-r--r--dev-lang/mono/mono-2.10.1-r1.ebuild7
-rw-r--r--dev-lang/mono/mono-2.8.2-r1.ebuild7
3 files changed, 14 insertions, 7 deletions
diff --git a/dev-lang/mono/ChangeLog b/dev-lang/mono/ChangeLog
index 7aea15eaf82e..49f8023b653f 100644
--- a/dev-lang/mono/ChangeLog
+++ b/dev-lang/mono/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/mono
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.212 2011/02/27 14:52:48 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.213 2011/03/05 16:35:18 pacho Exp $
+
+ 05 Mar 2011; Pacho Ramos <pacho@gentoo.org> mono-2.8.2-r1.ebuild,
+ mono-2.10.1-r1.ebuild:
+ Fix building on hardened (bug #347365 by onox). Thanks a lot to Anders
+ Hellgren and Magnus Granberg for their help.
*mono-2.10.1-r1 (27 Feb 2011)
diff --git a/dev-lang/mono/mono-2.10.1-r1.ebuild b/dev-lang/mono/mono-2.10.1-r1.ebuild
index 813c202fa099..5b004d95fef9 100644
--- a/dev-lang/mono/mono-2.10.1-r1.ebuild
+++ b/dev-lang/mono/mono-2.10.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-2.10.1-r1.ebuild,v 1.1 2011/02/27 14:52:48 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-2.10.1-r1.ebuild,v 1.2 2011/03/05 16:35:18 pacho Exp $
EAPI="2"
@@ -68,11 +68,12 @@ src_prepare() {
die "Sedding patch file failed"
go-mono_src_prepare
- # we need to sed in the paxctl -m in the runtime/mono-wrapper.in so it don't
+ # we need to sed in the paxctl -mr in the runtime/mono-wrapper.in so it don't
# get killed in the build proces when MPROTEC is enable. #286280
+ # RANDMMAP kill the build proces to #347365
if use hardened ; then
ewarn "We are disabling MPROTECT on the mono binary."
- sed '/exec/ i\paxctl -m "$r/@mono_runtime@"' -i "${S}"/runtime/mono-wrapper.in
+ sed '/exec/ i\paxctl -mr "$r/@mono_runtime@"' -i "${S}"/runtime/mono-wrapper.in
fi
}
diff --git a/dev-lang/mono/mono-2.8.2-r1.ebuild b/dev-lang/mono/mono-2.8.2-r1.ebuild
index aa8b62ff20ef..756879fd6088 100644
--- a/dev-lang/mono/mono-2.8.2-r1.ebuild
+++ b/dev-lang/mono/mono-2.8.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-2.8.2-r1.ebuild,v 1.4 2011/01/29 17:02:55 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-2.8.2-r1.ebuild,v 1.5 2011/03/05 16:35:18 pacho Exp $
EAPI="2"
@@ -68,11 +68,12 @@ src_prepare() {
die "Sedding patch file failed"
go-mono_src_prepare
- # we need to sed in the paxctl -m in the runtime/mono-wrapper.in so it don't
+ # we need to sed in the paxctl -mr in the runtime/mono-wrapper.in so it don't
# get killed in the build proces when MPROTEC is enable. #286280
+ # RANDMMAP kill the build proces to #347365
if use hardened ; then
ewarn "We are disabling MPROTECT on the mono binary."
- sed '/exec/ i\paxctl -m "$r/@mono_runtime@"' -i "${S}"/runtime/mono-wrapper.in
+ sed '/exec/ i\paxctl -mr "$r/@mono_runtime@"' -i "${S}"/runtime/mono-wrapper.in
fi
}